Mailversandeinstellungen (Postfix)

german

#1

Mahlzeit!

Ich habe in letzter immer wieder Mails die nicht versendet werden können…


: Recipient address rejected: Mail appeared to
    be SPAM or forged. Ask your Mail/DNS-Administrator to correct HELO and DNS
    MX settings or to get removed from DNSBLs; MTA helo: testmail.org, MTA
    hostname: static-213-127-93-188.netcologne.de[213.127.93.188]
    (helo/hostname mismatch) (in reply to RCPT TO command)

Wie kann ich den HELO Eintrag mit dem MTA hostname gleichsetzten ?
Gruss Rainer !


#2

Hallo Rainer,

[quote=“ramsoft”]

MTA helo: testmail.org, MTA hostname: static-213-127-93-188.netcologne.de[213.127.93.188]

Wie kann ich den HELO Eintrag mit dem MTA hostname gleichsetzten ?[/quote]
Mittels UCR Variable mail/smtp/helo/name lässt sich der HELO Eintrag ändern. Ihn aber immer an den FQDN der externen IP anzupassen wird schwierig… Wahrscheinlich ist das relayen über den Mail-Rely des ISPs besser.

Gruß
Daniel


#3

Ich versende meine Mali über 1und1 , das ist doch ein Relay oder …
Ich versende nicht meine Mail direct.

Muß ich das bei 1und1 beantragen ?


#4

Hallo,

irgendwie passen die Aussagen nicht oder zeigen etwas Gefiltertes:

Die eingangs zitierte Meldung sieht nach Policyd-Weight aus. Bei einem authentifiziertem Versand (13.8.1. Konfiguration eines Relay-Hosts für den Mailversand) sollte man nie auf so etwas stoßen. Entweder haben Sie das noch nicht richtig eingerichtet oder Ihr Relay ist kaputt.

Die IP-Adressen/DNS-Namen sind hoffentlich frei erfunden. Mein DNS löst 213.127.93.188 jedenfalls anders auf.

Womit man sich bei einer dynamischen Adresse nicht beschäftigen sollte ist jedenfalls das HELO.
Insofern würde ich beim letzten Satz von Daniel gern das “wahrscheinlich” gegen etwas Nachdrücklicheres ersetzen.

hth,
Dirk


#5

IP hab ich etwas verändert, man weiss ja nie wer mitliest.

Die IP ist eine fest vergebene Adresse weil ich diese ausschließlich für das :443 Protokohl ( Zarafa ) nutze.

Ich habe nicht generell dieses Problem, sondern nur bei paar Mailservern…

Hier noch mal die orginale Meldung:

[code]This is the mail system at host ucs-1571.fenestra.org.

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system

info.de@pawlikokna.pl: host mail.pawlikokna.pl[194.181.130.130] said: 550
5.7.1 info.de@pawlikokna.pl: Recipient address rejected: Mail appeared to
be SPAM or forged. Ask your Mail/DNS-Administrator to correct HELO and DNS
MX settings or to get removed from DNSBLs; MTA helo: fenestra.org, MTA
hostname: static-212-117-93-188.netcologne.de[212.117.93.188]
(helo/hostname mismatch) (in reply to RCPT TO command)

Reporting-MTA: dns; ucs-1571.fenestra.org
Original-Envelope-Id: 8e3d7741-4322-dc58-f4d7-e92670741058@fenestra.org
X-Postfix-Queue-ID: EB2EF1FF28E
X-Postfix-Sender: rfc822; rh@fenestra.org
Arrival-Date: Fri, 11 Nov 2016 11:13:34 +0100 (CET)

Final-Recipient: rfc822; info.de@pawlikokna.pl
Original-Recipient: rfc822;info.de@pawlikokna.pl
Action: failed
Status: 5.7.1
Remote-MTA: dns; mail.pawlikokna.pl
Diagnostic-Code: smtp; 550 5.7.1 info.de@pawlikokna.pl: Recipient address
rejected: Mail appeared to be SPAM or forged. Ask your
Mail/DNS-Administrator to correct HELO and DNS MX settings or to get
removed from DNSBLs; MTA helo: fenestra.org, MTA hostname:
static-212-117-93-188.netcologne.de[212.117.93.188] (helo/hostname
mismatch)

Return-Path: rh@fenestra.org
Received: from localhost (localhost [127.0.0.1])
by ucs-1571.fenestra.org (Postfix) with ESMTP id EB2EF1FF28E
for info.de@pawlikokna.pl; Fri, 11 Nov 2016 11:13:34 +0100 (CET)
X-Virus-Scanned: by amavisd-new-2.7.1 (20120429) (Debian) at fendom.intranet
Received: from fenestra.org ([127.0.0.1])
by localhost (ucs-1571.fendom.intranet [127.0.0.1]) (amavisd-new, port 10024)
with ESMTP id dKpbxM2eFYbs for info.de@pawlikokna.pl;
Fri, 11 Nov 2016 11:13:33 +0100 (CET)
Received: from [192.168.0.152] (unknown [192.168.0.152])
by ucs-1571.fenestra.org (Postfix) with ESMTPSA id B3EEA1FF28D
for info.de@pawlikokna.pl; Fri, 11 Nov 2016 11:13:33 +0100 (CET)
Subject: Preisanfrage
References: adaee304-5a94-78b7-c455-55a02937b2be@fenestra.org
To: info.de@pawlikokna.pl
From: "rh@fenestra.org" rh@fenestra.org
X-Forwarded-Message-Id: adaee304-5a94-78b7-c455-55a02937b2be@fenestra.org
Message-ID: 8e3d7741-4322-dc58-f4d7-e92670741058@fenestra.org
Disposition-Notification-To: "rh@fenestra.org" rh@fenestra.org
Date: Fri, 11 Nov 2016 11:13:30 +0100
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101
Thunderbird/45.4.0
MIME-Version: 1.0
In-Reply-To: adaee304-5a94-78b7-c455-55a02937b2be@fenestra.org
Content-Type: multipart/mixed;
boundary="------------CAB34611414F624A5AED4F4F"
[/code]


#6

hier noch die /etc/postfix/main.cf

[code]# The message_size_limit parameter limits the total size in bytes of

a message, including envelope information. Default is 10240000

message_size_limit = 50240000

mailbox_size_limit limits the max. size of local mailboxes. Default is 51200000

mailbox_size_limit = 51200000

some basic path definitions

command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix

some basic mail system settings

myhostname = ucs-1571.fenestra.org

mydomain is unset - The default is to use $myhostname minus the first component.

myorigin = ucs-1571.fendom.intranet
smtp_helo_name = fenestra.org

append_dot_mydomain = no

inet_interfaces = all
inet_protocols = ipv4

mydestination = $myhostname, localhost.$mydomain, localhost
mynetworks = 127.0.0.0/8

masquerade_domains = $mydomain
masquerade_exceptions = root

transport_maps = hash:/etc/postfix/transport

we need to name a smtp relay host to which we forward non-local

mails. smtp authentication is also possible.

smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_password_maps = hash:/etc/postfix/smtp_auth
[/code]


#7

Kann das der Eintrag in der mai.cf sein ?

myorigin = ucs-1571.fendom.intranet

#8

Hallo Ramsoft,

ich hatte das gleiche Problem wie du, auch wir versenden über 1und1.

Bei mir war die Lösung, die UCR-Variable mail/relayhost auf dem Mailserver zu füllen
mit dem Eintrag smtp.1und1.de

Seitdem habe ich keine Probleme mehr gehabt.

Die Variable mail/relayauth muss natürlich dann ebenfalls auf “yes” gesetzt werden
und die smtp_auth muss angepasst werden:

VG,
Oliver Bertgen


#9

Hallo,

u.U. auch mal hilfe-center.1und1.de/e-mail-c8 … 83433.html ansehen und für UCS adaptieren.

Nur für den Fall, dass mal ein Provider auf die Idee kommt, Port 25 von dynamischen Adressen zu blocken…

Viel Erfolg,
Dirk Ahrnke


#10

Mit den Einstellung von 1und1 hat es geklappt.
Ich mußte zwar die EInstellungen direkt in der main.cf ändern, aber ich weiß ja jetzt was ich ändern muß !
Vielen Dank an Alle für eure tolle Unterstützung…

Gruss Rainer !