Mailcow with univention keycloak

As a current user of Kopano, I am starting to test different alternatives now.

My first test is mailcow, which has support for keycloak in its nightly builds now. I hope the feature while hit stable soon. I have currently installed mailcow on a separate ubuntu server, so not as to overcomplicate things (for now).

I have tried the original mailcow post to set up: 🔒🔑 External Identity Providers for User authentication - mailcow: dockerized - Blog
However, when I click “Test connection” i get an error. If I save anyway and try to log in to mailcow, I get “login failed”. However, when I turn on logging in keycloak, the login shows as successful.

Any help would be very welcome to debug the situation further.

UPDATE: I have tested a bit further, working around my certificate problem.

I am giving up on mailcow (for now) because external authentication is not sufficiently supported (for what I have in mind).
Keycloak is in nightly builds, but there are no mail clients that could use that way of authentication. Only web-ui.
Could not get the integrated LDAP to work.
Tried an external LDAP-sync which errored out but already warned, that this does not work for EAS, which I need for smartphones to connect.