Mailabruf

german

#21

Der Befehl heißt ja auch nicht “telnet $(192.168.0.3 -f) 25” sondern “telnet $(hostname -f) 25”. Aber die Ausgabe ist ja nicht mehr so wichtig. Denn offensichtlich gibt es Probleme mit der /etc/postfix/master.cf. Bitte mal ausführen und die Ausgabe posten (und diesmal bitte in Code-Blöcken):

ucr commit /etc/postfix/master.cf
ucr get mail/postfix/inet/interfaces
/etc/init.d/postfix restart

#22

Ich vermute mail/smtpport="".

Bitte führen Sie aus:

ucr search --brief mail/smtpport

Sollte das Ergebnis nicht

mail/smtpport: <empty>

sein (es kommt auf das “” an), dann führen Sie bitte folgendes aus:

ucr unset mail/smtpport /etc/init.d/postfix restart


#23

Hier der Report zu Ihren Anregungen. Danke für die Mühe! Empfang funktioniert jetzt wieder! Es gibt nur immer noch Probleme mit dem Versand, siehe unten Mailfeedback von Strato.

/var/log$ ucr search --brief mail/smtpport
mail/smtpport:
/var/log$ ucr unset mail/smtpport
Unsetting mail/smtpport
Module: zarafa-cfg
Multifile: /etc/postfix/master.cf
/var/log$ /etc/init.d/postfix restart
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.

Jetzt steht Empty drin:
/var/log$ ucr search --brief mail/smtpport
mail/smtpport:

Hier die Verwiegerung der Mailannahme, kann es am “falschen” SMTP Port hängen?
This is the mail system at host local.hss-pietschmann.de.

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system

<meineMail.de>: host smtp.strato.de[81.169.145.133] said: 530 5.7.0 Bitte
konfigurieren Sie ihr E-Mailprogramm fuer Authentifizierung am SMTP Server,
wie auf strato.de/email-hilfe beschrieben. - Please configure your mail
client for using SMTP Server Authentication (in reply to MAIL FROM command)


#24

Um Mails über Stratos SMTP-Relay / Smarthost zu verschicken, muss das Versenden mit Authentifikation eingerichtet werden (der Postfix auf Ihrem Server soll sich bei Strato anmelden, bevor er deren Server Mails zum Versandt übergibt): docs.univention.de/handbuch-4.0. … fig::relay

Gruß
Daniel Tröder


#25

SMTP_AUTH wie im Handbuch beschrieben hatte ich schon abgearbeitet:
mail/relayhost Wert eingetragen: smtp.strato.de
mail/relayauth Wert eingetragen: yes

Datei im Verzeichnis “etc/postfix” mit dem Namen “smtp_auth” angelegt.
Inhalt:
<smtp.strato.de> info@meineDomain.de:

Befehl über Konsole abgesetzt:
postmap /etc/postfix/smtp_auth
Ist es korrekt das keinerlei bestätigung nach dem Ausführen des Befehls kommt? Der Kursor springt nach kurzer Zeit, ohne eine Meldung, einfach eine Zeile weiter.

Feedback nach dem Senden von einer Mail ist das gleiche wie oben. Mailversand funktioniert nich, der Server verweist auf Aktivierung der Authentifikation :frowning:


#26

[quote=“dark957”]SMTP_AUTH wie im Handbuch beschrieben hatte ich schon abgearbeitet:
mail/relayhost Wert eingetragen: smtp.strato.de
mail/relayauth Wert eingetragen: yes

Datei im Verzeichnis “etc/postfix” mit dem Namen “smtp_auth” angelegt.
Inhalt:
<smtp.strato.de> info@meineDomain.de:
[/quote]Die sollte ohne spitze Klammern sein:

smtp.strato.de                      info@meineDomain.de:g3h31m

[quote=“dark957”]Befehl über Konsole abgesetzt:
postmap /etc/postfix/smtp_auth
Ist es korrekt das keinerlei bestätigung nach dem Ausführen des Befehls kommt? Der Kursor springt nach kurzer Zeit, ohne eine Meldung, einfach eine Zeile weiter.[/quote]Keine Rückmeldung heißt unter Linux oft “alles wie erwartet”. Um zu sehen ob es geklappt hat, können Sie schauen ob nun eine Datei /etc/postfix/smtp_auth.db existiert, die als Zeit die vom ausführen des postmap Befehls hat.

[quote=“dark957”]Feedback nach dem Senden von einer Mail ist das gleiche wie oben. Mailversand funktioniert nich, der Server verweist auf Aktivierung der Authentifikation :-([/quote]* Was steht in /var/log/mail.log dazu?

  • Es sollten alle Mails noch in der queue sein. Nachsehen mit “mailq”, löschen mit “postsuper -d QUEUEID” oder “postsuper -d ALL” für alle, erneuten Versandt anstoßen mit “postqueue -f”.
    Zum Testen evtl. alle löschen und ein postfix restart machen und dann das log währende des Sendeversuchs verfolgen.

SMTP Mail Relay per LDAP einrichten
#27

Danke erst mal für die Super Unterstützung!!!

Nachfolgende eine kleine Zusammenfassung des Treads

@ Administrator: Vielleicht kann jemand das hin und her zwischen drin löschen?

Einrichten externen Mailabruf mittels Zarafa VM am Beispiel von Strato:
Benötigte Tools:
z.B. WinSCP funktioniert wie Explorer mit Konsolenfunktion

Anmelden auf die Administratoroberflache mit Benutzername Administrator und dem zuvor festgelegten Passwort.
1.) Erstellen eines Benutzers
Primäremailadresse festlegen z.B. inof@meineDomain.de
Reiter erweiterte “Erweiterte Einstellungen” klicken
Mailabruf von externen Servern klicken
Daten des Providers eintragen: Benutzernamen, Passwort, gewünschte Abruf Art IMAP, POP3 & im Feld “SSL/TLS Verbindung” Haken setzen.

Starten der Univention Configuration Registry.
Unter Schlüsselwort nach den nachfolgende Einträgen suchen und entsprechende Werte setzen:
relayauth: yes
relayhost: smtp.strato.de

Mit WinSCP am Server als root Benutzer anmelden:
Im Verzeichnis /etc/postfix/ eine Datei Names smtp_auth anlegen.

Datei mit nachfolgenden Inhalt füllen (Benutzername und Passwort vom Provider):
smpt.strato.de MeinBenutzername:MeinPasswort

WinSCP Konsole starten und nachfolgenden Befehl eingeben:
postmap /etc/postfix/smtp_auth

Wenn alles funktioniert hat, ist jetzt eine Datei Names smtp_auth.db im Verzeichnis zu finden.

Zustätzliche Änderungen welche nicht zwingen sind aber nützlich:
Abrufinterval ändern: Dazu im nachfolgenden Verzeichnis die Datei fechmailrc öffnen und den Wert 1200 (es handelt sich um Sekunden (20min) auf den gewünschten setzten):
/etc/fetchmailrc
z.B. set daemon <60>

ntp Zeitserver setzen in Univention Configuration Registry (UCS) wenn es mit der Zeit durcheinander geht:
timeserver: ntp1.t-online.de

Logs zur Fehlersuche sind hier zu finden:
/var/log/mail.err
/var/log/mail.log
/var/log/mail.info

Nützliche Befehle:
ucr search --brief mail/smtpport

Feedback sollte sein:
mail/smtpport:

Zurücksetzten erfolgt mit:
ucr unset mail/smtpport

Neustart von Postfix:
/etc/init.d/postfix restart


#28

Hallo,

nur noch ein kleiner Hinweis zum Abrufintervall. Man kann das gern auf 60 Sekunden stellen, aber man kann sich damit auch die Karten legen. Ich hole meine Mails (bei unterschiedlichen Providern, unter anderem web.de und gmx) auch mit Fetchmail ab, und wenn ich ein Intervall unter 10 Minuten (600 Sekunden) einstelle, sehe ich im Log immer zwischendurch Login-Fehler, und nach einer Weile geht es dann wieder.
Hatte es sogar mal eine Weile geschafft, daß mich GMX wegen meiner zu häufigen Logins zeitweise ganz ausgesperrt hat. Also Vorsicht mit zu kurzen Intervallen; im Zweifelsfall nochmal die Doku/AGB des Hosters lesen.

viele Grüße
Frank Greif.


#29

Hallo Herr Ahrnke,

leider beutelt es mich jetzt komplett (evtl. auch im Zusammenhang mit meinem Nagios-Problem).
Bei mir tritt derselbe Fehler (Abholen der Mail unmöglich) mit den gleichen Fehlermeldung auf.
Ein Horchen auf Port 25 mit netstat -tlpn | grep :25

root@server:/etc/init.d# netstat -tlpn | grep :25
tcp6 0 0 :::2501 :::* LISTEN 4288/java

An den Einstellung wurd nichts verändert.
Gibt es eine Möglichkeit, dass Fetchmail wieder auch Port 25 lauscht?

Kann es vielleicht sein, dass ich ein IPv6-Problem habe?

Viele Grüße
Stephan Thul

[quote=“ahrnke”]Hallo,

den Logs ist lediglich zu entnehmen, dass Fetchmail nicht, wie üblich an Postfix via 127.0.0.1:25 zustellen kann. In der Standardeinstellung “lauscht” Postfix auf allen IP-Adressen inklusive localhost:

# netstat -tlpn | grep :25 tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 3403/master

Eine mögliche Ursache könnte eine vorherige Modifikation von “mail/postfix/inet/interfaces” (Default: ‘all’) sein. Bitte schauen Sie zunächst, welche Änderungen an UCR-Variablen vorgenommen wurden. UCS protokolliert das in /var/log/univention/config-registry.replog*.

Ein weiterer Anhaltspunkt könnte mail.log oder mail.err zum Startzeitpunkt von postfix liefern. Dies wäre der Fall, wenn sich vorher irgendein anderer Dienst niedergelassen hat. Das dürfte man aber auch schon mit dem o.g. netstat Befehl sehen.

Viele Grüße,
Dirk Ahrnke[/quote]


#30

Hallo

[quote=“StephanT”]…
Bei mir tritt derselbe Fehler (Abholen der Mail unmöglich) mit den gleichen Fehlermeldung auf.
Ein Horchen auf Port 25 mit netstat -tlpn | grep :25

root@server:/etc/init.d# netstat -tlpn | grep :25
tcp6 0 0 :::2501 :::* LISTEN 4288/java

[/quote],

fetchmail versucht,in der Standardkonfiguration, die Mails zum lokalen Postfix zuzustellen. Dieser sollte eigentlich auf Port 25 Verbindungen annehmen, was aber hier nicht der Fall ist.
Wenn keine Konfigurationsänderungen vorliegen, würde ich zunachst mal Postfix starten (/etc/init.d/postfix start) und - falls sich nichts ändert, mal nachsehen, was in /var/log/mail.log bzw mail.err zu sehen ist.

Viele Grüße,
Dirk Ahrnke


#31

Hallo,

ich habe jetzt den postfix wieder gestartet.

In /var/log/mail.info steht:
[color=#FF0000]Aug 3 18:41:12 server postfix/postfix-script[4148]: starting the Postfix mail system
Aug 3 18:41:12 server postfix/master[4149]: fatal: bind 0.0.0.0 port 587: Address already in use

[/color]In /var/log/mail.err steht:
Aug 3 18:41:12 server postfix/master[4149]: fatal: bind 0.0.0.0 port 587: Address already in use

In /var/log/mail.log steht ebenfalls:
Aug 3 18:41:12 server postfix/postfix-script[4148]: starting the Postfix mail system
Aug 3 18:41:12 server postfix/master[4149]: fatal: bind 0.0.0.0 port 587: Address already in use

Auf Port 587 ist ein Java-Prozess aktiv:
root@server:/etc/init.d# netstat -tlpn | grep :587
tcp6 0 0 :::587 :::* LISTEN 4288/java

Nachdem ich die zugehörige Anwendung (agorum) gestoppt habe, funktioniert der Mailverkehr lt. log-File wieder.

Nach einem Neustart von Agorum funktioniert wieder alles.

Vielen Dank trotzdem
Stephan Thul


#32

ok, also dieses Problem: Nach Update auf UCS 4: Postfix läuft nicht mehr.
Workaround an Ende des Threads.


#33

Hallo, habe ein Problem mit Mailversand und jetzt leider auch mit dem Mailabruf. Mailabruf soll per pop3 (Port: TLS 110, SSL 995) und Versand über SMTP (TLS 25, SSL 465, 587) über alfa3xxx.alfahosting-server.de gehen. Zum Versand gibt es zu sagen, dass die Webapp erfolgreichen Versand meldet aber die Mail im Postausgang liegen bleibt. Hier die Logs:

Log Mail.err
Benutzer eingerichtet aber scheinbar gibt es ein Problem mit dem Postfix:
Nov 2 21:32:26 mail fetchmail[1693]: Nachricht xxxxxp4@alfa3xxx.alfahosting-server.de:673 von 677 wird gelesen (189480 Bytes) (Log-Meldung unvollständig)
Nov 2 21:32:26 mail fetchmail[1693]: Verbindungsfehler für diesen Abruf:#012Name 0: Verbindung zu localhost:smtp [::1/25] fehlgeschlagen: Verbindungsaufbau abgelehnt.#012Name 1: Verbindung zu localhost:smtp [127.0.0.1/25] fehlgeschlagen: Verbindungsaufbau abgelehnt.
Nov 2 21:32:26 mail fetchmail[1693]: SMTP-Verbindung zu localhost fehlgeschlagen
Nov 2 21:32:26 mail fetchmail[1693]: SMTP-Transaktion-Fehler beim Abholen von xxxxxp4@alfa3xxx.alfahosting-server.de und Auslieferung zum SMTP-Host localhost

Log Mail.info
Nov 2 21:42:32 mail fetchmail[1693]: 677 Nachrichten (672 gesehene) für xxxxxp4 bei alfa3xxx.alfahosting-server.de (366760436 Bytes).
Nov 2 21:42:32 mail fetchmail[1693]: Nachricht xxxxxp4@alfa3xxx.alfahosting-server.de:673 von 677 wird gelesen (189480 Bytes) (Log-Meldung unvollständig)
Nov 2 21:42:32 mail fetchmail[1693]: Verbindungsfehler für diesen Abruf:#012Name 0: Verbindung zu localhost:smtp [::1/25] fehlgeschlagen: Verbindungsaufbau abgelehnt.#012Name 1: Verbindung zu localhost:smtp [127.0.0.1/25] fehlgeschlagen: Verbindungsaufbau abgelehnt.
Nov 2 21:42:32 mail fetchmail[1693]: SMTP-Verbindung zu localhost fehlgeschlagen
Nov 2 21:42:32 mail fetchmail[1693]: SMTP-Transaktion-Fehler beim Abholen von xxxxxp4@alfa3203.alfahosting-server.de und Auslieferung zum SMTP-Host localhost
Nov 2 21:42:32 mail fetchmail[1693]: Abfragestatus=10 (SMTP)

Wäre super wenn jemand helfen kann. Danke!


#34

Hat keiner einen Workaround oder einen Idee zur Fehlersuche?


#35

Vielleicht hätte dein Frage mehr Aufmerksamkeit bekommen, wenn du einen eigenen Thread erstellt hättest, statt auf eine drei Jahre alte Diskussion zu antworten.

Das auffällige ist hier das auf localhost nichts auf Port 25 lauscht. Läuft Postfix?


#36

Hallo fbartels,
danke für deine Anregung hat scheinbar am Postfix geklemmt. woran hast du das erkannt?

Habe am postfix etwas rumgespielt. Sieht jetzt wieder gut aus. Mails kommen wieder an:

/var/log$ ucr search --brief mail/smtpport
mail/smtpport: 
/var/log$ ucr unset mail/smtpport
Unsetting mail/smtpport
Module: kopano-cfg
Multifile: /etc/postfix/master.cf
/var/log$ /etc/init.d/postfix restart
Restarting postfix (via systemctl): postfix.service.
/var/log$ service postfix status
● postfix.service - Postfix Mail Transport Agent
   Loaded: loaded (/lib/systemd/system/postfix.service; enabled; vendor preset: enabled)
   Active: active (exited) since Fri 2018-11-09 08:10:09 CET; 25s ago
  Process: 7452 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 7452 (code=exited, status=0/SUCCESS)
      CPU: 1ms

Nov 09 08:10:09 mail systemd[1]: Starting Postfix Mail Transport Agent...
Nov 09 08:10:09 mail systemd[1]: Started Postfix Mail Transport Agent..

Jetzt klemmt die Säge noch beim Versand:

Nov 9 08:13:56 mail postfix/smtp[7669]: warning: database /etc/postfix/tls_policy.db is older than source file /etc/postfix/tls_policy

Nov 9 08:14:00 mail postfix/smtp[7669]: 5BD81303595: to=&lt;xxxx@arcor.de&gt;, relay=alfaxxx3.alfahosting-server.de[109.237.138.49]:25, delay=3.7, delays=0.04/0.04/3.7/0, dsn=4.7.8, status=deferred (SASL authentication failed; server alfaxxx3.alfahosting-server.de[109.237.138.49] said: 535 5.7.8 Error: authentication failed: )

Kannst du da etwas erkennen was bei der Autentifikation schief läuft?
Benutzernamen und PW ist richtig angelegt:
smtp_auth eingebunden
relayauth yes
smtps_sasl_auth_enable: yes
smtpd_tls_wrappermode: yes
smtpd_enforce: yes
smtps_sasl_auth_enable:
smtpport: leer

relayhost: alfaxxx3.alfahosting-server.de

Ich kann keinen Fehler erkennen :frowning:


#37

das war recht offensichtlich, da nichts auf Port 25 geantwortet hat.

Nein, da kann ich nicht helfen. Ich habe mir die Relay Settings für Postfix in Univention noch nicht ansehen müssen. Ich würde empfehlen ein neues Topic dafür aufzumachen.