Mailabruf bei live.com

mail
german

#1

Hallo,

ich habe ein paar Postfächer auf Hotmail/Outlook.com/Live.de und möchte diese nun abholen und getrennte Postfächer von Zarafa stecken.

Habe mir eine entsprechende Anzahl von “non-active Konten” angelegt

In der fetchmailrc ist folgendes eingetragen (manuell):

poll pop-mail.live.com with proto POP3 service 995 auth password user 'xxxxxx@hotmail.com' there with password 'xxxxxxxx' is 'ms_xxxxxx@mydomain.lan' here keep sslproto tls1 ssl #UID='ms_xxxxxxx'

Leider klappt das Abholen nicht. Es kommt folgende Fehlermeldung:

Jan  6 08:55:32 ucs002090 fetchmail[3001]: POP3-Verbindung zu pop-mail.live.com fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen
Jan  6 08:55:32 ucs002090 fetchmail[3001]: Abfragestatus=2 (SOCKET)

Hat jemand eine Beschreibung, wie man über POP3 die Mails abholen kann, die von den MS-Diensten gehostet werden?

Vielen Dank im Vorraus

LG
Michael


#2

Der Abruf von Mails per POP3 muss im Webmail zuerst erlaubt werden: windows.microsoft.com/de-de/wind … e-from-app

  1. Melden Sie sich bei Ihrem Outlook.com-Konto an.
  2. Klicken Sie auf das Symbol „Optionen“ Symbol „Optionen“ und dann auf Optionen.
  3. Klicken Sie unter Konto verwalten auf Geräte und Apps über POP verbinden.
  4. Wählen Sie unter POP die Option Aktivieren aus (evtl. das Löschen erlauben).
  5. Klicken Sie auf Speichern.

Dann funktioniert es für mich mit mit:

fetchmail --check --nodetach --protocol POP3 --all --keep --ssl --port 995 --username dtroeder3@outlook.de pop3.live.com

#3

Vielen dann für den link. Diese Option habe ich heute morgen aktiviert. Kann es sein, dass es eine Zeit dauert bis es aktiv ist?

Ich würde gern den Abruf über die fetchmailrc steuern. Du ruft ihn als direktes Kommando auf, oder?

Aber es ist schon mal gut zu wissen, dass es geht. Danke


#4

[quote=“MyKey0815”]Diese Option habe ich heute morgen aktiviert. Kann es sein, dass es eine Zeit dauert bis es aktiv ist?[/quote]Das kann sein. Bei mir hat es sofort geklappt.

[quote=“MyKey0815”]Ich würde gern den Abruf über die fetchmailrc steuern. Du ruft ihn als direktes Kommando auf, oder?[/quote]Ich habe das nur zu Testzwecken getan. Versuche es am Besten auch ertsmal an der Kommandozeile (mit -v | --verbose). Wenn das klappt, dann wende dich der fetchmailrc zu.


#5

Das ist eine gute Idee. Leider klappt es bei mir nicht.

[code] fetchmail -vvv --check --nodetach --protocol POP3 --all --keep --ssl --port 995 --username anmichael@hotmail.com pop-mail.live.com
fetchmail: WARNUNG: Vom Betrieb mit root-Rechten wird abgeraten.
Alte UID-Liste aus pop-mail.live.com:
Leere UID-Liste:
Geben Sie das Passwort für anmichael@hotmail.com@pop-mail.live.com ein:
fetchmail: --check eingeschaltet, hole keine Mail
fetchmail: 6.3.21 fragt pop-mail.live.com ab (Protokoll POP3) um Mi 06 Jan 2016 14:20:58 CET: Abfrage gestartet
Versuche, mit 65.55.60.123/995 zu verbinden…Verbindung fehlgeschlagen.
fetchmail: Verbindung zu pop-mail.live.com:995 [65.55.60.123/995] fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen.
fetchmail: Verbindungsfehler für diesen Abruf:
Name 0: Verbindung zu pop-mail.live.com:995 [65.55.60.123/995] fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen.
POP3-Verbindung zu pop-mail.live.com fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen
fetchmail: 6.3.21 fragt ab pop-mail.live.com (Protokoll POP3) um Mi 06 Jan 2016 14:23:05 CET: Abfrage beendet
Vereinigte UID-Liste aus pop-mail.live.com:
fetchmail: normale Beendigung, Status 2

[/code]

In der mail.log wird nichts geschrieben

Kann es daran liegen, das circa +8000 Mails in dem Postfach liegen?


#6

Jetzt kommts aber dicke :wink:

Wenn ich in mein Hotmail-Konto auf die Optionen gehe, dann steht da “pop-mail.live.com” = damit geht es nicht.

Wenn ich aber als Mail-Server “pop3.live.com” verwende (wie in deinem Beispiel), dann kommen die Mails rein.

Super!!! - Danke für deine Hilfe