Mail Server nicht erreichbar

german

#1

Hallo,

seit einer Stunde macht der Mailserver problem, er ist nämlich nicht mehr verfügbar. Auch das Univention Webinterface ist nicht erreichbar.

Hier mal ein paar logs und Meldungen:

Feb 19 17:46:11 dmoeko postfix/qmgr[1956]: 657E72BE4F3: to=<kaireit@gri-bremen.de>, relay=none, delay=1, status=deferred (delivery temporarily suspended: connect to /var/run/cyrus/socket/lmtp[/var/run/cyrus/socket/lmtp]: No such file or directory)
Feb 19 17:46:11 dmoeko postfix/qmgr[1956]: 6708B2BD465: removed
top
1796 cyrus     18   0 23964  13m  13m D 13.7  0.7   0:53.16 ctl_cyrusdb
  180 root      10  -5     0    0    0 S  0.3  0.0   0:00.74 kswapd0

Auch der Speicherverbrauch von cyrus erscheint mir sehr hoch.

root@dmoeko:~# cat /root/var.txt | grep G
3,8G    /var/log/samba
4,0G    /var/log
1,4G    /var/lib/samba/deploy/software/haufe
1,5G    /var/lib/samba/deploy/software
1,5G    /var/lib/samba/deploy
1,5G    /var/lib/samba
9,7G    /var/lib/cyrus/db
1,2G    /var/lib/cyrus/log/geile@oekonet-bremen.de
3,2G    /var/lib/cyrus/log
13G     /var/lib/cyrus
1,7M    /var/lib/univention-client-root/usr/share/locale/de/LC_MESSAGES
32K     /var/lib/univention-client-root/usr/share/perl5/Debconf/Element/Gnome
52K     /var/lib/univention-client-root/usr/share/perl/5.8.4/Getopt
76K     /var/lib/univention-client-root/usr/share/perl/5.8.4/CGI
16K     /var/lib/univention-client-root/usr/share/keymaps/i386/fgGIod
24K     /var/lib/univention-client-root/usr/lib/perl/5.8.4/auto/File/Glob
48K     /var/lib/univention-client-root/usr/lib/perl/5.8.4/auto/GDBM_File
100K    /var/lib/univention-client-root/usr/lib/GConf/2
104K    /var/lib/univention-client-root/usr/lib/GConf
104K    /var/lib/univention-client-root/usr/X11R6/lib/X11/locale/el_GR.UTF-8
2,1G    /var/lib/univention-server-cdrom/packages
2,1G    /var/lib/univention-server-cdrom
68K     /var/lib/univention-client-devices/thintest/vmware-tools-distrib/lib/modules/binary/bld-2.4.18-5-smp64G-TL80S/objects
76K     /var/lib/univention-client-devices/thintest/vmware-tools-distrib/lib/modules/binary/bld-2.4.18-5-smp64G-TL80S
68K     /var/lib/univention-client-devices/thintest/vmware-tools-distrib/lib/modules/binary/smp-2.4.18-17.i586smp64G-TL1077262098/objects
76K     /var/lib/univention-client-devices/thintest/vmware-tools-distrib/lib/modules/binary/smp-2.4.18-17.i586smp64G-TL1077262098
4,0K    /var/lib/squidguard/squidGuardRobot
17G     /var/lib
22G     /var/

Dann habe ich festgestellt, dass auch der apache nach einem restart des Servers nicht startet

root@dmoeko:~# /etc/init.d/apache start
Configuration syntax error detected. Not reloading.

fopen: No such file or directory
apache: could not open document config file /etc/apache/conf.d/nagios2.conf

Naja, hatte da mal versucht nagios zu installieren, was aber seinerzeit nicht ganz sauber ging.

Der Deinstallationversuch von Nagios scheitert wie folgt:

root@dmoeko:~# apt-get remove nagios2 nagios2-common nagios2-doc nagios-plugins-basic
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Paket nagios2 ist nicht installiert, wird also auch nicht entfernt
Paket nagios2-doc ist nicht installiert, wird also auch nicht entfernt
Paket nagios-plugins-basic ist nicht installiert, wird also auch nicht entfernt
Die folgenden Pakete werden ENTFERNT:
  nagios2-common
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 10 nicht aktualisiert.
Es müssen 0B Archive geholt werden.
Nach dem Auspacken werden 758kB Plattenplatz freigegeben sein.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 96766 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne nagios2-common ...
dpkg: Fehler beim Bearbeiten von nagios2-common (--remove):
 Unterprozess pre-removal script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 nagios2-common
Reading Package Lists... Done
Building Dependency Tree... Done
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@dmoeko:~#

root@dmoeko:~# dpkg --purge --force-depends nagios2-common
(Lese Datenbank ... 96766 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne nagios2-common ...
dpkg: Fehler beim Bearbeiten von nagios2-common (--purge):
 Unterprozess pre-removal script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 nagios2-common
root@dmoeko:~# dpkg -l | grep nagios
rc  nagios-common  1.3-cvs.200504 A host/service/network monitoring and manage
rc  nagios-nrpe-pl 2.5.1-3.3.2007 Nagios Remote Plugin Exectutor Plugin
rc  nagios-nrpe-se 2.5.1-3.3.2007 Nagios Remote Plugin Exectutor Server
rc  nagios-plugins 1.4.5-1.10.200 Plugins for the nagios network monitoring an
rc  nagios-plugins 1.4.5-1.10.200 Plugins for the nagios network monitoring an
pi  nagios2-common 2.5-3.5.200703 support files for nagios2

Wie bekomme ich alles wieder richtig zum Laufen? Danke vorab.

MfG


#2

Eine wichtige Meldung habe ich da noch vergessen

root@dmoeko:~# tail -f /var/log/mail.err
Feb 19 17:18:46 dmoeko amavis[1690]: nss_ldap: could not search LDAP server - Server is unavailable
Feb 19 17:39:42 dmoeko amavis[1651]: nss_ldap: could not search LDAP server - Server is unavailable
Feb 19 18:12:37 dmoeko amavis[1652]: nss_ldap: could not search LDAP server - Server is unavailable

Der Apache läuft so halb wieder, nachdem ich die /etc/apache/con.d/nagios2.conf gelöscht habe. Es bleibt im log aber noch diese Meldung:

[Tue Feb 19 19:21:54 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Tue Feb 19 19:22:17 2008] [error] [client 192.168.2.86] File does not exist: /var/lib/univention-server-cdrom/packages/Release
[Tue Feb 19 19:26:39 2008] [notice] SIGHUP received.  Attempting to restart
[Tue Feb 19 19:26:39 2008] [warn] NameVirtualHost dmoeko.gri-oekonet.de:443 has no VirtualHosts
[Tue Feb 19 19:26:42 2008] [notice] Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-16.97.200705030932 mod_auth_pam/1.1.1 mod_ssl/2.8.22 OpenSSL/0.9.7e configured -- resuming normal operations
[Tue Feb 19 19:26:42 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)

Das Admin-Webinterface ist erreichbar. Man kann sich auch einloggen, nur Horde teilt mit, dass Benutzername und/oder Oasswort falsch seien.

/usr/lib/cyrus/bin/reconstruct

hat nichts gebracht.

Merkwürdig dass ctl_cyrusdb teilweise bis zu 90% CPU frisst.

Nach dem Versuch des reconstructs kommt:

Feb 19 19:57:41 dmoeko amavis[1655]: nss_ldap: could not search LDAP server - Server is unavailable
Feb 19 19:59:33 dmoeko master[1770]: process 1806 exited, signaled to death by 11
Feb 19 19:59:33 dmoeko cyrus/cyr_expire[2361]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 19 19:59:33 dmoeko cyrus/cyr_expire[2361]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 19 19:59:34 dmoeko master[1770]: process 2361 exited, status 1
Feb 19 19:59:34 dmoeko cyrus/tls_prune[2362]: DBERROR: opening /var/lib/cyrus/tls_sessions.db: Invalid argument
Feb 19 19:59:34 dmoeko cyrus/tls_prune[2362]: DBERROR: opening /var/lib/cyrus/tls_sessions.db: cyrusdb error
Feb 19 19:59:34 dmoeko master[1770]: process 2362 exited, status 1

Ist das kritisch? Zugriff auf die E-Mail Konten geht jetzt wieder, auch über Horde.


#3

So ganz rund läuft die Geschichte leider immer noch nicht.
/var/log/mail.err meldet

Feb 19 21:55:55 dmoeko cyrus/lmtpunix[26749]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 19 21:55:55 dmoeko cyrus/lmtpunix[26750]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 19 21:55:55 dmoeko cyrus/lmtpunix[26750]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 19 21:55:55 dmoeko cyrus/lmtpunix[26750]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 19 21:55:55 dmoeko cyrus/lmtpunix[26751]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 19 21:55:55 dmoeko cyrus/lmtpunix[26751]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 19 21:55:55 dmoeko cyrus/lmtpunix[26751]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26752]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26752]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26752]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26753]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26753]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26753]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26754]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26754]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26754]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26755]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26755]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 19 21:55:56 dmoeko cyrus/lmtpunix[26755]: FATAL: lmtpd: unable to init duplicate delivery database

und aus dem syslog

Feb 19 22:10:04 dmoeko cyrus/ctl_cyrusdb[30027]: checkpointing cyrus databases
Feb 19 22:10:04 dmoeko cyrus/notify[30028]: executed
Feb 19 22:10:04 dmoeko cyrus/ctl_cyrusdb[30027]: archiving database file: /var/lib/cyrus/annotations.db
Feb 19 22:10:04 dmoeko cyrus/ctl_cyrusdb[30027]: archiving log file: /var/lib/cyrus/db/log.0000001005
Feb 19 22:10:04 dmoeko cyrus/ctl_cyrusdb[30027]: archiving database file: /var/lib/cyrus/mailboxes.db
Feb 19 22:10:04 dmoeko cyrus/ctl_cyrusdb[30027]: archiving log file: /var/lib/cyrus/db/log.0000001005
Feb 19 22:10:04 dmoeko cyrus/ctl_cyrusdb[30027]: done checkpointing cyrus databases
Feb 19 22:10:04 dmoeko master[30023]: process 30027 exited, status 0
Feb 19 22:12:14 dmoeko master[30041]: about to exec /usr/lib/cyrus/bin/pop3d
Feb 19 22:12:14 dmoeko cyrus/pop3s[30041]: executed
Feb 19 22:12:14 dmoeko cyrus/pop3s[30041]: accepted connection
Feb 19 22:12:14 dmoeko cyrus/pop3s[30041]: DBERROR operation not permitted during recovery: operation not permitted during recovery
Feb 19 22:12:14 dmoeko cyrus/pop3s[30041]: DBERROR: opening /var/lib/cyrus/tls_sessions.db: Invalid argument
Feb 19 22:12:14 dmoeko cyrus/pop3s[30041]: DBERROR: opening /var/lib/cyrus/tls_sessions.db: cyrusdb error
Feb 19 22:12:14 dmoeko cyrus/pop3s[30041]: starttls: TLSv1 with cipher AES256-SHA (256/256 bits new) no authentication
Feb 19 22:12:14 dmoeko cyrus/pop3s[30041]: login: [192.168.2.87] geile@oekonet-bremen.de PLAIN+TLS User logged in

Für eine schnelle Hilfe wäre ich dankbar.


#4

Der Versand über Horde funktioniert, nur die Nutzung des MUC nicht.

/var/lib/cyrus sieht so aus:

drwxr-x---  12 cyrus mail   4096 2008-02-20 09:08 .
drwxr-xr-x  56 root  root   4096 2007-12-19 11:34 ..
-rw-------   1 cyrus mail   4388 2008-02-20 09:02 annotations.db
-rw-rw----   1 cyrus mail   4308 2007-03-16 14:35 cert.pem
drwx------   2 cyrus mail   4096 2008-02-19 23:08 db
drwx------   2 cyrus mail   4096 2008-02-20 09:08 db.backup1
drwx------   2 cyrus mail   4096 2008-02-20 08:38 db.backup2
-rw-rw-rw-   1 cyrus mail 991232 2008-02-19 22:03 deliver.db
drwx------   4 cyrus mail   4096 2008-02-20 09:02 domain
drwx------  34 cyrus mail   4096 2007-11-16 11:37 log
-rw-------   1 cyrus mail  10940 2008-02-20 09:02 mailboxes.db
drwx------   2 cyrus mail   4096 2007-03-16 13:33 msg
-rw-rw----   1 cyrus mail    887 2007-03-16 14:35 private.key
drwx------   2 cyrus mail   4096 2008-02-20 09:25 proc
drwx------  28 cyrus mail   4096 2007-03-16 13:33 quota
drwxr-x---   2 cyrus mail   4096 2007-09-06 13:12 socket
-rw-rw-rw-   1 cyrus mail  24576 2008-02-19 19:55 tls_sessions.db
drwx------  28 cyrus mail   4096 2007-03-16 13:33 user
root@dmoeko:/var/lib/cyrus#

Da zwischenzeitlich Fehler mit tls_session.db auftauchten, hatte ich die Vermutung, dass etwas mit den in /etc/imapd.conf angegeben Zertifikaten evt. nicht in Ordnung ist. Wie kann man das überprüfen?

Die derzeitigen Meldungen aus /var/log/mail.err shen so aus:

Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7085]: executed
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7085]: DBERROR operation not permitted during recovery: operation not permitted during recovery
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7085]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7085]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7085]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 20 09:15:31 dmoeko master[9714]: process 7085 exited, status 75
Feb 20 09:15:31 dmoeko master[9714]: service lmtpunix pid 7085 in READY state: terminated abnormally
Feb 20 09:15:31 dmoeko master[7086]: about to exec /usr/lib/cyrus/bin/lmtpd
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7086]: executed
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7086]: DBERROR operation not permitted during recovery: operation not permitted during recovery
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7086]: DBERROR: opening /var/lib/cyrus/deliver.db: Invalid argument
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7086]: DBERROR: opening /var/lib/cyrus/deliver.db: cyrusdb error
Feb 20 09:15:31 dmoeko cyrus/lmtpunix[7086]: FATAL: lmtpd: unable to init duplicate delivery database
Feb 20 09:15:31 dmoeko master[9714]: process 7086 exited, status 75
Feb 20 09:15:31 dmoeko master[9714]: service lmtpunix pid 7086 in READY state: terminated abnormally
Feb 20 09:15:31 dmoeko master[7087]: about to exec /usr/lib/cyrus/bin/lmtpd

Diese Meldungen laufen endlos.


#5

Dann werde ich mal den Monolog weiterführen und die Lösung des Problems mitteilen:

/etc/init.d/cyrus22 stop
cd /var/lib/cyrus
rm deliver.db
rm tls_sessions.db
rm db/*
etc/init.d/cyrus22 start

#6

Nach der ganzen Aktion funktioniert die globale Spamverteilung nicht mehr:

root@dmoeko:~# univention-baseconfig get mail/antispam/globalfolder
spam@oekonet-bremen.de
root@dmoeko:~#

root@dmoeko:~# univention-baseconfig get mail/antispam
yes
root@dmoeko:~#


root@dmoeko:~# univention-baseconfig get mail/antivir
yes
root@dmoeko:~#

Die Anzahl der Spammails ist gestiegen und sie werden auch nicht mehr in dem globalen spamaccount gespeichert.


#7

Hallo,

sorry für die späte Antwort.

Wie ist der Status? Funktioniert die Spamerkennung wieder?

Viele Grüße
Stefan Gohmann


#8

Hallo,

die Erkennung schon, aber die Verteilung in den globalen SpamAccount Ordener nicht.

MfG


#9

Hallo,

sind Hinweise in der syslog/mail.log zu finden, während der Spam-Mailzustellung bzw. der Weiterleitung an den globalen Spam-Account? Was passiert derzeit mit den Spam-Mails? Werden diese zu den Benutzern zugestellt?

Die Weiterleitung an den globalen Spam-Account erfolgt per sieve-Skripte.

Welche UCS Version ist im Einsatz?

Viele Grüße
Stefan Gohmann


#10

Es ist UCS 1.3.2 im Einsatz.

Es gibt im LOG keine speziellen Hinweise

Mar  3 14:40:53 dmoeko spamd[31358]: prefork: child states: BB
Mar  3 14:40:53 dmoeko spamd[31358]: spamd: server successfully spawned child process, pid 12561
Mar  3 14:40:53 dmoeko spamd[7051]: spamd: connection from localhost [127.0.0.1] at port 56716
Mar  3 14:40:53 dmoeko spamd[12561]: spamd: connection from localhost [127.0.0.1] at port 56717
Mar  3 14:40:53 dmoeko spamd[31358]: prefork: child states: BBB
Mar  3 14:40:53 dmoeko spamd[12561]: spamd: setuid to nobody succeeded
Mar  3 14:40:53 dmoeko spamd[31358]: spamd: server successfully spawned child process, pid 12562
Mar  3 14:40:53 dmoeko spamd[7051]: spamd: setuid to nobody succeeded
Mar  3 14:40:53 dmoeko spamd[12561]: spamd: processing message <E4CB65DF7CB0D6408162AF421DADF7EA1454E2@arbeit05.arbeit-bremen.local> for nobody:65534
Mar  3 14:40:53 dmoeko spamd[7051]: spamd: processing message <E4CB65DF7CB0D6408162AF421DADF7EA1454E1@arbeit05.arbeit-bremen.local> for nobody:65534
Mar  3 14:40:53 dmoeko spamd[31358]: prefork: child states: BBBI
Mar  3 14:40:54 dmoeko spamd[3183]: spamd: identified spam (20.0/4.0) for nobody:65534 in 5.7 seconds, 8635 bytes.
Mar  3 14:40:54 dmoeko spamd[3183]: spamd: result: Y 19 - BAYES_99,DATE_IN_FUTURE_12_24,DRUGS_ERECTILE,HTML_MESSAGE,URIBL_JP_SURBL,URIBL_OB_SURBL,URIBL_SBL,URIBL_SC_SURBL scantime=5.7,size=8635,user=nobody,uid=65534,required_score=4.0,rhost=localhost,raddr=127.0.0.1,rport=56714,mid=<01c87e0d$95120580$34ca2159@gautier>,bayes=1,autolearn=no

Auch in /var/log/mail.err ist nichts enthalten.


#11

Hallo,

hilft es für einen Benutzer den Haken “Globalen Spam Account” zu deaktivieren und anschließend wieder zu aktivieren? Danach sollte das Listener Modul das sieve Skript neu schreiben.

Liegen unterhalb von /var/spool/cyrus/sieve/domain die Sieve Skripte der Benutzer?

Viele Grüße
Stefan Gohmann


#12

Hallo,

[quote=“Gohmann”]Hallo,

hilft es für einen Benutzer den Haken “Globalen Spam Account” zu deaktivieren und anschließend wieder zu aktivieren? Danach sollte das Listener Modul das sieve Skript neu schreiben.
[/quote]

Standardmäßig sind die Haken eh deaktiviert, da ja nicht per Benutzerbasis verteilt wird, sondern global, siehe meine Posting weiter oben

[quote=“Gohmann”]
Liegen unterhalb von /var/spool/cyrus/sieve/domain die Sieve Skripte der Benutzer?

Stefan Gohmann[/quote]

Ja, sind da.

MfG


#13

Hallo,

Bitte prüfen Sie auch die Logeinträge in /var/log/mail.log, sind dort noch Fehlermeldungen vergleichbar dem deliver.db-Fehler zu sehen?

Sehen die abgelegten sieve-Skripte und die gesetzten symbolischen Links korrekt aus? Sie sollten auf den korrekten globalen Spam-Account verweisen und bei allen aktivierten Benutzer identisch sein. Ggf. erstellen Sie zum Vergleich ein neues Benutzerkonto.

Ist der globale Spam-Folder erreichbar und schreibbar? Können Sie dem zugeordneten Benutzer direkt Mails senden?

Mit freundlichen Grüßen
Ingo Steuwer


#14

[quote=“Steuwer”]Hallo,

Bitte prüfen Sie auch die Logeinträge in /var/log/mail.log, sind dort noch Fehlermeldungen vergleichbar dem deliver.db-Fehler zu sehen?

Sehen die abgelegten sieve-Skripte und die gesetzten symbolischen Links korrekt aus? Sie sollten auf den korrekten globalen Spam-Account verweisen und bei allen aktivierten Benutzer identisch sein. Ggf. erstellen Sie zum Vergleich ein neues Benutzerkonto.

Ist der globale Spam-Folder erreichbar und schreibbar? Können Sie dem zugeordneten Benutzer direkt Mails senden?

Mit freundlichen Grüßen
Ingo Steuwer[/quote]

Hallo,

Es gibt keine Fehlermeldungen.
Alle Links sind korrekt auf global.sieve und local.sieve gesetzt. Der globale Spamaccount ist erreichbar. Das Schicken der Mails bereitet keine Probleme.

Wie lauten die Standard-Rechte für global.sieve und loccal.sieve? Es war 600 eingerichtet (cyrus:mail
)


#15

Hallo,

[quote=“hightower”]Hallo,

Standardmäßig sind die Haken eh deaktiviert, da ja nicht per Benutzerbasis verteilt wird, sondern global, siehe meine Posting weiter oben

root@dmoeko:~# univention-baseconfig get mail/antispam/globalfolder
spam@oekonet-bremen.de
root@dmoeko:~#
[/quote]

könnten Sie den Haken aktivieren? Wenn ich es richtig verstanden habe, dann sollen doch die erkannten Spam-Mails nicht an den Benutzer, sondern an an spam@oekonet-bremen.de verschickt werden. Dafür wird dieser Haken benötigt.

Falls Sie den Haken nicht aktivieren möchten, so können Sie anschließend den Haken wieder deaktivieren. Im Hintergrund wird dann das sieve Skript neu gestartet. Weitere Hinweise dazu sind im Dokument UCS Domänenkonzept auf http://www.univention.de/dokumentation.html zu finden.

Viele Grüße
Stefan Gohmann


#16

Hallo,

Die “Haken” waren noch nie aktiviert und es hat immer funktioniert.
Ich hatte die “Haken” aktiviert, um zu schauen, ob es nun richtig funktioniert. Tut es nicht.

Hier mal der Ordnerinhalt eines beliebigen Nutzers, dessen Spammail in den globalen Spamordner soll

root@dmoeko:/var/spool/cyrus/sieve/domain/g/gri-bremen.de/k/kxxxx# ls -al
insgesamt 16
drwxr-xr-x  2 root  nogroup 4096 2008-02-26 16:06 .
drwxr-xr-x  3 root  nogroup 4096 2007-04-27 09:21 ..
lrwxrwxrwx  1 root  nogroup   75 2008-02-26 16:06 default -> /var/spool/cyrus/sieve/domain/g/gri-bremen.de/k/kxxxx/global.sieve.script
-rw-r--r--  1 cyrus mail     132 2008-02-26 16:06 defaultbc
lrwxrwxrwx  1 root  nogroup   29 2007-04-27 09:21 global.sieve.script -> /var/spool/sieve/global.sieve
lrwxrwxrwx  1 root  nogroup   28 2007-04-27 09:21 local.sieve.script -> /var/spool/sieve/local.sieve
root@dmoeko:/var/spool/cyrus/sieve/domain/g/gri-bremen.de/k/kxxxxxt#

Wie man sieht ist “default” auf das “global.sieve.script” verlinkt u.s.w.

Der Inhalt eben dieses Skripts ist folgender:

root@dmoeko:/var/spool/cyrus/sieve/domain/g/gri-bremen.de/k/kxxxxx# cat global.sieve.script
require "fileinto";
if header :matches "X-Spam-Status" "Yes,*" {
        redirect "spam@oekonet-bremen.de";
        stop;
}
root@dmoeko:/var/spool/cyrus/sieve/domain/g/gri-bremen.de/k/kxxxxx#

"spam@oekonet-bremen.de" steht stellvertretend für eine existierende Mailadresse, die ich hier nicht nennen möchte.

Für mich sieht der Sieve-Ablauf korrekt aus, aber trotzalledem werden alles getagten Spammails an den jeweiligen User ausgeliefert und nicht an den definierten Account.

Vielleicht ist die Problematik nun etwas deutlicher dargestellt und beweist, dass es nicht nur das Problem eines nichtgesetzen Hakens ist.


#17

Hallo,

Wenn die Mails an den Benutzer ausgeliefert werden, landen Sie dann in dem Spam-Ornder des Benutzers? Ist in der SPAM-Mail auch das Header-Feld X-Spam-Status enthalten? Wenn eine Spam-Mail ausgeliefert wird, was steht dann in der Log-Datei /var/log/mail.log zu dem Vorgang?

Mit freundlichen Grüßen
Andreas Büsching