Mail:Server: Mails beim Provider löschen

mail
german

#1

Hallo an alle

Mails holen und verschicken funzt wunderbar…aber…
Die abgeholten Mails werden beim Provider nicht gelöscht :frowning:
(obwohl die Benutzereinstellungen “Mails auf dem Server nicht löschen” aus sind)
Die “/var/log/mail.log” zeigt mir keine Fehler an…

Gruß Torsten


#2

Upppsss… Hab’ gerade gesehen, dass es ein Mail-Forum gibt, bitte evtl. verschieben
Gruß Torsten


#3

Ich gehe davon aus, dass Sie von fetchmail sprechen, oder? Wie sieht denn der Inhalt der /etc/fetchmailrc aus (sensitive Daten bitte aus-xen oder ähnliches)?


#4

Hallo Moritz
Erstmal vielen Dank für die schnelle Hilfe

[quote]Ich gehe davon aus, dass Sie von fetchmail sprechen, oder? [/quote]Ja

Die Config “/etc/fetchmailrc” sieht so aus:

[quote]set daemon 360
set syslog
set postmaster “postmaster”
set bouncemail
set no spambounce
set properties “”
poll pop.1und1.de with proto POP3 auth password user ‘xx.xx@xxx_xxx.com’ there with password ‘xxxx’ is xx.xx@xxx_xxx.com’ here nokeep ssl #UID=‘xx.xx’
poll pop.1und1.de with proto POP3 auth password user ‘xxx.xxx@xxx_xxx.com’ there with password 'xxxx is ‘xxx.xxx@xxx_xxx’ here nokeep ssl #UID=‘xxx.xxx’
poll pop.1und1.de with proto POP3 auth password user ‘xxxx.xxxx@xxx_xxx.com’ there with password 'xxxxx is ‘xxxx.xxxx@xxx_xxx’ here nokeep ssl #UID=‘xxxx.xxxx’
poll pop.1und1.de with proto POP3 auth password user ‘xxxxx.xxxxx@xxx_xxx.com’ there with password 'xxxxxx is ‘xxxxx.xxxxx@xxx_xxx’ here nokeep ssl #UID=‘xxxxx.xxxxx’
[/quote] usw. usw.
Die Einstellungen sind bei allen Postfächern gleich. Die Option “nokeep” ist bei allen gesetzt. Aber nur bei dem Postfach "info@xxxxx.com" funktioniert das Löschen beim Provider. Bei den anderen nicht.
Der einzige Unterschied, der mir Z.Zt. einfällt: Beim Anlegen von “info@…com” wurde die Option “Mails auf dem Server nicht löschen” ausgeschaltet, beim den anderen Postfächern wurde die Option beim Erstellen an- und erst später ausgeschaltet.

Gruß Torsten

PS.: Gibt es eigentlich eine Einstellung, die Emails beim Provider erst nach einer festgelegten Anzahl von Tagen zu löschen?


#5

fetchmail löscht nur diejenigen E-Mails, die in der Verbindung auch heruntergeladen wurden. Weiterhin wird die Option »all« nicht benutzt, sodass nur neue E-Mails heruntergeladen, nicht aber bereits gelesene.

Das bedeutet, dass bereits gelesene E-Mails auch nicht gelöscht werden. Dies müsste einmalig manuell gemacht werden (z.B. mit einem regulären E-Mail-Client).

PS.: Gibt es eigentlich eine Einstellung, die Emails beim Provider erst nach einer festgelegten Anzahl von Tagen zu löschen?

Nein. So etwas bietet fetchmail selber nicht an.


#6

ok, ich werde die bereits empfangenen Mails per Webzugang manuell löschen
und dann die Postfächer beobachten…
Vielen Dank für die Hilfe
Gruß Torsten