Locales fehler

german

#1

nach dem befehl “dpkg-reconfigure locales” wird dieser Fehler ausgegeben:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “de_DE@euro”,
LANG = “de_DE.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
Generating locales (this might take a while)…
de_DE.UTF-8… done
en_US.UTF-8… done
Generation complete.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “de_DE@euro”,
LANG = “C”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “de_DE@euro”,
LANG = “C”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).

wenn man ucr set drückt wird dieser fehler ausgegeben:
-bash: Warnung: setlocale: LC_CTYPE: cannot change locale (de_DE@euro)
-bash: Warnung: setlocale: LC_CTYPE: cannot change locale (de_DE@euro)

Version:
update/umc/nextversion: true
version/erratalevel: 62
version/patchlevel: 1
version/releasename: Borgfeld
version/version: 3.2


#2

Hallo,

Dieser Befehl ändert die Locale Einstellungen nur auf der Debian-Ebene, alle UCS-spezifischen Dinge würden damit nicht angeglichen werden. Das Resultat sind dann solche Folgefehler wie der beschriebene Perl-Fehler.

Die in der aktuellen Shell gerade geltenden Werte sieht man mit:

root@hostname:~# locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Wenn man mit den UCS-Mitteln (UCR oder UDM) die Locale ändert, werden die Debian-Anteile ebenfalls geändert. Anschauen kann man die momentanen Einstellungen mit der UCR:

root@hostname:~# ucr search locale
locale/default: en_US.UTF-8:UTF-8
 Localisation properties such as time/date formats and the preferred translation are specified in locales. The installed locales can be selected using the UMC module 'System settings'. This variable selects the default locale for the system.

locale/keymap: us
 The keyboard layout in use. It can modified using the UMC module 'System settings'.

locale: en_US.UTF-8:UTF-8 de_DE.UTF-8:UTF-8
 Localisation properties such as time/date formats and the preferred translation are specified in locales. The installed locales can be selected using the UMC module 'System settings'. This variable contains the installed locales.

Die Syntax lädt ziemlich zu Tippfehlern ein, deshalb würde ich für das “Geradeziehen” von Einstellungen lieber den UDM nehmen, unter “System” -> “Basis-Einstellungen”. Danach kann man ja nochmal kontrollieren. (man muß die aktuelle Shell verlassen und sich neu anmelden, bevor Environment-Einstellungen wirksam werden)

viele Grüße
Frank Greif.