Linux-headers nicht vorhanden

german

#1

Hallo,

ich will ein externes Gerät anschließen (eine Funkuhr).

Für die Installation der Hersteller-Treiber benötige ich die linux-headers. Ich bekomme jedoch folgende Fehlermeldung:

root@hbucsvm01:~# univention-install linux-headers-$(uname -r)
...
E: Unable to locate package linux-headers-3.10.0-ucs73-amd64
E: Couldn't find any package by regex 'linux-headers-3.10.0-ucs73-amd64'

Selbes per apt-get …


#2

Hallo,

das Paket ist auf meinem Testsystem normal über das 3.2-3 maintained Repository verfügbar:

root@master:~# apt-cache policy linux-headers-3.10.0-ucs73-amd64 linux-headers-3.10.0-ucs73-amd64: Installiert: (keine) Kandidat: 3.10.11-1.73.201407171015 Versionstabelle: 3.10.11-1.73.201407171015 0 500 http://updates.software-univention.de/3.2/maintained/ 3.2-3/amd64/ Packages root@master:~# univention-install -s linux-headers-$(uname -r) [...] OK http://updates.software-univention.de 3.2-0/all/ Packages OK http://updates.software-univention.de 3.2-0/amd64/ Packages OK http://updates.software-univention.de 3.2-1/all/ Packages OK http://updates.software-univention.de 3.2-1/amd64/ Packages OK http://updates.software-univention.de 3.2-2/all/ Packages OK http://updates.software-univention.de 3.2-2/amd64/ Packages OK http://updates.software-univention.de 3.2-3/all/ Packages OK http://updates.software-univention.de 3.2-3/amd64/ Packages OK http://updates.software-univention.de 3.2-3-errata/all/ Packages OK http://updates.software-univention.de 3.2-3-errata/amd64/ Packages [...] Paketlisten werden gelesen... Paketlisten werden gelesen... Abhängigkeitsbaum wird aufgebaut... Statusinformationen werden eingelesen... Die folgenden zusätzlichen Pakete werden installiert: linux-headers-3.10.0-ucs73-common linux-kbuild-3.10 Die folgenden NEUEN Pakete werden installiert: linux-headers-3.10.0-ucs73-amd64 linux-headers-3.10.0-ucs73-common linux-kbuild-3.10 0 aktualisiert, 3 neu installiert, 0 zu entfernen und 0 nicht aktualisiert. Inst linux-headers-3.10.0-ucs73-common (3.10.11-1.73.201407171015 Univention:updates.software-univention.de [amd64]) Inst linux-kbuild-3.10 (3.10-2.6.201307181501 Univention:updates.software-univention.de [amd64]) Inst linux-headers-3.10.0-ucs73-amd64 (3.10.11-1.73.201407171015 Univention:updates.software-univention.de [amd64]) Conf linux-headers-3.10.0-ucs73-common (3.10.11-1.73.201407171015 Univention:updates.software-univention.de [amd64]) Conf linux-kbuild-3.10 (3.10-2.6.201307181501 Univention:updates.software-univention.de [amd64]) Conf linux-headers-3.10.0-ucs73-amd64 (3.10.11-1.73.201407171015 Univention:updates.software-univention.de [amd64])

Was sagt apt-cache policy linux-headers-3.10.0-ucs73-amd64 bei Ihnen?

Mit freundlichen Grüßen,
Tim Petersen


#3

Der Paketname ist richtig, wobei es vielleicht sinnvoller ist das Metapaket univention-kernel-headers zu installieren. Wie sieht denn die vollständige Ausgabe von univention-install aus? Wie ist die Ausgabe von

cat /etc/apt/sources.list.d/15_ucs-online-version.list

#4

Hallo,

vielen Dank für die schnelle Hilfe.

Aus irgendwelchen Gründen war die Datei

/etc/apt/sources.list.d/15_ucs-online-version.list

leer, bzw. nur Kommentare drin.

Nach einem Commit war alles gut.

Nun kann ich die Treiber installieren.

Danke nochmals!