Libmysqlclient-dev passt nicht zu libmysqlclient16

german

#1

Hallo,

um in “R” das Paket “Rmysql” zu kompilieren muss ich das Paket libmysqlclient-dev installieren.

Dieses scheint aber nicht zur Version libmysqlclient-Version aus dem Repository zu passen…

[code]root@***:~# apt-get install libmysqlclient-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libmysqlclient-dev : Depends: libmysqlclient16 (= 5.1.63-0.23.201209281413) but 5.1.66-0.25.201212130923 is to be installed
E: Broken packages[/code]

Hat jemand zufällig eine Idee?

VG Oli


#2

Hallo,

MySQL wurde in einem Errata-Update aktualisiert, daher muss auch für die Errata-Komponente des Repository der “unmaintained”-Bereich aktiviert werden:ucr set repository/online/component/3.1-0-errata/parts="maintained,unmaintained" univention-install libmysqlclient-dev

Mit freundlichen Grüßen
Janis Meybohm


#3

Die Variable “parts” sollte in docs.univention.de/manual-3.1.ht … repoadducr dokumentiert werden.


#4

[quote=“Meybohm”]Hallo,

MySQL wurde in einem Errata-Update aktualisiert, daher muss auch für die Errata-Komponente des Repository der “unmaintained”-Bereich aktiviert werden:ucr set repository/online/component/3.1-0-errata/parts="maintained,unmaintained" univention-install libmysqlclient-dev

Mit freundlichen Grüßen
Janis Meybohm[/quote]

Funktioniert prima, dankeschön!


#5

Hallo,

Mit freundlichen Grüßen
Janis Meybohm