Letsencrypt caldav service 8443 kopano

letsencrypt

#1

Hi all,
as mentioned here Cool Solutions - Let’s Encrypt I installed letsencrypt without problems. My problem now is, I want to access my kopano calendars via caldav over port 8443 and accessing https://my.server.com:8443/caldav/mailbox sends back the standard UCS certificate, and not the one I registered via letsencrypt.

Is there an additional variable like the letsencrypt/services/apache2 for caldav? Or how to achieve that my UCS sends back also the letsencrypt certificate for requests to the address mentioned above?

Thanks for your help!

rittel


#2

Hi,

you’ll have to specify the SSL cert in ical.cfg config file in /etc/kopano/
you should do this in with UCR variable “kopano/cfg/ical/ssl_private_key_file” and “kopano/cfg/ical/ssl_certificate_file”

rg
Christian


#3

Christian, thanks for the quick answer, that did the trick! Wasn´t aware of these settings.

rittel