Les Encrypt Failing to Install

Hi, very new to Univention but enjoying the solution immensely. Exceptional platform.

However when I try to add Let’s Encryt as my first app to the new server I get initially “Let’s Encrypt: Performing software tests on involved systems”. Runs for about 3-4 minutes and then I get “An Error Occurred - Internal Server Error”. Fresh install on VMware.

I have tried adding other apps and have no issues.

I wanted to get this base app operating prior to adding additional apps.

Is there anyway I can install this from the CLI?

Any assistance greatly appreciated.

Dev

Hi Have fixed issue by installing via CLI.

Hello @GetSmarts,

welcome to Univention Help and I’m glad to hear, you could “fix” it yourself.

Just for other users who may stumble over this posting. Installation a the Let’s Encrypt app via cli can be done with univention-app install letsencrypt.

The management system and the cli are actually using the same algorithm in the background. Can you remember or see any entries in /var/log/univention/appcenter.log regarding your first installation over the management system?

Best regards,
Nico

CLI works. I tried installing Let’s encrypt (tried on versions 4.4.0-4.4.4) via GUI but it was not installing and there were no errors in the log either. After wasting 2 days, I tried via CLI and it installed perfectly.