Leidiges "Send as" Thema ;-)

mail
german

#1

Hallo,

ich habe gestern die UCS-Domäne in Betrieb genommen. 2 Benutzer sind angelegt und 8 “non actice Konten” in Zarafa.

Bei allen habe ich einen Stellvertreter eingetragen. Da es in der aktuellen Implementation nur mit einzelnen Benutzern geht, hab ich den jetzt einzeln eingetragen (bei den Benutzern und bei den Non active Konten")

Dennoch bekomme ich die Meldung

[code]Unfortunately, I was unable to deliver your mail.
The error given was:

Es ist nicht erlaubt unter diesem Benutzer- oder Gruppennamen E-Mails zu versenden.xxxx

You may need to contact your e-mail administrator to solve this problem.[/code]

Hab ich mir irgendwas verstellt? Oder sogar vergessen einzutragen, damit das ganze geht?

LG
Michael


#2

Hallo Michael,

klappt hier ohne Probleme.

Zwei Benutzer (user01 und user02). Bei Benutzer user02 im “Zarafa” Reiter user01 als “Stellvertreter” eingetragen. In WebApp als user01 angemeldet, von-Zeile eingeblendet und user02 aus dem Adressbuch ausgewählt. Nachricht wurde dann als user02 versendet.


#3

OK,

wenn es bei dir funktioniert, könntest du bitte mal schauen, was bei dir steht, wenn du folgendes ausführst

zarafa-admin --list-sendas user1

Bei mir kommt dann nur

Send-as list (0) for user user1:
        Username        Fullname
        ------------------------

Meine UCR sieht im Bereich “zarafa” wie folgt aus:

zarafa/cfg/ldap/ldap_sendas_attibute_type = text
zarafa/cfg/ldap/ldap_sendas_relation attibute = uidNumber

Vielen Dank im Vorraus für die Rückmeldung


#4

Hast du es eventuell verdreht? zarafa-admin --list-sendas user01 listet bei mir nichts, da die Berechtigungen ja auch für user02 hinterlegt sind.

Beim Objekt als das gesendet werden soll muss die Berechtigung gesetzt werden, nicht beim User der sendet.


#5

Ja klar - ich meinte natürlich user2 :wink:

Vielleicht noch als Info: Ich habe neulich folgenden Befehl ausgeführt: github.com/zarafa4ucs/zarafa4ucs/issues/94
Kann es sein, da der etwas “verändert” hat?

Ich habe heute morgen den daraus entstehenden LDAP-Eintrag wieder entfernt. Aber leider kann ich immer noch keinen Stellvertreter eintragen - zumindest keinen, der dann mit zarafa-admin angezeigt wird. Muss ich den Server komplett neustarten?

LG
Michael


#6

Das auf Github verlinkte Ticket verändert nur die Univention Oberfläche und hat keine direkte Auswirkung auf Zarafa selbst, daher kann dies keinen Einfluss darauf haben.

Eine Idee die ich noch hätte, ist ob eventuell der Listener kein “zarafa-admin --sync” angestoßen hat. Dieser wird bei Univention eigentlich nach jeder Zarafa relevanten Änderung (neuer Benutzer, etc) aufgerufen und sorgt dafür, dass die interne Nutzerdatenbank mit dem LDAP abgeglichen wird.

Sollte es auch nach einem manuellen Aufruf von “zarafa-admin --sync” nicht gehen würde ich eine direkte Ticketeröffnung bei Zarafa vorschlagen: portal.zarafa.com (aktive Subskription vorausgesetzt).


#7

Hab nochmal alle Einstellungen überprüft und dann einen NEUSTART gemacht.

Jetzt werden die SendAs - Adressen korrekt angezeigt und das Versenden funktioniert :wink:

LG
Michael