LDAP Connection fails


#1

Hello,
I’m trying to connect to my domain via SugarCRM and LDAP Admin. Until recently I was able to log in without any problem. I have triple checked the base DN, username, password, etc.
In both I get the same error. See attached.
What should I check? Thank you


#2

Hi,

the message indicates that the security level you are using does not match the requirements, most likely on the server side.
It depends on your environment how to solve it. In case you have installed Samba 4 and are trying to connect on Port 389 you should follow the instructions of you solution to be used against Active Directory.
For OpenLDAP use Port 7389.
In case case the generic solution would be to use TLS instead of unencrypted session.

Best Regards,
Dirk Ahrnke


#3

That’s the strange part though. It doesn’t work over TLS, SSL, or anything else.
It worked perfectly not long ago and I have not changed anything. I have another UCS instance for testing and that one still works perfectly.

EDIT:
Attempting a TLS connection gives the exact same error as above.


#4

Depending on the LDAP you are trying to connect to (Samba4 oder OpenLDAP) you could increase log verbosity and check the logs.

Best Regards,
Dirk Ahrnke