Ldap_bind: Invalid credentials (49) and so I cannot use web gui: I am stuck


#1

Hello,
I have a UCS latest version joined to a windows PDC.
All was working but today I have added a new user in the domain.
I can login with the user to the univention web interface (so it seems UCS join is good).
But I cannot login to Nextcloud in UCS.
I checked in UCS users and I do not see my new user so I cannot enable Nextcloud for him.
What can I do?
Thanks,
Mario


#2

Any idea? I installed by mistake and then uninstalled Active Directory Takeover.
Do I need to rerun some scripts?


#3

It is also quite difficult to debug, do I start with docker? or with something else?
Where are nextcloud logs?


#4

You could take a look at the AD Connector troubleshooting guide.


#5

Hi,
after looking at that guide I followed forum threads, accidentally corrupted machine.secret and after many steps I cannot login anymore to web interface.
I want to unjoin domain and then join again. Can I do it from command line?
How can I access again to web gui? My administrator password does not work anymore and as root I cannot enter!


#6
  • Univention-join gives me Join on DC Master impossible
  • univention-ldapsearch gives me ldap_bind: Invalid credentials (49)
  • ldapsearch -H ldapi:// -LLL -Q -Y EXTERNAL -b “cn=config” “(olcRootDN=*)” dn olcRootDN olcRootPW gives me:

dn: olcDatabase={0}config,cn=config
olcRootDN: cn=config

dn: olcDatabase={1}mdb,cn=config
olcRootDN: cn=admin,dc=giammar,dc=mio


#7

I have recovered from backup. But the nextcloud problem persists.