Kopano WebApp seit Update öffen Mails teilweise ewig nicht

kopano
german

#1

Guten Morgen zusammen,

seit dem letzten Update der UCS-Version von Kopano auf 8.6.2.1-0+5.1 habe ich vermehrt in der DeskApp (1.9.0 unter Ubuntu 64) dass bem versuch eine Mail zu öffnen dieser hell dargestellt wird und dann ein kleines PopUp “Laden” angezeigt wird.

Das läuft dann ewig. Manchmal klappt das öffnen nach dem 4 oder 5 Versuch.

Nutzt jeman von Euch auch DeskApp und hat dieses Verhalten ebenfalls beobachtet?

Viele Grüße
Sven


#2

Moin,

ich denke, es wäre im Kopano-Forum besser aufgehoben. Frag’ doch mal da nach, das hat ja nicht direkt was mit der App bzw. UCS selbst zu tun.

/KNEBB


#3

Ich habe mal wieder zu wenig Infos raus gegeben …

Also ich habe beim Support von Kopano nachgefragt und als Antwort erhalten:

Support:
haben Sie die Performanceparameter für MySQL und Kopano angepasst bzw. gesetzt?

Ich:
Nein, ich habe damals installiert und im wesentlich nur User eingerichtet und die Daten mittels migratins-Tool rein gepumpt. Aber wie gesagt. Vor dem Update trat das Problem nie auf.

Oder sollte ich da was anpassen?

Support:
Kopano setze das Tuning inzwischen fast zwingend voraus. Hier https://nextcloud.kopano.com/index.php/s/uAHd0Q7qVyEqefM sind die wichtigen Parameter beschrieben. Die müssen natürlich der Größe der DB und des Anhangverzeichnisses angepasst werden. So wie Sie es beschreiben liefert die MySQL nicht schnell genug.

Meine Frage ist nun ob ich die Anleitung auch unter der “UCS-Version” von Kopano einfach so 1:1 umsetzen kann.

Ich will da vorsichtig sein da nach meinem Verständnis ja das Konzept von UCS ist eben nicht per Hand in den Conf-Dateien rum zu machen.

Möchte mir nur keine Probleme einhandeln :slight_smile:


#4

Das kann man so generell nicht behaupten. Natürlich klappt auch erstmal alles ohne Tuning von Datenbank etc. Einzig bei grossen Daten- und Nutzermengen sollte swingend Hand angelegt werden. Generell ist aber eher ein Performenacezuwachs von älteren auf neuere Versionen zu erwarten, ob das tatsächlich die Lösung ist wage ich zu bezweifeln.

Ich habe mir im übrigen das betreffende Ticket herausgesucht und es endet vor sieben Stunden mit der folgenden Aussage:

Warum sollen die Tuningparameter für MySQL und Kopano auf einem UCS nicht gelten? Beide Programme gibt es auch auf anderen OS. Und UCS 4.3 entspricht eigentlich Debian 9.


#5

Das war auch meine Vermutung da dass Verhalten vorher (vor dem Update) definitiv niemals auftrat und der Server sehr leistungsfähig ist (Dual Xenon, Hardware-RAID mit SSD’s, 128 GB) und hier im Büro im Moment nur ein User dran hängt.

Ich habe halt keine Ahnung wo ich ansetzen soll.

Ich weiß nicht ob ich mich so unklar ausdrücke. Ich weiß schon dass UCS auf Debian basiert aber bei Debian passt man alles in den Conf-Dateien an, bei UCS soll man dies ja (soweit ich das weiß) nicht unbedingt.

Von daher weiß ich jetzt auch nicht was ich tun soll :frowning:


#6

wird eventuell das hier gesucht? https://wiki.z-hub.io/display/K4U/Changing+configuration+options

ähnliches funktioniert auch mit mysql/mariadb. Die folgenden UCR Variablen gibt es per Default:

mysql/config/mysqld/bind_address: 0.0.0.0
mysql/config/mysqld/innodb_buffer_pool_size: 157286400
mysql/config/mysqld/max_allowed_packet: 33554432
mysql/config/mysqld/max_connections: 151
mysql/config/mysqld/query_cache_limit: 2097152
mysql/config/mysqld/query_cache_size: 33554432

Diese können afaik mit eigenen Variablen erweitert werden.


#7

ICh muss das Thema nochmal aufgreifen. Zum einen ist der Betreff des Beitrags falsch. In DeskApp hae ich dieses verhalten seit dem Update.

Ich habe bisher jetzt keine “Optimierungen” vorgenommen … weil:

  • In WebApp tritt das Problem nicht auf
  • Der Server zwei Intel® Xeon® Silver 4114 CPU @ 2.20GHz (je 16 Kernen), 128GB RAM, Hardwar-RAID auf SSD’s und einem User dran mit Sicherheit keine Performance-Probleme hat.

Und wie gesagt. Vor dem Update war dieses Problem einfach nicht da.

Ich kann diese Optimierung gerne probieren aber ich denke da ändert sich nichts


#8

Hallo @pixel,

ich würde empfehlen mit der Information dass es nur die DeskApp betrifft, aber nicht die WebApp auf den Support zu zugehen.

Falls das aus irgendwelchen Gründen nicht gewünscht ist, wäre das Kopano Forum ein anderer Ort.