Kopano WebApp --> PHP mapi extension not found (nearly fixed - how to fix included)

php
kopano
ucs-4-3
german

#21

Hi - kurzes Update zu den nerfigen eMails.

Auch die heute eingespielten Update:

  • 4.3-2 errata287
  • Kopano WebApp 3.4.21.1723

haben leider keine Verbesserung gebracht.

Die PHP5 Reste werden mir wohl noch weitere Monate treu bleiben ;-(


#22

Ah, diese Antwort sehe ich erst jetzt. Ich hatte dieses Thread gemutet, da Pepe und ich nur bedingt kompatibel scheinen. Auch in meinem Augen ist hier die Lösung die Dependencies umzudrehen und PHP7 an erster Stelle stehen zu haben. Nach viel hin und her mit unserem WebApp Team wurde das auch bereits vor einigen Monaten für die Nightly Builds umgesetzt, scheinbar wurde diese Änderung nach wie vor nicht für die anderen Releasetypen übernommen. Ich habe das jetzt nochmal angeschoben:

$ apt -a show kopano-webapp
Package: kopano-webapp
Version: 3.4.23.1907+1058.1
Priority: optional
Section: web
Maintainer: Kopano Development <development@kopano.io>
Installed-Size: 28,2 MB
Depends: php7-mapi | php5-mapi (>= 7.2.5), php-json | php5-json, php-gettext | php5-gettext, php-xml, php-zip, php-common, php-mbstring
Download-Size: 4.932 kB
APT-Sources: https://download.kopano.io/supported/webapp:/master/Univention_4.3  Packages
Description: New and improved WebApp for Kopano
 Provides a web-client written in PHP that uses JSON and Ext JS
 to allow users to make full use of Kopano
 through a modern web browser.

#23

Hi - kurzes Update zum aktuellen Status.

Auch die heute eingespielten Update:

  • 4.3-2 errata376 (Neustadt)
  • Kopano WebApp 3.4.22.1782

haben leider keine Verbesserung gebracht.

Die PHP5 Reste werden mir wohl noch weitere Monate treu bleiben ;-(

Bleibt die Frage ab wann denn die Version 3.4.23.1907+1058.1 zur Verfügung steht - und ob dann wirklich das Problem weg ist.

Vielleicht wird es ja noch ein Weihnachtsgeschenk ;-)))


#24

siehe :slight_smile:

lg
Christian


#25

Hallo - kurzes Update

Nach dem Update auf Kopano Core auf die Version 8.7.1.0 und UCS 4.4-0 errata137, kommen vom Core keine störenden eMails mehr - PERFEKT ! ! !
Kopano%20Core

Nicht so gut sieht es leider auf dem Server aus, auf dem die WebApp läuft. Auch hier wurde die aktuelles Version die UCS anbietet installiert (3.5.5.2276+93.1). Bei den zu deinstallierenden Paketen sind die betroffenen jedoch auch nicht mit dabei:
Kopano%20WebApp

Laut dem Kopano Support (siehe weiter oben) solle das bereits mit der Version 3.4.23.1907+1058.1 gefixt sein - tja, ist es aber nicht.

Wäre schön, wenn man den Fix denn für das WebApp Paket denn mal bald nachliefern könnte bevor der Post Geburtstag feiert :wink:

PS: Nein - ich möchte die zu deinstallierenden Dateien immer noch nicht von Hand bearbeiten :wink: