Kopano Problem mit Suchindex

kopano
german

#1

Hallo,

seit wenigen Wochen tritt auf einmal das Problem auf, dass neuere Emails in Kopano nicht mehr indiziert wurden und somit der Suchfunktion nicht bereitstanden. Emails die älter als ein paar Wochen sind lassen sich hingegen ohne weiteres finden.

Beim Blick in die Datei /var/log/kopano/search.log fanden sich dann permanent wiederholte Fehlermeldungen wie folgt:

2017-04-07 17:37:11,080 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=2/5)
2017-04-07 17:37:17,531 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=3/5)
2017-04-07 17:37:23,982 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=4/5)
2017-04-07 17:37:30,433 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=5/5)
2017-04-07 17:37:36,840 - index0 - ERROR - Too many retries, skipping change
2017-04-07 17:37:36,885 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=0/5)
2017-04-07 17:37:43,329 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=1/5)
2017-04-07 17:37:49,790 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=2/5)
2017-04-07 17:37:56,243 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=3/5)
2017-04-07 17:38:02,697 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=4/5)
2017-04-07 17:38:09,156 - index0 - WARNING - Received a MAPI error or timeout (error=0x8004010f, retry=5/5)
2017-04-07 17:38:15,563 - index0 - ERROR - Too many retries, skipping change

Da sich an der Systemkonfiguration nichts geändert hat ist das plötzliche Auftreten des Fehlers nicht nachzuvollziehen. Auf dem Laufwerk befindet sich genügend Speicherplatz, auch ein Neustart des Servers hat nichts geholfen.

Was könnte man hier noch tun?

Vielen Dank!


#2

Hallo @ikue,

hmm einen solchen Fehler habe ich schon länger nicht mehr gesehen. 0x8004010f ist ein MAPI_E_NOT_FOUND. Er konnte also Mutmaßlich ein Element nicht mehr finden. Die Einfache Lösung ist für den Benutzer den Suchindex zu löschen und neu zu indexieren.

Für Debuggingzwecke wäre die Ausgabe auf einem höheren Loglevel interessant. Da würde ich dich dann aber bitte es drüben auf https://forum.kopano.io/ zu posten, da das nichts mit Univention zu tun hat.


#3

Danke für die Rückmeldung. Ich würde dann vorerst den Suchindex zurücksetzen und schauen, ob sich die Problematik somit dauerhaft beseitigt. Merkwürdig ist halt, dass das Problem lediglich Emails betrifft, die seit ca. 2 - 3 Wochen eingegangen / versandt wurden, ältere sind nicht betroffen.

Unter der Dokumentation von Kopano zum Thema Suchfunktion (https://documentation.kopano.io/kopanocore_administrator_manual/configure_kc_components.html#configure-kopano-search) erscheint kein Hinweis, was für ein Zurücksetzen des Suchindex nötig ist. Wie wäre hier die Vorgehensweise?


#4

Das kann für einen Benutzer über das kopano-search Kommando gemacht werden, also z.B. kopano-search --reindex=mein-benutzer.

Wenn es für alle Nutzer durchgeführt werden soll einfach service kopano-search stop gefolgt von rm -r /var/lib/kopano/search und service kopano-search start.


#5

Hallo,

kurz als Rückmeldung: Das nutzerspezifische Reindizieren hat nicht funktioniert, zumindest traten nach wie vor die gleichen Probleme auf.

Das Löschen des gesamten Suchindizes (Lösungsvorschlag Nr. 2) hingegen scheint geklappt zu haben.

Danke schön noch einmal.


#6

Hi - ich habe/hatte auch ein solches Such/Finde-Problem. Wobei ich auch bereits gelöschte eMail angezeigt bekommen habe - und die z.B. neuen nicht.
Habe gerade auch mit

service kopano-search stop
rm -r /var/lib/kopano/search
service kopano-search start

den Index neu aufgebaut - und bisher sehen die Ergebnisse wieder so aus wie sie sollen.

Danke das es hierfür bereits eine Lösung gibt :wink:

Pepe