Kopano/Postfix empfängt keine Mails

mail
kopano
postfix

#1

Hallo!
Ich beschäftige mich nun seit ein ein paar Wochen mit UCS und würde jetzt gerne meinen “alten” Mailserver (Debian, Postfix, Zarafa, fetchmail, z-Push) erneuern. Dazu habe ich UCS 4.3.3 installiert und Kopano (Core, WebApp, z-Push) installiert. Das Senden der Emails funktioniert, allerdings scheint postfix keine Mails anzunehmen.

Meine Konfiguration sieht folgendermaßen aus:
Der Server (“ucs.abc.net”) sitzt hinter einer fixen IP Adresse auf welche meine Domain “abc.net” zeigt. Die relevanten Ports werden per NAT an die lokale Adresse des Servers durchgereicht
Der MX Record lautet “mail.abc.net”. In UCS habe ich eine Email Domäne “mail.abc.net” hinzugefügt und in der UCS Config Registry den Eintrag “mail/smtp/helo/name” auf “mail.abc.net” gesetzt. Ich habe keine Einstellungen zum Konfigurieren eines Relay-Hosts gemacht.

Wie schon geschrieben funktioniert der Mailversand aber es werden keine Mails angenommen.
In /var/log/mail.err findet man folgende Zeilen:

Jan  9 11:34:29 services postfix/smtpd[3296]: connect from mail.xyz.com[xxx.xxx.xxx.xxx]
Jan  9 11:34:30 services postfix/smtpd[3296]: NOQUEUE: reject: RCPT from mail.xyz.com[xxx.xxx.xxx.xxx]: 454 4.7.1 <myname@abc.net>: Relay access denied; from=<sendername@xyz.com> to=<myname@abc.net> proto=ESMTP helo=<mail.xyz.com>
Jan  9 11:34:30 services postfix/smtpd[3296]: disconnect from mail.xyz.com[xxx.xxx.xxx.xxx] ehlo=2 starttls=1 mail=1 rcpt=0/1 quit=1 commands=5/6

Vielleicht findet sich ja jemand der mich auf die richtige Fährte lenken kann.


#2

Hi RoLee,

  • Email Domäne sollte ‘abc.net’ sein, wenn du Mailadressen wie bspw. xyz@abc.net empfangen willst, du kannst auch mehrere Mail-Domänen haben. Danach Postfix-Service neu starten, ev. macht das UMC aber auch automatisch nach dieser Änderung. Das wird dein (Haupt)Problem auch schon behoben haben.
  • Weiters würde ich das PortForward bzw. virt. IP Config auf deiner Firewall/Router bei Port 25 (SMTP) ohne NAT machen, damit dein Mailserver inkl. SpamAssassin & Co. die originäre IP-Adresse des Sende- MTAs sieht.
  • Ich würde auch sicherstellen, dass dein (zusätzlicher) Mail-server Hostname ‘mail.abc.net’ auch einen DNS Eintrag am internen DNS bekommt oder hat, damit bei internem Resolving gleich intern aufgelöst & geroutet wird.
  • Relay-Host Config betrifft Versenden und würde dringend empfehlen, ein qualitativ “hochwertiges” Relay (externer Internet Access oder Hosting Provider) zu verwenden, wenn man wenig Probleme betreffend SPAM Falsch-Erkennung mit Blockaden/Ablehnungen beim Versand haben will.

HTH,
Robert


#3

Hi Robert,

besten Dank für die prompte Hilfe. Hab die Mail-Domäne geändert und nun funktioniert es. Ich werde auch versuchen Deine anderen Hinweise umzusetzen, bis auf die Relay-Host Config. Mein bisheriger Server lief/läuft seit 8 Jahren ohne Macken - ich hatte nur einmal das Problem, dass eine Firma meine Mails nicht akzeptieren wollte und da hat eine kurze Nachricht an den Admin geholfen.

SG
Roland