Kopano | libvmime-kopano0 vs libvmime-kopano1

german

#1

Hallo allerseits,

wir haben kopano letzten Oktober aus dem App-Center installiert, mittlerweile sind wir auf der aktuellen Version 8.1.1.10

Ich habe die installierten debian-Pakete mit den zur Verfügung stehenden verglichen und festgestellt, dass es zwei Pakete mit ähnlichem Namen gibt: libvmime-kopano0 und libvmime-kopano1.
Die libvmime-kopano0 ist installiert.

[quote]root@master:/tmp# apt-cache show libvmime-kopano1
Package: libvmime-kopano1
Priority: optional
Section: libs
Installed-Size: 6605
Maintainer: Kopano Development development@kopano.io
Architecture: amd64
Source: libvmime-kopano
Version: 0.9.2~g500-8.1
Depends: libc6 (>= 2.2.5), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.6)
Filename: kopano-core_20161230140839/amd64/libvmime-kopano1_0.9.2~g500-8.1_amd64.deb
Size: 1599762
MD5sum: 8d0181c0a943dd39fbb883c8be551f79
SHA1: 8a9a0070d07d89fbd70bc0ab50a200bfdbc51267
SHA256: 09b404565db873ceedebf28cbdd9b66948f95729d647788ec7c67b7091b77ddf
Description: a C++ mail library (runtime library)
VMime is a powerful C++ class library for parsing, generating, or editing
Internet RFC-[2]822 and MIME messages. VMime is designed to provide a fast
and an easy way to manipulate Internet mail messages.
.
The recent releases of VMime also include support for using messaging
protocols (POP3, IMAP, SMTP and maildir) with a lot of features supported:
listing folders, downloading and adding messages to folders, extracting parts
from message, getting and setting message flags, and a lot more.

root@master:/tmp# apt-cache show libvmime-kopano0
Package: libvmime-kopano0
Priority: optional
Section: libs
Installed-Size: 2255
Maintainer: Kopano Development development@kopano.io
Architecture: amd64
Source: libvmime-kopano
Version: 0.9.1+svn603-3.1
Depends: libc6 (>= 2.2.5), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.6)
Filename: kopano-core_20161230140839/amd64/libvmime-kopano0_0.9.1+svn603-3.1_amd64.deb
Size: 784418
MD5sum: 5adb388533d6e519b43f07196903f233
SHA1: df8a6016106f1fdb8ad6787cc17cf8a2ce0950fd
SHA256: ff89e922f529be04c2f9ede78fd7cd610ba2bff7abc2d35bc1c803d22fa9fb73
Description: a C++ mail library (runtime library)
VMime is a powerful C++ class library for parsing, generating, or editing
Internet RFC-[2]822 and MIME messages. VMime is designed to provide a fast
and an easy way to manipulate Internet mail messages.
.
The recent releases of VMime also include support for using messaging
protocols (POP3, IMAP, SMTP and maildir) with a lot of features supported:
listing folders, downloading and adding messages to folders, extracting parts
from message, getting and setting message flags, and a lot more.[/quote]

Da die Beschreibungen identisch sind, wird wohl libvmime-kopano1 das neuere Paket sein. Aber libkcinetmapi0 referenziert noch das alte Paket (apt-cache rdepends libvmime-kopano0).
Ist das ein Paketierungsbug, oder mache ich mir umsonst Sorgen?


#2

Hmm. es scheint als hätte ich dieses Paket mal bei einem früheren Upload dazu geschmuggelt, da es auch nicht Teil des öffentlichen Repos ist. (aber in >=8.2 tatsächlich nach libvmime-kopano1 wechseln werden). Ich habe es gerade mal aus der aktuelle App gelöscht.

PS: “no harm done” weil es auch nicht Teil der Abhängigkeiten von 8.1 ist.


#3

ok :wink: