Kopano. Anhang nur 2MB

kopano
german

#1

Hallo zusammen,

ich habe Kopano aus dem App-Store (UCS 4.3) am laufen. Im UCS habe ich doe Variable:

mail/messagesizelimit = 37200000

gesetzet. Wenn ich nun aber versuche einen 6MB Anhang via DeskApp oder WebApp rein zu ziehen bekomme ich den Hinweis dass nur 2MB erlaubt sind.

Ich habe mal testweise vom Handy aus (ActiveSync) ein paar größerer Bilder versenden > 10MB was Problemlos ging.

Was muss ich für WebApp / DeskApp noch ändern damit es auch dort geht?

Viele Grüße
Sven


#2

Huhu,

die upload_max_filesize in der korrespondierenden php.ini vermutlich.

Gruß
mosu


#3

ok, ich finde mehrere:

root@saturn:/# find -name 'php.ini'
./etc/php/7.0/cgi/php.ini
./etc/php/7.0/cli/php.ini
./etc/php/7.0/apache2/php.ini
./etc/php5/cli/php.ini
./etc/php5/apache2/php.ini

#4

Huhu,

welche verwendet wird, hängt von der Apache-Konfiguration ab. PHP läuft höchstwahrscheinlich als Modul und nicht via CGI, also ist es das apache2-Unterverzeichnis. Und aktuelles Kopano nutzt PHP 7.0 auf UCS 4.3 — sprich in der Standardkonfiguration ist die richtige Datei /etc/php/7.0/apache2/php.ini.

Zu prüfen mit dpkg -l | grep 'libapache2-mod-php' und cat /etc/apache2/mods-enabled/php*load

Nach Änderungen Reload vom Apache nicht vergessen.

Gruß
mosu


#5
root@saturn:~# dpkg -l | grep 'libapache2-mod-php'
ii  libapache2-mod-php5                                 5.6.33+dfsg-0+deb8u1                             amd64        server-side, HTML-embedded scripting language (Apache 2 module)
ii  libapache2-mod-php7.0                               7.0.27-0+deb9u1                                  amd64        server-side, HTML-embedded scripting language (Apache 2 module)
root@saturn:~# cat /etc/apache2/mods-enabled/php*load
# Conflicts: php5
# Depends: mpm_prefork
LoadModule php7_module /usr/lib/apache2/modules/libphp7.0.so

Also die:
/etc/php/7.0/apache2/php.ini
?


#6

Jau, genau die.

Die libapache2-mod-php5 kann man dann bei Zeiten auch mal deinstallieren. Beide gleichzeitig kann man eh nicht einsetzen (zumindest nicht in derselben Apache-Instanz).

m.


#7

ok, danke. Hat funktioniert