Kopano and Mail Home Server

mail
kopano
mailserver

#1

Hi there,

in the last days I was testing UCS and some apps. I installed a master with Kopano and another server as UCS member with the mail and horde apps. Mails are retrieved via fetchmail.

I was playing around with the Mail Home Server option to get the mails for one user to the mail/horde system and it was not working. The reason was that ldap:/etc/postfix/ldap.transport was missing in the postfix main.cf. I added it and everything worked as expected.

Yesterday I upgraded the system to UCS 4.3 and the same problem appeared. The option for transport_maps was missing. Somehow (maybe during the Kopano installation?) the ldap entry is removed and breaks the Mail Home function. Bug or Feature? :wink:

Best regards,
Christian


#2

Hi @christianroeser,

most of the configuration files in Univention are generated from templates. So if a particular setting is missing its (most of the time) not a good idea to just add it by hand and expect to stay in the same file forever (there is a large header warning about this for config files where this is the case).

I’d say that during the 4.3 upgrade one of the processes did a change in the postfix configuration which triggered the config file to be recreated. Hence you change was removed.

PS: Kopano also does not make use of the Mail Home Server feature in UCS


#3

Hi @fbartels,

you are right. I don’t know why, on the master mail/postfix/transport/ldap/enabled was set to false. On the mail/horde system it was true. But I can’t remember that I changed this on the master. :face_with_raised_eyebrow:

Nevertheless: solved. Thank you for clearing that.

EDIT:
That didn’t let me rest. I just installed a fresh UCS 4.3, the default settings for transport/ldap is false. I can only guess but it seems that the mail app sets this to true.