Keine Profile im UVMM mit KVM

virtualization
german

#1

Hallo,

ich habe ein frisch aufgesetztes UCS 2.4. System auf einen physikalischen Server, mit UVMM und KVM installiert (Xen abgewählt).
Anschließend auf UCS 2.4-1-1 Stand gebracht.

Im UVMM habe ich keine Profile zur Auswahl,
obwohl diese im UDM unter
/Virtual Machine Manager /Profiles /kvm
vorhanden sind.

Muss noch ein Schritt gemacht werden, damit die Profile im UVMM verfügbar sind?

Grüße,
S.Schulz


Problem mit Betriebssystemen (UVMM)
UVMM: Keine Verbindung zum libvirtd
#2

Hallo,

auf welcher Systemrolle wurde UVMM / KVM Installiert? Ist das System korrekt gejoint?

Könnten Sie bitte einmal die Ausgabe eines ldapsearch -xLLL cn= anhängen? Außerdem wäre Interessant ob es in der UVMM Logdatei (/var/log/univention/virtual-machine-manager-daemon.log) zu Fehlermeldungen kommt.

Mit freundlichen Grüßen
Janis Meybohm


#3

Hallo Herr Meybohm,

System ist alleiniger Domaincontroller Master.

Ich habe jetzt auch ein zweites System, das genau den gleichen Zustand zeigt, hänge daher beide Ausgaben an.

ldapsearch -xLLL cn=anduin
anduin.ldif (1.25 KB)

ldapsearch -xLLL cn=wunstorfgw
wunstorfgw.ldif (1.08 KB)

/var/log/univention/virtual-machine-manager-daemon.log
ist bei beiden Servern komplett leer

Grüße,
s.schulz


#4

Hallo,

das Fehlerbild ist uns so noch nicht bekannt. Hilfreich wären evtl. ein Screenshot des UVMM sowie des “Hinzufügen”-Dialogs. Außerdem wäre Interessant ob bei der Installation des Systems und/oder während des Updates Fehler aufetreten sind (/var/log/univention/installation.log.gz bzw. /var/log/univention/updater.log) und ob beide Systeme auf identischer Hardware aufgesetzt wurden.

Ich würde Sie außerdem bitten die Ausgaben der folgenden Befehle (am besten als Dateien) an diesen Thread zu hängen:

ps aux | grep virt

eval "$(ucr shell)" ldapsearch -xLLL cn=* -b "cn=Profiles,cn=Virtual Machine Manager,$ldap_base" | ldapsearch-wrapper

univention-run-join-scripts
virsh -c qemu://$(hostname -f)/system capabilities

Mit freundlichen Grüßen
Janis Meybohm


#5

Hallo Herr Meybohm,

beide Systeme sind auf unterschiedlicher Hardware aufgesetzt.
Ich beschränke mich bei den logs hier mal auf mein Testsystem.

P.S.: es gehen wohl nicht mehr als 3 Dateianhänge
(daher alle Ausgaben in der ucs.zip)
Die e-mail Benachrichtigung bei neuen Antworten scheint auch nicht zu funktionieren.

Grüße,
S.Schulz
ucs.zip (91.2 KB)



#6

Hallo,

die Ausgabe von virsh -c qemu://$(hostname -f)/system capabilities zeigt dass das System die Virtualisierung mit KVM nicht unterstützt (vermutlich ist eine CPU ohne Hardware-Unterstützung für Virtualisierung verbaut). Daher werden auch keine Profile zur Auswahl angeboten:

<capabilities> <host> <uuid>624e77e9-2cf8-6f97-d511-f4fe4058a55b</uuid> <cpu> <arch>i686</arch> <model>pentium3</model> <vendor>Intel</vendor> <topology sockets='1' cores='1' threads='1'/> <feature name='xtpr'/> <feature name='cid'/> <feature name='pbe'/> <feature name='tm'/> <feature name='ht'/> <feature name='ss'/> <feature name='sse2'/> <feature name='acpi'/> <feature name='ds'/> <feature name='clflush'/> <feature name='apic'/> </cpu> <migration_features> <live/> <uri_transports> <uri_transport>tcp</uri_transport> </uri_transports> </migration_features> </host> </capabilities>

Auf einem System das KVM Gäste unterstützt, finden sich in der Ausgabe entsprechende “”-Blocks, z.B.:

<capabilities> <host> ... </host> <guest> <os_type>hvm</os_type> <arch name='x86_64'> <wordsize>64</wordsize> <emulator>/usr/bin/kvm</emulator> <machine>pc-0.12</machine> <machine canonical='pc-0.12'>pc</machine> <machine>pc-0.11</machine> <machine>pc-0.10</machine> <machine>isapc</machine> <domain type='qemu'> </domain> <domain type='kvm'> <emulator>/usr/bin/kvm</emulator> </domain> </arch> <features> <cpuselection/> <acpi default='on' toggle='yes'/> <apic default='on' toggle='no'/> </features> </guest> </capabilities>

Mit freundlichen Grüßen
Janis Meybohm

PS:
Vielen Dank für die Hinweise. Die maximale Anzahl von Dateianhängen habe ich erhöht und die Benachrichtigungsfunktion werden wir prüfen.


#7

[quote=“Meybohm”]Hallo,

die Ausgabe von virsh -c qemu://$(hostname -f)/system capabilities zeigt dass das System die Virtualisierung mit KVM nicht unterstützt (vermutlich ist eine CPU ohne Hardware-Unterstützung für Virtualisierung verbaut). Daher werden auch keine Profile zur Auswahl angeboten:[/quote]

welchen CPU benötigt man denn mindestens für KVM?
bzw. benötigt Xen weniger CPU Leistung und würde in meinem Fall funktionieren?

nach cat /proc/cpuinfo

System1:
Intel® Xeon® CPU 5110 @ 1.60GHz

System2:
Intel® Pentium® 4 CPU 2.80GHz

Danke,
s.schulz


#8

Eine mit Intel-VT-Unterstützung (de.wikipedia.org/wiki/Intel_Virt … Technology) bzw. eine neuere ADM-CPU (Im Gegensatz zu Intel unterstützen alle ab einem gewissen Datum hervorgebrachten AMD-Modelle Hardware-Virtualisierung).

Mit diesen CPUs kannst du nur Xen verwenden, wobei du da dann auch nur freie Betriebssystem wie Linux, BSD betreiben kannst und kein Windows, da dieses entweder angepaßt werden müßte (was soweit ich weiß doch nicht passiert ist) oder eine eine CPU mit Hardware-Virtualisierung benötigen würde.


#9

Hallo,

danke für die Infos,
da muss ich bei den älteren Systemen wohl erst mal bei VMWareServer Software Virtualisierung bleiben und auf die UCS Integration verzichten.

Danke,
s.schulz