Keine Mailabholung nach Update auf 5 mit OX Fetchmail / No mail collection after update to 5 with OX Fechtmail

Hallo zusammen,
nach dem Update auf Version 5.0 läuft das Fetchmail von OX nicht mehr richtig und holt keine Mails vom externen Mailsserver mehr ab.

Es sieht so aus als ob irgendwas mit der Aushandlung des Protokolls nicht mehr funktioniert.

Kann mir jemand auf die Sprünge helfen was da jetzt schief läuft?

fetchmailrc:

identifier b’LDuemmer’

poll ‘mailservice.wn-onlineservice.de’ with proto imap no dns
user ‘linus.duemmer@cohausz-leuchten.de’ there with password ‘XXXXXXXXXXXXXXX’ is ‘linus.duemmer@cohausz-leuchten.de’ here

Fetchmal ist die Version:
Installierte Version 6.4.0~beta4-3+deb10u1A~5.0.0.202104091504

Im Log bekomme ich folgende Fehlermeldung:

Dez 13 13:47:07 hansolo fetchmail[4108]: mailservice.wn-onlineservice.de:
Dez 13 13:47:07 hansolo fetchmail[4108]: Systemfehler während SSL_connect(): handshake failed at protocol or connection level.
Dez 13 13:47:07 hansolo fetchmail[4108]: mailservice.wn-onlineservice.de: Upgrade auf TLS fehlgeschlagen.
Dez 13 13:47:07 hansolo fetchmail[4108]: Unbekannter Einlogg- oder Authentifikationsfehler bei linus.duemmer@cohausz-leuchten.de@mailservice.wn-onlineservice.de
Dez 13 13:47:07 hansolo fetchmail[4108]: Socket-Fehler beim Abholen von linus.duemmer@cohausz-leuchten.de@mailservice.wn-onlineservice.de

debug-run:
fetchmail: Abfragestatus=2 (SOCKET)
fetchmail: 6.4.0.beta4 fragt mailservice.wn-onlineservice.de ab (Protokoll IMAP) um Mo 13 Dez 2021 13:56:05 CET: Abfrage gestartet
Versuche, mit 94.156.147.32/143 zu verbinden…verbunden.
fetchmail: IMAP< * OK [CAPABILITY IMAP4 IMAP4REV1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] perdition ready on mx01b.wn-onlineservice.de 0002d3a1
fetchmail: IMAP> A0001 CAPABILITY
fetchmail: IMAP< * CAPABILITY IMAP4 IMAP4REV1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS
fetchmail: IMAP< A0001 OK CAPABILITY
fetchmail: Protokoll identifiziert als IMAP4 rev 1
fetchmail: IMAP> A0002 STARTTLS
fetchmail: IMAP< A0002 OK Begin TLS negotiation now
fetchmail: mailservice.wn-onlineservice.de: fetchmail: Systemfehler während SSL_connect(): handshake failed at protocol or connection level.
fetchmail: mailservice.wn-onlineservice.de: Upgrade auf TLS fehlgeschlagen.
fetchmail: Unbekannter Einlogg- oder Authentifikationsfehler bei linus.duemmer@cohausz-leuchten.de@mailservice.wn-onlineservice.de
fetchmail: Socket-Fehler beim Abholen von linus.duemmer@cohausz-leuchten.de@mailservice.wn-onlineservice.de
fetchmail: 6.4.0.beta4 fragt ab mailservice.wn-onlineservice.de (Protokoll IMAP) um Mo 13 Dez 2021 13:56:05 CET: Abfrage beendet
Vereinigte UID-Liste aus mailservice.wn-onlineservice.de:

English
Hi, everyone,
After the update to version 5.0, the OX Fetchmail no longer runs properly and no longer fetches emails from the external mail server.

It looks like something has stopped working with the negotiation of the protocol.

Can someone help me with what’s going wrong now?

fetchmailrc:

identifier b’LDuemmer ’

poll ‘mailservice.wn-onlineservice.de’ with proto imap no dns
user ‘linus.duemmer@cohausz-uchten.de’ there with password ‘XXXXXXXXXXXXXXX’ is ‘linus.duemmer@cohausz-uchten.de’ here

Fetchmal is the version:
Installed version 6.4.0 ~ beta4-3 + deb10u1A ~ 5.0.0.202104091504

I get the following error message in the log:

Dec 13 13:47:07 hansolo fetchmail [4108]: mailservice.wn-onlineservice.de:
Dec 13 13:47:07 hansolo fetchmail [4108]: System error during SSL_connect (): handshake failed at protocol or connection level.
Dec 13 13:47:07 hansolo fetchmail [4108]: mailservice.wn-onlineservice.de: Upgrade to TLS failed.
Dec 13 13:47:07 hansolo fetchmail [4108]: Unknown login or authentication error at linus.duemmer @ cohausz-uchten.de @ mailservice.wn-onlineservice.de
Dec 13 13:47:07 hansolo fetchmail [4108]: Socket error when fetching linus.duemmer @ cohausz-uchten.de @ mailservice.wn-onlineservice.de

debug run:
fetchmail: query status = 2 (SOCKET)
fetchmail: 6.4.0.beta4 queries mailservice.wn-onlineservice.de (IMAP protocol) on Mon 13 Dec 2021 13:56:05 CET: query started
Trying to connect to 94.156.147.32/143 … connected.
fetchmail: IMAP <* OK [CAPABILITY IMAP4 IMAP4REV1 UIDPLUS CHILDREN NAMESPACE THREAD = ORDEREDSUBJECT THREAD = REFERENCES SORT QUOTA IDLE ACL ACL2 = UNION STARTTLS] perdition ready on mx01b.wn-onlineservice.de 0002d3a1
fetchmail: IMAP> A0001 CAPABILITY
fetchmail: IMAP <* CAPABILITY IMAP4 IMAP4REV1 UIDPLUS CHILDREN NAMESPACE THREAD = ORDEREDSUBJECT THREAD = REFERENCES SORT QUOTA IDLE ACL ACL2 = UNION STARTTLS
fetchmail: IMAP <A0001 OK CAPABILITY
fetchmail: protocol identified as IMAP4 rev 1
fetchmail: IMAP> A0002 STARTTLS
fetchmail: IMAP <A0002 OK Begin TLS negotiation now
fetchmail: mailservice.wn-onlineservice.de: fetchmail: System error during SSL_connect (): handshake failed at protocol or connection level.
fetchmail: mailservice.wn-onlineservice.de: Upgrade to TLS failed.
fetchmail: Unknown login or authentication error at linus.duemmer @ cohausz-uchten.de @ mailservice.wn-onlineservice.de
fetchmail: Socket error when fetching linus.duemmer @ cohausz-uchten.de @ mailservice.wn-onlineservice.de
fetchmail: 6.4.0.beta4 asks from mailservice.wn-onlineservice.de (IMAP protocol) on Mon 13 Dec 2021 13:56:05 CET: query ended
United UID list from mailservice.wn-onlineservice.de:

Workaround:
Nach langem suchen habe ich gefunden, das Fetchmail ab der Version 6.4 eine SSL oder TLS aushandlung erfordert.
Die kann man mit dem Eintrag protossl ’ ’ in der fetchmailrc umgehen.

Da aber die Fetchmailrc automatisch vom UCS System erzeugt wird werden die Einträge dann überschrieben.

Die Frage die sich noch stellt ist warum keinen TLS Verbindung hergestellt werden kann, liegt es am Zertifikat auf dem Server?

English:
Workaround:
After a long search I found that Fetchmail version 6.4 or higher requires an SSL or TLS negotiation.
You can avoid this with the entry protossl ‘’ in the fetchmailrc.

However, since the Fetchmailrc is generated automatically by the UCS system, the entries are then overwritten.

The question that still arises is why no TLS connection can be established, is it due to the certificate on the server?