Keine Installation im App Center möglich


#1

Hallo Community,
ich würde gern über das App Center eine App installieren - so weit, so logisch :wink:
Allerdings bekomme ich folgende Fehlermeldung, die das Installieren anscheinend verhindert:

Konnte https://appcenter.software-univention.de/meta-inf/4.2/index.json.gz.gpg nicht herunterladen. Das deutet auf ein Problem auf dem App Center-Server hin. Bitte versuchen Sie es später noch einmal.

Folgendes habe ich nun schon unternommen:

  • Univention als fertige VMWare Maschine herunterladen --> selber Fehler
  • Installation von Version 4.3. über das ISO Image --> selber Fehler
  • Installation von Version 4.2. über das ISO Image --> selber Fehler
  • apt-get update & upgrade

Die Datei gibt es in der Ordnerstruktur auch gar nicht.

Habe ich etwas übersehen?
Oder irgendwas bei der Einrichtung falsch gemacht?

Vielen Dank schon mal!
Gruß Tommy


#2

Guten Morgen,
ich hab gestern Nacht einige Updates gemacht und jetzt das gleiche Problem.

Gruß
Matthias


#3

Huhu,

was wird ausgegeben, wenn Sie auf dem Server folgenen Befehl ausprobieren:

curl -v https://appcenter.software-univention.de/meta-inf/4.2/index.json.gz.gpg > /dev/null

Edit: oh, I see — die Datei gibt es auf dem Server momentan nicht. Wird Univention bestimmt bald fixen.

Gruß
mosu


#4

HTTP/1.1 404 Not Found


* Hostname was NOT found in DNS cache
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying 176.9.114.147...
* Connected to appcenter.software-univention.de (176.9.114.147) port 443 (#0)
* successfully set certificate verify locations:
*   CAfile: none
  CApath: /etc/ssl/certs
* SSLv3, TLS Unknown, Unknown (22):
} [data not shown]
* SSLv3, TLS handshake, Client hello (1):
} [data not shown]
* SSLv2, Unknown (22):
{ [data not shown]
* SSLv3, TLS handshake, Server hello (2):
{ [data not shown]
* SSLv2, Unknown (22):
{ [data not shown]
* SSLv3, TLS handshake, CERT (11):
{ [data not shown]
* SSLv2, Unknown (22):
{ [data not shown]
* SSLv3, TLS handshake, Server key exchange (12):
{ [data not shown]
* SSLv2, Unknown (22):
{ [data not shown]
* SSLv3, TLS handshake, Server finished (14):
{ [data not shown]
* SSLv2, Unknown (22):
} [data not shown]
* SSLv3, TLS handshake, Client key exchange (16):
} [data not shown]
* SSLv2, Unknown (20):
} [data not shown]
* SSLv3, TLS change cipher, Client hello (1):
} [data not shown]
* SSLv2, Unknown (22):
} [data not shown]
* SSLv3, TLS handshake, Finished (20):
} [data not shown]
* SSLv2, Unknown (20):
{ [data not shown]
* SSLv3, TLS change cipher, Client hello (1):
{ [data not shown]
* SSLv2, Unknown (22):
{ [data not shown]
* SSLv3, TLS handshake, Finished (20):
{ [data not shown]
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
*        subject: C=DE; postalCode=28359; ST=Bremen; L=Bremen; street=Mary-Somerville Str. 1; O=Univention GmbH; OU=PremiumSSL Wildcard; CN=*.software-univention.de
*        start date: 2015-08-31 00:00:00 GMT
*        expire date: 2018-11-28 23:59:59 GMT
*        subjectAltName: appcenter.software-univention.de matched
*        issuer: C=GB; ST=Greater Manchester; L=Salford; O=COMODO CA Limited; CN=COMODO RSA Organization Validation Secure Server CA
*        SSL certificate verify ok.
* SSLv2, Unknown (23):
} [data not shown]
> GET /meta-inf/4.2/index.json.gz.gpg HTTP/1.1
> User-Agent: curl/7.38.0
> Host: appcenter.software-univention.de
> Accept: */*
>
* SSLv2, Unknown (23):
{ [data not shown]
< HTTP/1.1 404 Not Found
< Date: Tue, 24 Apr 2018 06:24:13 GMT
* Server Apache/2.4.25 (Debian) is not blacklisted
< Server: Apache/2.4.25 (Debian)
< Content-Length: 327
< Content-Type: text/html; charset=iso-8859-1
<
{ [data not shown]
100   327  100   327    0     0    779      0 --:--:-- --:--:-- --:--:--   780
* Connection #0 to host appcenter.software-univention.de left intact


#5

Huhu,

Ich hab mal einen Bug dafür eröffnet.

Gruß
mosu


Apps aus dem Appcenter nicht installierbar
#6

Hallo,

das Problem ist behoben!

Wir hatten am Wochenende ein Update an unserem Buildsystem vollzogen und hierbei gab es anschließend ein Problem mit dem Signieren der Packages-Dateien. Das Problem zeigte sich nach einem Sync der Dateien auf die öffentlichen Server am späten Nachmittag gestern.

Bitte entschuldigt die dadurch aufgetretenen Unannehmlichkeiten.

Gruß, Nico.