Kein reverse lookup für einen eintrag

german

#1

hallo zusammen,

habe in der reverse zone 2 einträge. die “2” und die “58”. die zwei wird sauber reverse aufgelöst - die 58 leider nicht. siehe screenshot

danke vorab für vorschläge.

gruß

ulf neubauer



#2

Hallo,

nur zum Verständnis: Haben Sie diesen Beitrag komplett neu geschrieben? Ich glaubte hier stand gestern noch etwas von DHCP.

Zur aktuellen Frage: Was steht den konkret bei “58”?

Sie können das auch in der Shell vergleichen:

univention-ldapsearch -b relativeDomainName=58,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunkt,dc=local univention-ldapsearch -b relativeDomainName=2,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunkt,dc=local

Ich hoffe, ich habe die Befehle anhand der Daten aus dem Screenshot richtig zusammengebaut.

Viele Grüße,
Dirk Ahrnke


#3

hallo dirk,

ja - ich habe diesen eintrag mehrfach verändert. während dem tippen kam ich noch auf die ein oder andere idee und habe diese sogleich getestet. am ende war ich mir sicher, dass ich kein dhcp problem habe sondern ein reines DNS problem.

ich habe mir mithilfe ihrer beiden suchabfragen die einträge angesehen und kann keinen fehler feststellen.
KORREKTUR: bei unserem problemkind ist ein eintrag mit der domäne mit leerzeichen in die falsche zeile gerückt:

dn: relativeDomainName=58,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunk t,dc=local

FRAGE: wie wäre ihr stundensatz, wenn sie uns per fernwartung (teamviewer o.ä.) helfen, das problem zu analysieren und ggf. falls möglich zu beheben? ich habe ein ausgeprägtes grundverständnis für diese ganze thematik - komme aber aus der apple/windows welt und tue mich mit univention im speziellen schon etwas hart.
ich wüsste jetzt nicht, in welchen dateien ich suchen muß, wie ich die einträge, die offensichtlich durch die grafische oberfläche FALSCH in die config files übertragen wurden korrigieren kann usw. außerdem muß man noch SEP installieren und konfigurieren - auch hier könnte ich hilfe brauchen. ich würde als “helping hand” vor ort fungieren. muß mir aber noch die freigabe vom kunden holen.

genaugenommen besteht das ganze DNS problem nur, weil wir SEP installieren wollen :slight_smile:
SEP braucht eine saubere DNS auflösung in beide richtungen. SEP soll auf einen windows client installiert werden und von dort aus die daten des SMB shares UND zarafa sichern. als sicherungsmedium hatte unser “open-source”-kollege ein synology NAS vorgesehen. dieses muß ich irgendwie noch mit dem windows 7 rechner verbinden. aktuell verweigert mir windows den zugriff. von einem mac komme ich problemlos drauf :slight_smile: vermutlich sind irgendwelche sicherheitseinstellungen in windows schuld daran. das NAS befindet sich aktuell nicht in der domäne.

hier der ganze code:

[code]root@srv01:~# univention-ldapsearch -b relativeDomainName=58,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunkt,dc=local

extended LDIF

LDAPv3

base <relativeDomainName=58,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunkt,dc=local> with scope subtree

filter: (objectclass=*)

requesting: ALL

58, 106.168.192.in-addr.arpa, dns, vierpunkt.local

dn: relativeDomainName=58,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunk
t,dc=local
objectClass: top
objectClass: dNSZone
relativeDomainName: 58
pTRRecord: RIP-SERVER.vierpunkt.local.
zoneName: 106.168.192.in-addr.arpa

search result

search: 3
result: 0 Success

numResponses: 2

numEntries: 1

root@srv01:~# univention-ldapsearch -b relativeDomainName=2,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunkt,dc=local

extended LDIF

LDAPv3

base <relativeDomainName=2,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunkt,dc=local> with scope subtree

filter: (objectclass=*)

requesting: ALL

2, 106.168.192.in-addr.arpa, dns, vierpunkt.local

dn: relativeDomainName=2,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunkt
,dc=local
objectClass: top
objectClass: dNSZone
objectClass: univentionObject
univentionObjectType: dns/ptr_record
relativeDomainName: 2
pTRRecord: srv01.vierpunkt.local.
zoneName: 106.168.192.in-addr.arpa

search result

search: 3
result: 0 Success

numResponses: 2

numEntries: 1

[/code]


#4

Hallo,

[quote=“uneubauer”]
KORREKTUR: bei unserem problemkind ist ein eintrag mit der domäne mit leerzeichen in die falsche zeile gerückt:

dn: relativeDomainName=58,zoneName=106.168.192.in-addr.arpa,cn=dns,dc=vierpunk t,dc=local [/quote]das ist der Ausgabe von “ldapsearch” geschuldet die immer nach 78 Zeichen umgebrochen wird, ein Problem erzeugt das nicht.

Verwenden Sie Samba3 oder Samba4? Welche UCS-Version setzen Sie ein?

Können Sie evtl. einmal die komplette DNS-Domäne abfragen und die Ausgabe hier anhängen?dig @127.0.0.1 106.168.192.in-addr.arpa -t AXFR

Mit freundlichen Grüßen
Janis Meybohm


#5

Nachtrag:

Bei der weiteren Analyse dieses Problems stellte sich heraus, dass die Listener-/Notifier-Replikation gestört war. Nachdem dies behoben war, funktionierte auch der DNS-Lookup wie erwartet.