Kein Homelaufwerk

german

#1

Guten Tag,

wenn ich mich an dr Domäne anmelde wird den User kein Laufwerk auf den Server zugewiesen. In der Netzwerkumgebung finde ich nur die neetlogon ,sysvol und Drucker Freigaben. Ich habe schon versucht für einen User eine spezielle Einstellung einzutragen und auf dieses Verzeichniss eine Freigabe angelegt. Hat alles nichts geholfen.
Mit “testparms” auf den UCS wird eine Freigabe [homes] angezeigt. Auf welche Verzeichniss im Dateisystem zeigt diese? Kann das der Fehler sein?
Mache ich etwas falsch?
Wo kann ich nach der Lösung suchen?

Vielen Dank im vorraus.

Thomas H.


#2

Welche UCS-Version? Welche Samba-Version?


#3

UCS Version 3.2-1, Free for personal use edition
Active Directory-kompatibler Domänencontroller 4.1


#4

Bei Samba 4 muß der Home-Pfad für jeden User sperat am Benutzerobjekt gesetzt werden. Wurden die entsprechenden Felder in der Sektion Windows im Tab Konto ausgefüllt?


#5

Ich habe es schon mit und ohne Einträge probiert.
Folgendes habe ich jetzt eingetragen:
Laufwerk für das Windows-Heimatverzeichnis: U:
Windows-Heimatverzeichnis: //thhoe105.thhoe.lan/home/thomas
In den weiteren Feldern habe ich nichts eingetragen.


#6

Hallo,

am Benutzer muss das Windows-Heimatverzeichnis auf \$SERVERNAME$USERNAME gesetzt werden, beispielsweise “\master\test1” (Achtung! Backslashes). Optional kann noch das Laufwerk für das Windows-Heimatverzeichnis angegeben werden (“U:”). Die Freigabe \SERVER_NAME\USERNAME gibt es auf allen UCS Samba Server per default.

Weitere Informationen dazu können auch dem Handbuch entnommen werden, docs.univention.de/handbuch-3.2. … ome:samba4 .


#7

Hallo,

hat etwas gedauert mit der Antwort, weil ich den Server neu installiert habe.

  • UCS 3.2-1 errata62 (Borgfeld) als Domän-Master
  • Active Directory-kompatibler Domänencontroller
  • DHCP-Server
  • Zarafa Collaboration Platform
  • Z-Push for Zarafa
  • Fetchmail

Ich habe es noch einmal ohne und mit Einstellungen im Benutzer probiert. Beides ohne Erfolg.
Als Testrechner benutze ich Win-XP-Pro im vmware-player. Das Anmelden in der Domäne war erfolgreich.
Wenn ich im Explorer meine Domäne anschauen will kommt folgende Fehlermeldung:
“Auf xxx kann nicht zugegriffen werden. Sie haben eventuell keine Berechtigung, …”
Der angemeldete User ist aber in der Gruppe der Domän-Admins.
In den Samba-logs sehe ich nicht was mir weiterhilft.
Wo musss ich nach den Fehler suchen? kann mir da jemand einen Tip geben?

Thomas


#8

Mit samba4 geht es nur noch mit den Einstellungen am Benutzerobjekt. Dort sollte für den Benutzer ein entsprechendes Share als “Windows-Heimatverzeichnis” gesetzt sein. Vielleicht prüfen wir zunächst, was am Benutzer-Objekt im Samba4 steht (die Änderungen am Benutzer werden über die UMC in das Samba4 synchronisiert).

Könnten Sie vielleicht die Ausgabe des folgenden Befehls posten (die DN’s können Sie weglassen, es geht nur um die Werte aus homeDrive und homeDirectory)?

univention-s4search cn=$BENUTZER_NAME homeDrive homeDirectory

Können Sie sich über Windows am Share aus “homeDirectory” mit dem Benutzer anmelden?

Ist der Server aus “homeDirectory” auch in die Domäne gejoint (falls es nicht der UCS ist)?

Falls der Server aus “homeDirectory” der UCS ist, gibt es dort die “homes” Freigabe?

testparm --section-name homes  -s

#9

Vielen Dank für die Antwort.

So hatte ich das aus einen der vorigeen Antworten auch verstanden.

homeDrive: u:
homeDirectory: \thhoe105\home\thomas\

Das sind die Werte die ich beim Usert Thomas eingetragen habe.

Nein, ständig die Passwortabfrage, bzw “Der Netzwerkpfad wurde nicht gefunden”.

Es ist dert UCS.

Für mich sieht das so aus. Hier die Ausgabe zum Vergleich:
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section “[netlogon]”
Processing section “[sysvol]”
Processing section “[IPC$]”
WARNING: No path in service IPC$ - making it unavailable!
NOTE: Service IPC$ is flagged unavailable.
Processing section “[homes]”
Processing section “[printers]”
Processing section “[print$]”
Loaded services file OK.
‘winbind separator = +’ might cause problems with group membership.
[homes]
comment = Heimatverzeichnisse
read only = No
create mask = 0700
directory mask = 0700
browseable = No
vfs objects = acl_xattr


#10

Die Standard-Home Freigabe (homes) ist aber über \SERVERNAME\USERNAME erreichbar , nicht über \SERVERNAME\home\USERNAME? Können Sie es bitte einmal mit

\thhoe105\thomas

als Windows-Home versuchen?


#11

Das war es.
Vielen Dank für die Hilfe.


#12

Ich habe zu früh gefreut.
XP funktioniert, Windows7 geht nicht.
Muss ich die Funktion in den Gruppenrichtlinien aktivieren?


#13

Hallo,

[quote=“thhoe”]
Muss ich die Funktion in den Gruppenrichtlinien aktivieren?[/quote]
Nein, das sollte alles automatisch funktionieren, sofern “homeDirectory:” am Benutzer richtig gesetzt und die Freigabe erreichbar ist.

Kann man sich auf dem UCS selbst an der Freigabe anmelden?

smbclient //thhoe105/thomas -Uthomas

Gibt es im Windows7 eine Fehlermeldung? Kann nach der Anmeldung am Windows 7 auf die Freigabe \thhoe105\thomas zugegriffen werden?

Mit freundlichen Grüßen
Felix Botner


#14

Hallo ,

       Ja, das funktioniert.
       Es wird keine Angezeigt. Im Eventlog habe ich folgendes gefunden:

Der Computer konnte eine sichere Sitzung mit einem Domänencontroller in der Domäne THHOE aufgrund der folgenden Ursache nicht einrichten:
Es sind momentan keine Anmeldeserver zum Verarbeiten der Anmeldeanforderung verfügbar.
Dies kann zu Authentifizierungsproblemen führen. Stellen Sie sicher, dass der Computer mit dem Netzwerk verbunden ist. Wenden Sie sich an den Domänenadministrator, wenn das Problem weiterhin besteht.

       Das funktioniert ohne Probleme. Unter XP funktioniert ja auch alles wie erwartet. 

Kann es an meinen Windows liegen? Es ist Win7 pro 64bit.

Mit freundlichen Grüßen,
Thomas


#15

Hallo

mir sind keine Problem diesbezüglich mit Win7 Pro 64 bekannt. Mein Testrechner ist auch ein Win7 Pro 64. Vielleicht könnten Sie den Windows Rechner nochmal neu joinen (Windows Rechner aus der Domäne nehmen, das Rechnerobjekt in der UMC löschen und dann den Windows Rechner wieder joinen)?

Mit freundlichen Grüßen
Felix Botner


#16

Hallo

das neu in der Domäne anmelden hat nichts gebracht. Es scheint ein Problem von Windows7 zu sein. Im Ereignissprotokoll kommen bei jeder Anmeldung der Fehler 5719:

(Der Computer konnte eine sichere Sitzung mit einem Domänencontroller in der Domäne THHOE aufgrund der folgenden Ursache nicht einrichten:
Es sind momentan keine Anmeldeserver zum Verarbeiten der Anmeldeanforderung verfügbar.
Dies kann zu Authentifizierungsproblemen führen. Stellen Sie sicher, dass der Computer mit dem Netzwerk verbunden ist. Wenden Sie sich an den Domänenadministrator, wenn das Problem weiterhin besteht. )

und 1129:

(Bei der Verarbeitung der Gruppenrichtlinie ist aufgrund fehlender Netzwerkkonnektivität mit einem Domänencontroller ein Fehler aufgetreten. Dies kann eine vorübergehende Bedingung sein. Es wird eine Erfolgsmeldung generiert, wenn die Verbindung des Computers mit dem Domänencontroller wiederhergestellt wurde und wenn die Gruppenrichtlinie erfolgreich verarbeitet wurde. Falls für mehrere Stunden keine Erfolgsmeldung angezeigt wird, wenden Sie sich an den Administrator.)

Bei Mikrosoft gibt es dazu einen Artickel (support.microsoft.com/kb/2459530), der Hotfix dazu behept das Problem bei mir nicht. Im Moment habe ich die Freigabe über den Explorer verbunden.

Mit freundlichen Grüßen,
Thomas


#17

Hallo,

leider ist es mir immer noch nicht möglich das Verhalten zu
reproduzieren. Ich vermute ein Problem auf Windows Client Seite. Als
nächstes könnte man prüfen, welche Daten wirklich über das Netzwerk
verschickt werden, bspw. via wireshark.

Das können wir aber leider nicht so ohne weiteres im Forum durchführen.
Angebote diesbzgl. sind hier zu finden:
(univention.de/download-und-s … tangebote/).

Mit freundlichen Grüßen
Felix Botner