Kein gültiger vollqualifizierter Domänenname, versch. Szenar

german

#1

Hallo,

In meiner Testumgebung erhalte ich, wenn ich einen Drucker hinzufügen will folgende Fehlermeldung

Die folgenden Eigenschaften konnten nicht validiert werden: Server: kein gültiger vollqualifizierter Domänenname

Mein Aufbau:
UCS-1001 als Primary DC - IP: 10.10.1.1
FQDN: ucs-1001.4454454.lrs.mydomain.net
Derzeit Installierte Apps: Active Directory-kompatibler Domaincontroller; Nertzwerküberwachung Nagios; RADIUS; Software Installationsmonitor; UCS Virtual Machine Manager

UCS-1002 als Memberserver - IP: 10.10.1.2
Hostname: ucs-1002
Installierte Apps: Druckserver (CUPS)

Wenn ich nun wie oben erwähnt einen Drucker via UMC auf ucs-1001 hinzufügen will, trage ich die entsprechenden Daten ein und wähle aus der Liste (Server) den Memberserver “ucs-1002.4454454.lrs.mydomain.net” aus. Wenn ich das ganze jetzt Speicher erhalte ich die oben genannte Fehlermeldung.

Kurz zur Erklärung der Domain:
dc=ucs-1001 = Hostname zur lokalen Identifizierung der Server
dc=4454454 = Identifikationsnummer (Vergleichbar etwa einer art Kundennummer)
dc=lrs = Local Root Server (alternativ “rs” zur Identifizierung gehosteter Rootserver, hier keine Relevanz)
dc=mydomain.net = Von Webhoster verwaltete Domain

Das einzig vergleichbare bzgl. des Wortlautes der Fehlermeldung https://forge.univention.org/bugzilla/show_bug.cgi?id=24069habe ich hier gefunden, jedoch keine Ahnung ob das irgendetwas damit zu tun hat

UPDATE von 23:02 Uhr:
In einem weiteren Test, den Druckserver direkt auf dem DC Master zu installieren, führt zum selben Ergebnis

Hat jemand einen Ansatz, was ich prüfen könnte, oder gibt es evtl. Einschränkungen in der Vergabe des Domänennamens, Länge?


#2

Es scheint am Domänennamen zu liegen. Ich habe jetzt eine neue Testumgebung erstellt und der DC Master hat nun “ucs-1001.mydomain.com” und er meckert nicht mehr rum.

Schade nur dass man entgegen des Prinzips verschachtelter Strukturen nicht so weit in die Tiefe gehen kann.

Weiteres Szenario wäre jetzt noch mal was mit “ucs-1001.server.mydomain.com” ist und “uc1.sub3.sub2.sub1.fqdn.de”, um zu testen obs an der Anzahl der dc’s liegt oder einfach am input und den damit verbundenen max-chars


#3

Das sieht nach diesem Issue aus: forge.univention.org/bugzilla/s … i?id=38378. Wenn ja, dann müsste es bspw. mit so einem Eintrag funktionieren: ucs-1001.i4454454.lrs.mydomain.net, also ein Buchstabe vor der Identifikationsnummer.


#4

Danke für den Hinweis, das werde ich nachher gleich mal testen.

BTW: ucs-1001.k4454454… stand sogar auf meinem Mockup, hatte es allerdings dann vergessen und dann wars erstmal eh zu spät :wink:


#5

So, ich habe jetzt noch einmal alles neu aufgesetzt mit dem Eintrag ucs-1001.k4454454.lrs.mydomain.net und einige Drucker eingerichtet.

Es funktioniert jetzt!

@Gohmann Danke nochmals