Kein Desktop

german

#1

Hallo,

als absoluter Neuling im Bereich UCS und Linux brauche ich gleich zu Anfang etwas Hilfe:

Ich habe die UCS Core Edition installiert, boote das erste Mal und lande automatisch auf der Seite ‘Willkommen auf Univention Corporate Server’. So weit so gut. Ich habe die Option ‘Suchen Sie nach einer Kommandozeile?’, sonst keine. KDE Desktop habe ich bei der Installation angewählt. Das Verkleinern des Firefoxfensters mittel F11 zeigt, dass im Hintergrund eine schwarze Oberfläche ohne jegliche Steuerelemente zu sehen ist…

Ergo habe ich die Möglichkeit mit der Kommandozeile zu arbeiten, oder mittels neuem Firefox - Tab in die UCS Managementoberfläche zu gelangen, aber nicht mit den Desktopelementen zu arbeiten.

In Virtualbox hat das schon mal geklappt, nun auf echter Hardware (128 GB SSD, Pentium Haswell 3.2GHz, 8GB Ram) leider nicht…

Hat jemand eine Idee, wo das Problem ist oder wie eine Lösung aussehen könnte?

Danke und Gruß


#2

Hallo,
Kurz vorweg:
Üblicherweise würden Sie nicht auf dem Server selbst per KDE o.ä. arbeiten (es sei denn in Ausnahmefällen auf der Konsole bei bestimmten Aktionen - welche wiederum oft auch per SSH aus der Ferne erledigt werden können). Sie würden per Browser von einem “entfernten” Rechner im selben Netz die UMC starten (also per Browser auf die IP Adresse des Servers). Gibt es hier einen bestimmten Grund warum Sie die KDE auf dem Server benötigen?

Mit freundlichem Gruß,
Jens Thorp-Hansen


#3

Ich würde UCS gern in Zukunft für ein kleines Unternehmen nutzen und würde daher gern den vollen Funktionsumfang ausprobieren können, auch wenn die UMC wohl die zentrale Plattform für die Konfiguration des Servers ist (und ich diese ja auch problemlos über Firefox erreiche)…

Und: Ich habe zuerst eine Virtualbox - Installation ausprobiert und hatte da problemlos Zugriff auf den Desktop - da das nun nicht mehr der Fall ist, hatte ich einen Fehler vermutet…


#4

Hallo,
Die Virtualbox Installation ist hier nicht wirklich ein Vergleich zur “echten” Core Edition. Die Virtual Box ist wirklich nur zum Testen.
Bei UCS und wahrscheinlich auch Linux im Allgemeinen sollten Sie sich von der Idee lösen die Server direkt auf dem Server selbst zu administrieren - das erfolgt standardgemäß und vollumfänglich (voller Funktionsumfang) über die UMC bei UCS.

Es ist natürlich möglich auch auf UCS eine KDE installieren und zu starten (wenn KDE installiert ist sollte die Oberfläche aus der Konsole mit “kdm” zu starten sein), allerdings sollten Sie hier dann keine Oberfläche wie bei Windows Server erwarten - Die Steuerung würde dann trotzdem über die UMC erfolgen. Das heisst Sie starten die KDE, dann Firefox und die UMC. Das geht auch einfacher. :wink:

Mit freundlichem Gruß,
Jens Thorp-Hansen


#5

Hallo,

erst einmal danke für die prompte Antwort! Da sich interessanterweise nun nach dem letzten Neustart der Desktop gezeigt hat, ist das Thema wohl gelöst - auch wenn ich irgendwie nicht aktiv dazu beigetragen habe… :wink:

Ich werde mich gedanklich auf die UMC konzentrieren und ggf. die Oberfläche mit dem ‘KDM’ - Befehl starten, sollte sie nochmal verschwinden.

Gruß aus dem Süden!


#6

Nachtrag noch einmal: Offensichtlich verhält sich das Starten / Anzeigen der Desktopoberfläche auf dem UCS nach Lust und Laune. Manchmal erscheint sie nach einem Neustart des Servers, jedoch meistens nicht. Ich kann nicht feststellen, wovon das abhängt. Ich habe jedenfall gesehen, dass der Prozess ‘KDM’ läuft, und ihn probeweise geschlossen (KILL - Befehl). Der Versuch eines Neustarts mit Befehl ‘KDM’ ergibt folgende Fehlermeldung:

‘Die Design-Datei @@@ToBeReplacedByDesktopBase@@@ kann nicht geöffnet werden’

Hat jemand weitere Tipps für mich?

Grüße!


#7

[quote=“stebeck”] Ich habe jedenfall gesehen, dass der Prozess ‘KDM’ läuft, und ihn probeweise geschlossen (KILL - Befehl). Der Versuch eines Neustarts mit Befehl ‘KDM’ ergibt folgende Fehlermeldung:

‘Die Design-Datei @@@ToBeReplacedByDesktopBase@@@ kann nicht geöffnet werden’
[/quote]

Die KDE besteht nicht nur aus einem einzelnen Prozess, daher führt das “Abschiessen” des einzelnen KDM Prozesses und das anschließende Starten dann nicht zu einem normalen Start.
Sie soll aber natürlich normalerweise starten wenn man diese installiert hat - folgende Logdateien können hier Aufschluss geben:

var/log/syslog
var/log/xorg.x.log

wiki.ubuntuusers.de/dmesg kann ebenfalls helfen.

Mit freundlichem Gruß,
Jens Thorp-Hansen