Joining Without Univention Client

Hi everyone,

I’ve joined my Ubuntu/Fedora/etc workstation using SSSD to UCS. The issue is that they currently shows up as “Windows Workstation/Server” under the type column of the Computer menu/list.

I had previously tried the Univention client on Ubuntu 18.04, and that column was set correctly when using the Univention client. Thus, the client must be setting something that allows UCS to set the type as Ubuntu/Linux. I tried to look through client code to see what value is being set so that this is displayed correctly, to no avail.

Does anybody know where this info/value is stored? I’d love it if SSSD would work correctly for this, as I’d like to reliably join more than just Ubuntu as a Linux client.

Cheers

Did you followed the handbook? https://docs.software-univention.de/domain-4.4.html

1 Like

I’ve gone through all of it, and as far as I can tell SSSD has configured all the correct settings.
Could you point me to which section tells UCS that the workstation is a Linux machine in the type column?
Cheers

edit: Appears to be this, actually


# Create an account and save the password
password="$(tr -dc A-Za-z0-9_ </dev/urandom | head -c20)"
ssh -n root@${ldap_master} udm computers/ubuntu create \
    --position "cn=computers,${ldap_base}" \
    --set name=$(hostname) --set password="${password}" \
    --set operatingSystem="$(lsb_release -is)" \
    --set operatingSystemVersion="$(lsb_release -rs)"
printf '%s' "$password" >/etc/ldap.secret
chmod 0400 /etc/ldap.secret

My assumption then is that the “Windows Workstation/Server” type is simply a default that UCS applies. I’ll have a look and try this out with a VM.

I thought I would share the script I created to automate this stuff a little bit. My testing was on Ubuntu 20.04. See https://github.com/ABotelho23/UCS_domain_join

1 Like