Issues Domain Join Mint 21.1

Hi UCS Team,

I would like to share my todays experience of the domain join tool for Linux Mint 21.1.

To join the Clients I installed the univention-domain-join package like suggested in the github repo.

sudo add-apt-repository ppa:univention-dev/ppa
sudo apt-get update
sudo DEBIAN_FRONTEND=noninteractive apt-get install univention-domain-join

When I ran univention-domain-join it complained about a missing /etc/ldap/ldap.conf file, which was not there.
I installed also libldap-common to have the file in place. So the domain join could find the file and write it’s content to it. Not sure if this shouldn’t be added as dependency of the univention package or if there is a different issue within one of the scripts to join UCS.

After that I had some other issues, which I was not able to debug, because my time at this voluntary project at a small community driven school is very limited. But I couldn’t login as ucs user into the system eventough the domain join didn’t complain.

I had to install also additional dependencies before the domain join, to get the user login to work properly.

sudo apt install heimdal-docs heimdal-kcm python3-sniffio python3-trio adcli sssd-tools libsasl2-modules-ldap

Not sure which package fixed it… but after this, ucs users where able to login again, and fresh users where created again at the client system.

I used univention-domain-join-cli after some failures with the gui…
UCS version 5.0-3

If I can help with more information, I will try to add more precise information if needed.
Thank you,