iSCSI wechselt bei Last in Read-Only

virtualization
german

#1

Hallo,

ich habe eine UVMM erstellt (Ubuntu 14.04). Diese soll auf mein NAS (Netgear NAS) auf eine Platte zugreifen, die ich als iSCSI im Netzwerk bereitstelle.

Im System wird dies dann als SDB angebunden. Anfangs funktioniert auch alles sehr gut. Nur wenn ich massenveränderungen vornehme, dann kommt es dazu, das das Gerät in den Read-Only-Modus springt. Ich habe mal ein Log beigefügt. Kann mir jemand einen Tipp geben, wie ich das Laufwerk wieder zuverlässig verbunden bekomme?

[quote][ 1.044190] sd 0:0:0:0: [sda] 41943040 512-byte logical blocks: (21.4 GB/20.0 GiB)
[ 1.046372] sd 0:0:0:0: [sda] Write Protect is off
[ 1.048507] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 1.048746] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 1.051136] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
[ 1.101923] sda: sda1 sda2 < sda5 >
[ 1.104779] sd 0:0:0:0: [sda] Attached SCSI disk
[ 12.267263] EXT4-fs (sda1): mounting ext2 file system using the ext4 subsystem
[ 12.293054] EXT4-fs (sda1): mounted filesystem without journal. Opts: (null)
[ 13.869639] fb: switching to cirrusdrmfb from EFI VGA
[ 13.910630] fbcon: cirrusdrmfb (fb0) is primary device
[ 14.281280] cirrus 0000:00:02.0: fb0: cirrusdrmfb frame buffer device
[ 17.500965] sd 2:0:0:0: [sdb] 5755876568 512-byte logical blocks: (2.94 TB/2.67 TiB)
[ 17.503310] sd 2:0:0:0: Attached scsi generic sg1 type 0
[ 17.512725] sd 2:0:0:0: [sdb] Write Protect is off
[ 17.512745] sd 2:0:0:0: [sdb] Mode Sense: 43 00 10 08
[ 17.513915] sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, supports DPO and FUA
[ 17.580089] sdb: sdb1
[ 17.591287] sd 2:0:0:0: [sdb] Attached SCSI disk
[ 17.963634] EXT4-fs warning (device sdb1): ext4_clear_journal_err:4762: Filesystem error recorded from previous mount: IO failure
[ 17.963641] EXT4-fs warning (device sdb1): ext4_clear_journal_err:4763: Marking fs in need of filesystem check.
[ 17.971252] EXT4-fs (sdb1): warning: mounting fs with errors, running e2fsck is recommended
[ 18.055980] EXT4-fs (sdb1): recovery complete
[ 18.078724] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[ 259.705716] sd 2:0:0:0: [sdb] FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 259.705782] sd 2:0:0:0: [sdb] Sense Key : Not Ready [current]
[ 259.705794] sd 2:0:0:0: [sdb] Add. Sense: Logical unit communication failure
[ 259.705806] sd 2:0:0:0: [sdb] CDB: Write(16) 8a 00 00 00 00 00 ab 84 20 08 00 00 40 00 00 00
[ 259.705812] blk_update_request: I/O error, dev sdb, sector 2877562888
[ 259.707519] Aborting journal on device sdb1-8.
[ 259.711772] EXT4-fs error (device sdb1): ext4_journal_check_start:56: Detected aborted journal
[ 259.711935] EXT4-fs (sdb1): Remounting filesystem read-only
[/quote]

Lg
Michael


#2

Ich hab auf der Suche nach der Lösung folgendes gefunden, was meiner Beschreibung sehr nahe kommt

https://groups.google.com/forum/#!msg/open-iscsi/UE2JJfDmQ7w/mPZUmCiTEgAJ

Leider kann ich aber nicht erkennen, was nun die Lösung zu sein scheint. Vielleicht kann ja jemand sich da mal einlesen und bestätigen/dementieren, das es sich hier um mein Problem handelt.

Außerdem habe ich folgende Artikel noch gefunden:

http://docs.software-univention.de/uvmm-3.2.html
http://qemu-buch.de/de/index.php?title=QEMU-KVM-Buch/_Speichermedien/_iSCSI

Diese beiden Artikel legen nahe, das ich die Verbindung zum iSCSI Laufwerk nicht IN DER VM mache, sondern schon bei der Definition welche Laufwerke die VM verwenden soll.

Ist das die eigentliche Lösung?


#3

Nur der Vollständigkeit halber (falls andere auf diesen Thread stoßen):

wenn man das iSCSI-Device an den Host koppelt und dann als Laufwerk der VM zur Verfügung stellt, dann funktioniert es perfekt - auch unter Last

Hier nochmal der Link aus der Doku, der das Vorgehen sehr gut beschreibt: http://docs.software-univention.de/uvmm-3.2.html