Installed Apps in subdomains

Fresh install of UCS 4.4 and Nextcloud Hub.

I’m trying to configure my server so that hostname.domain.whatever brings me to my UCS management page and nextcloud.domain.whatever brings me to the Nextcloud instance.

I followed all of the instructions here without any errors and configured DNS to point nextcloud.domain.whatever at my server’s IP. I also changed the overwrite and rewrite parameters in the Nextcloud container’s config.php as described here.

However visiting nextcloud.domain.whatever brings up the management page instead of Nextcloud. Nextcloud can be accessed at nextcloud.domain.whatever/nextcloud.

What might be the problem?

Can you post your apache vhost config for nextcloud?

Best, Bernd

/etc/apache2/sites-available/nextcloud.conf - Pastebin.com

If you have the config enabled so that it is linked to /etc/apache2/sites-enabled/nextcloud.conf I don’t see why it isn’t working.

There is no mention of sites-enabled in either of the posts I linked to nor does the file exist on my server. Do I need to a2enmod /etc/apache2/sites-available/nextcloud.conf ? I assumed the ucr commit script would do whatever was needed publish the site how I configured.

Yes, you are right - that point is missing but nevertheless necessary. Also a reload of apache afterwards.

Ran a2ensite nextcloud with no errors and restarted Apache. nextcloud.domain.whatever does not load with err_too_many_redirects. nextcloud.domain.whatever/nextcloud works–which is not the desired result.

Scrapped my installation and since I couldn’t get things to work and am now starting with a fresh UCS 5. Followed the exact same steps as above and after running ucr commit … received error

File “”, line 22
‘’’ % {‘id’: app.id, ‘web_interface’: web_interface, ‘web_port’: host_port, ‘scheme’: scheme}
^

What could be the problem now?

SyntaxError: invalid syntax

This is the string with the syntax error is:

‘’’ % {‘id’: app.id, ‘web_interface’: web_interface, ‘web_port’: host_port, ‘scheme’: scheme}

There is a carot underneath the third quote mark. I tried removing it and ucr commit threw a different error. What syntax error is present?