Installation - späterer Join: Validierungsfehler

german

#1

Hallo,

ich bin dabei, einen zweiten UCS aufzusetzen. Der soll später als Slave arbeiten.
Zum Zeitpunkt der Installation hat der Server jedoch keine Verbindung zum Domänennetzwerk. Das soll erst via VPN geschaffen werden. Wenn UCS installiert ist.

Lt. doku kann man den Join ja auch später durchführen. Dummerweise meckert mir der Installer jedoch:

Das stimmt ja, aber ich kann nur noch “Zurück”.

Wie kriege ich den UCS denn installiert, ohne dass er Domänenanbindung hat?

Danke!


#2

Hallo knebb,

benutzt Du zufällig zum Installieren deines neuen UCS die aktuelle Installations-ISO ?

Mir ist bei dieser aufgefallen, das bei der Abfrage der Rolle des Servers der Punkt “Keine Domäne benutzen” gar nicht mehr existiert.

Weiterhin ist mir bei der aktuellsten ISO auch noch ein Fehler aufgefallen, den ich allerdings erst noch überprüfen möchte.
Hierzu werde ich allerdings einen eigenen Thread erstellen.

Im Moment benutze ich eine ältere Installations-ISO, bei der diese Punkte nicht auftreten.
Die hatte ich hier zum Glück noch herumliegen.

Ich weiss jetzt auch nicht, ob und wie man bei Univention an ältere ISOs kommt.

Viele Grüße,

O. Bertgen


#3

Hallo knebb,

muss mich korrigieren … es gibt bei der Installation doch
den Punkt “Keine Domäne benutzen”.

O. Bertgen


#4

Den sollte knebb AFAIK aber nicht nutzen, da er AFAIK für Systeme gedacht ist, die nie einer Domain beitreten sollen (hieß früher Basissystem). Sollte ich mich irren, so möge man mich korrigieren.

@knebb Als Workaround sehe ich folgende Möglichkeiten:
[ul]
[li] Eine temporäre Verbindung zum DNS des Masters[/li]
[li] Die Installation eines Test-Masters mit den passenden Daten (Domainname etc.)[/li]
[li] Die Verwendung eines Clones des Masters[/li][/ul]


#5

[quote=“SirTux”]Als Workaround sehe ich folgende Möglichkeiten:
[ul]
[li] Eine temporäre Verbindung zum DNS des Masters[/li]
[li] …[/li][/ul][/quote]

Als Variante hätte ich noch, die Maschine im Domänennetz grundsätzlich durchzuinstallieren und sie dann erst remote aufzustellen.
Dort dann das VPN aktivieren und den Join zu wiederholen.


#6

Diese Variante geht natürlich auch. Ich ging aber davon aus, daß der OP zunächst keine unkontrollierte Verbindung vom neuen Slave zum Netzwerk will.


#7

Hallo,

habe es jetzt so gemacht, dass ich die Kiste lokal installiert habe, dann die Firewallregeln via Registry-Setting entfernt habe (und damit alles außer https und ssh geblockt ist). localhost scheint zu funktionieren.

Dann das Image auf den Internetserver transferiert und gestartet. Läuft soweit erst einmal. OpenVPN installiert und die IP Verbindung zum Domänen-Master steht.

Allerdings kämpfe ich mit den DNS Einstellungen. der via OVPN übergeben DNS Server ist nur zusätzlich- das System nutzt auch noch den via /etc/resolv.conf eingetragene DNS Server und löst damit die lokalen Rechner falsch auf. Ich kann aber auch die öffentlichen dort nicht rausnehmen, weil sonst OVPN seinen Server nicht findet.

Jetzt habe ich ein Loch in die Firewall zu Hause gebohrt und kann die internen Domäns ganz regulär darüber auflösen. Allerdings verweigert der Domänenmaster bei nicht-Domänenabfragen dem client die Zusammenarbeit:

Sep  4 20:22:17 abc named[3246]: client 188.x.y.z#45441: query (cache) 'www.heise.de/A/IN' denied

Wo kann ich das einstellen, dass der DNS auch Clients außerhalb seiner Netzwerke versorgt?


#8

Update: Frage beantwortet, Problem gelöst.

Die zuständige UCS Variable lautet dns/allow/query/cache
Dieser habe ich jetzt mit /32 noch die öffentliche IP meines Servers hinzugefügt und nun beantwortet er alle DNS- Anfragen :smiley:

So, dann mal weiter und schauen, ob das jetzt funktioniert.