Install or Update python auf Version 3.9

Hallo,
ich würde gern auf einem UCS School Memberserver die aktuelle Version von python installieren um über einen python-pip Installation ein Programm zum DynDNS Sync zu installieren.
Leider bekomme ich beim Versuch python3.9 über den Befehl univention-install python3.9 zu installieren folgende Fehlermeldung:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
postgresql-plpython3-9.1 : Hängt ab von: libpython3.4 (>= 3.4.2~rc1) soll aber nicht installiert werden
postgresql-plpython3-9.4 : Hängt ab von: libpython3.4 (>= 3.4.2~rc1) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Ich habe auch bereits die unmaintained Pakete freigeschaltet.

Was mache ich falsch? Warum lässt er die Installation nicht zu?

Danke für einen Hinweis und eine kurze Hilfestellung.
Viele Grüße