IMAP/SMTP Authentication failure

mail
german

#1

Ich verzweifle an folgender Situation und hoffe auf einen hilfreichen Hinweis oder eine Lösung des Problems.

Ich habe UCS mit OX Community installiert und soweit läuft es auch. Ich kann mich per IMAP mit einem lokalen Mail-Client und auch über die App Suite problemlos einloggen. Fetchmail funktioniert auch problemlos - die Mails werden abgefragt, den Postfächern zugeordnet und Mails versenden über eine Relay funktioniert auch. Nur die Verbindung zum SMTP funktioniert vom Client aus nicht.

Diese Meldung wird ausgegeben:

[quote]Could not connect to SMTP host: xxx.xxx.xxx.xxx, port: 587.
ECONNREFUSED (Connection refused)
(isConnected failed: ECONNREFUSED (Connection refused))[/quote]

Dieselbe Meldung erscheint, wenn ich ohne TLS/SSL und auf Port 25 verbinden will. Was mache ich falsch? Habe ich irgendwelche Einstellungen vergessen?


#2

Habe das Problem lösen können. In der Datei master.cf fehlte die Port-Angabe für den SMTP-Dienst. Und der Port 587 ist standardmäßig weder in den Postfix-Einstellungen, noch in den ipTables freigegeben.

Der Eintrag für SMTP-Port 25 in der master.cf sollte so aussehen:

25        inet  n       -       n       -       -       smtpd

#3

Hallo,

Port 587 ist im Moment nicht per default an. Es gibt einen Enhancement-[bug]30043[/bug], aber offensichtlich nicht genügend Interesse seitens der Kunden, das zu implementieren.
Wobei eine Änderung für das eigene System auch ziemlich einfach durch entfernen des Kommentars bei Zeile 35 in /etc/univention/templates/files/etc/postfix/master.cf.d/10_services machbar ist.

Nicht ganz nachvollziehbar ist das Fehlen der Port 25-Zeile.

[code]root@meister:/etc/univention/templates/files/etc/postfix/master.cf.d# head 10_services
@%@UCRWARNING=# @%@

==========================================================================

service type private unpriv chroot wakeup maxproc command + args

(yes) (yes) (yes) (never) (50)

==========================================================================

@!@
smtp = ‘%s inet n - n - - smtpd’ % configRegistry.get(‘mail/smtpport’, ‘25’)
if configRegistry.is_true(“mail/postfix/smtpd/debug”, False):
smtp += " -v"
[/code]
Das dürfte eigentlich immer eine Konfiguration erzeugen.
Sie sollten ggf. mal ein ucr commit /etc/postfix/master.cf ausführen und schauen, ob die master.cf noch passt. Wenn Sie das Template wie oben beschrieben ändern, müssen Sie da sowieso machen. Eine manuelle Änderung der Konfiguration in /etc/postfix ist ungünstig weil nicht dauerhaft.

Viele Grüße,
Dirk Ahrnke


#4

Hallo,

die Zeile für Port 25 fehlte nicht gänzlich, sondern es war nicht “25” eingetragen. Stattdessen stand an der Stelle auch “smtp”, was aber wohl nicht aufgelöst wurde. Nachdem ich das geändert hatte funtionierte es. Ich prüfe jetzt auch das Template nochmal, konnte in den letzten Tagen aber kein Problem damit mehr feststellen.

Viele Grüße,
Sören Wiechert


#5

Interessant wäre auch die Ausgabe von

ucr search --brief smtpport

Wenn das Resultat nicht “” ist, sondern vielleicht sogar “smtp”, kann man zumindest mal suchen, wann das gesetzt wurde

zgrep smtpport /var/log/univention/config-registry.replog*


#6

:~# ucr search --brief smtpport mail/smtpport:

:~# zgrep smtpport /var/log/univention/config-registry.replog* /var/log/univention/config-registry.replog.1.gz:2014-05-31 12:30:56: set mail/smtpport=587 old:[Previously undefined] /var/log/univention/config-registry.replog.1.gz:2014-05-31 12:36:09: set mail/smtpport='' old:587 /var/log/univention/config-registry.replog.1.gz:2014-05-31 13:35:57: set mail/smtpport=587 old: /var/log/univention/config-registry.replog.1.gz:2014-05-31 13:43:22: set mail/smtpport=25 old:587 /var/log/univention/config-registry.replog.1.gz:2014-05-31 14:34:04: set mail/smtpport='' old:25 /var/log/univention/config-registry.replog.1.gz:2014-05-31 15:34:56: set mail/smtpport=587 old: /var/log/univention/config-registry.replog.1.gz:2014-05-31 22:20:24: set mail/smtpport=465 old:587 /var/log/univention/config-registry.replog.1.gz:2014-05-31 23:15:57: set mail/smtpport='' old:465
Das sieht nach meinen eigenen Versuchen aus…


#7

Damit wäre die Ursache gefunden. Im Template steht “nimm den Wert von mail/smtpport”. Das ist eine leere Zeichenkette.

Richtig wäre hier:

ucr unset mail/smtpport

Oder halt “25”.

Viele Grüße,
Dirk Ahrnke


#8

Vielen Dank! Wieder was gelernt!