HP ProLiant BL2 mit StorageWorks MSA1000 (qla2xxx)

hardware
german

#1

Hallo,
hab Probleme gehabt, eine MSA1000 an einem HP Blade ans Laufen zu bekommen, bin aber gerade beim Verfassen einer Supportemail auf die Lösung gekommen:

Beim laden des Kernelmoduls qla2xxx kam es immer zu abbrüchen:

qla2xxx 0000:01:03.1: Mailbox command timeout occured. Issuing ISP abort.
qla2xxx 0000:01:03.1: Performing ISP error recovery - ha= f59982c0.
qla2xxx 0000:01:03.1: LIP reset occured (f7f7).

UCS hatte nach der Installation in der lilo.conf den Kernelparameter pci=noacpi eingesetzt und so wurden die beiden qla2312-Controller auf den gleichen Interrupt gelegt, was anscheinend die Probleme verursacht hat. Nach einem reboot ohne diesen Parameter (habe noch den Parameter acpi_irq_balance angegeben, müsste aber auch ohne gehen) funktioniert nun alles.

btw: hat jemand (debian-)start-stop-Scripte für den sansurfer-agent (qlremote)? (hab ehrlich gesagt noch nicht nach gegooglet, bin aber auch (wie gesagt) grad erst auf die Lösung meines Problems gekommen :slight_smile:

Falls mal andere vor gleichem Problem stehen sollten, hab ich mir gedacht, doch noch eben grad diesen Beitrag zu schreiben. (Mich hat dieser am Ende doch recht simple Fehler einen Tag suchen/compilieren/ausprobieren gekostet)

Gruss
Michael Heide


#2

Das Problem tritt bei allerlei Kombinationen von Kernelversion auf: (univention-2.6.14/kernel.org-2.6.16/17, Kernelinternem qla2xxx und qla2xxx-Versionen direkt von QLogic)

Und acpi_irq_balance scheint hier zumdindest notwendig zu sein.