How to share samba folder with windows 10 host machine in hyper-v UCS virtual machine

samba
hyper-v
ucs-4-3

#1

Hello.
I’m running UCS 4.3 VM on Hyper-V (Windows 10).
Here is my VM:
image

I can get to UCS, by using http://192.168.2.92 in windows os browser.
I’ve shared folder like this: Domain -> Shares -> Add.

That’s how my share looks like:
image
image

What is next? How can I use this shared folder in my host os?
I’ve tried like this:
image

But no luck!

Thank you for any help.


#2

Hi melashkina,

please find below my settings that are working for me (quite similar to yours):

share1
samba

To access the share from my Win10-machine I simply type \\SERVER-NAME\Gruppen in the search-box (you can use IP-address instead of server name as well):

win10

BR,
Thomas


#3

Hi, thank you for your answer.
I’m still not able to connect. Maybe it’s somehow connected with Hyper-V? What kind of virtual switch are you using?


#4

Hi, im using Hyper-V on Windows Server 2016. Did you tried to connect from the same machine (from the server itself)? What is the setting of your virtual Hyper-V switch - external?


#5

Hi,

The first question is, whether or not the problem is reaching the server or the share.

For the server, try to connect to the server, so in your case \\192.168.2.92
Please note, that depending on the installation time, Windows version and settings on the machine, you will have to use Backslash. Thus, the slashes in your run box screenshot might be part of the problem.

If you can connect to the server, check, whether there is a firewall in between the client and server. Can you open the UMC from your client http://192.168.2.92 ? The second question, check whether samba is running on the server. In the management console, go to System -> System Services and search for Samba 4.

If you can reach the server, but do not see the share, then the problem is in the share itself. My first guess would be, that the underscore is producing issues. Try to rename the Windows Name to something without the underscore.

Best,

Kevin


#6

\\192.168.2.92 - doesn’t work for me.
But I can connect to UCS from windows browser via http://192.168.2.92

Looks like Samba 4 is not installed (System -> System Services):
image


#7

Hi,

The error is that you don’t have the needed software installed. As your UMC is on the same server as your share, I assume, that this is your Master (or a Backup or Slave)

In the UMC, go to Software -> AppCenter.

Appcenter_path

Here enter “Samba” and select “Active Directory -compatible Domain Controller.”

AD

In the Next Menu Select Install and confirm the dialogs.

Install

Once the server installed the software, you should be able to access the share.

Best,

Kevin

PS: you should be able to access the UMC from any browser, that can reach the server. No need to go through the Hyper-V console, log into the desktop environment and start a browser there.


#8

Finally it’s there. Thank you very much!
image


#9

Hi, Kevin.
Thank you for help. One more question.
I can connect to vm. But I’m asked for PIN. Like here:
image
After I give pin (I’m sure, that PIN is right), I get this message:
image

I’ve also tried Admisitrator and root users, but no luck. Should I add my user somewhere?

UPDATE:
Resolved this issue like this:
Edited samba config file directly in the terminal.
public is set to yes.
image


#10

Hi,

you can find the public setting on the Samba Page of the share as “Allow anonymous read-only access with a guest user”

Public

From my guess, you are currently using or have used either a PIN or Windows Hello for logging into the machine. In this case, the Pin is required to access your stored session credentials, which, unless the client is a domain member, are different than the credentials to access the server. However, clicking on the button “more choices” should give you the option of logging in with a username and password.

Please be aware, that you might need to specify the Domain for the user, notably if the username exists as a local user. You can construct the full login like the following:

Username: kevin
FQDN Master: master.internal.univention.com
Login: kevin@internal.univention.com
Shortlogin@ internal/kevin

Most likely both the login and shortlogin plus the domain password should get you in. However, if you changed some windows registry variables, it might be that only the loger login name works.

Best,

Kevin