Hostname kopano provided via SNI and hostname mail.realdomain.com provided via HTTP have no compatible SSL setup

kopano

#1

Hello, i have this issue after update to 4.4
Reason is that by default where is no ServerName variable in apache2 /etc/apache2/sites-enabled/default-ssl.conf.
I can write it directly (ServerName mail.realdomain.com) , but this file will be override by crontab. Or i can create new conf file for mail.realdomain.com.

But i’d like to solve this problem with Univention Configuration Registry. Is it possible?


#2

There is no Univention Configuration Registry variable for the ServerName. However, the UCS apache2 config contains this line: IncludeOptional /etc/apache2/ucs-sites.conf.d/*.conf. You can add a .conf file in that directory to configure the ServerName variable persistently.


#3

yeah , i did it in /etc/apache2/conf-available/servername.conf already.

ok , now i know that UCS as service doesn’t control ServerName , thank you.