HORDE Webmail zeight HTML nicht inline an

mail
german

#1

Hallo,

wenn ich in Horde (unter UCS 3.1 errata 38) eine eMail, die in HTML verfasst ist öffne, bekomme ich in einer gelben Box angezeigt:

Das sieht sehr ähnlich aus zu einer Einstellung, die laut Bug19355 geändert sein sollte

[quote]\item Über die neue \ucsUCRV{horde/mime_settings/imp/html/inline}
kann jetzt vorgegeben werden, ob HTML"=Emails per Voreinstellung direkt in
HTML"=Formatierung dargestellt werden sollen. Die Vorgabe ist \emph{yes}[/quote]

Aber irgendwie scheint das nicht zu funktionieren…
Ich habe auch bereits (da ich die Einstellung in UCR nicht gefunden habe, folgendes ausgeführt

root@testserver:~# ucr set horde/mime_settings/imp/html/inline=yes Create horde/mime_settings/imp/html/inline File: /etc/horde4/ingo/backends.d/10-ucs.php File: /etc/horde4/imp/backends.d/10-ucs.php File: /etc/horde4/imp/prefs.d/10-ucs.php File: /etc/horde4/horde/registry.d/10-ucs.php File: /etc/horde4/kronolith/conf.d/10-ucs.php File: /etc/horde4/imp/conf.d/10-ucs.php File: /etc/horde4/ingo/prefs.d/10-ucs.php File: /etc/horde4/horde/conf.d/10-ucs.php root@testserver:~# /etc/init.d/apache2 restart Restarting web server: apache2 ... waiting .
Aber es kommt immer noch die gleiche Meldung und der HTML-Teil wird nicht angezeigt.

Können Sie bitte weiterhelfen?

Danke und mit freundlichen Grüßen,
Frank Illenseer


#2

Hallo,

bitte prüfen Sie einmal das folgende Vorgehen:
Editieren der Datei /etc/horde4/imp/mime_drivers.php (z.B. mit vim). Dort passen Sie bitte ab Zeile 47 die folgende Zeile an:

/* HTML driver settings */ 'html' => array( /* NOTE: Inline HTML display is turned OFF by default. */ 'inline' => false, 'handles' => array( 'text/html' ),
‘inline’ => false zu ‘inline’ => true:

/* HTML driver settings */ 'html' => array( /* NOTE: Inline HTML display is turned OFF by default. */ 'inline' => true, 'handles' => array( 'text/html' ),

Anschließend starten Sie bitte den Apache noch einmal neu und testen das Verhalten erneut.

Mit freundlichen Grüßen,
Tim Petersen


#3

Hallo Herr Petersen,

vielen Dank für Ihren Tip! - Das hat nun funktioniert. Die HTML eMails werden nun inline angezeigt.

Nur bin ich nun etwas unsicher: Muss nur Ihr Hinweis umgesetzt werden und/oder muss auch die UCR Einstellung, die ich in meinem Post angegeben habe gesetzt werden?

Aktuell ist noch beides aktiv. Und so scheint es zu funktionieren.

Vielen Dank und mit freundlichen Grüßen,
Frank Illenseer

(PS: Dies ist auch so ein Fall, bei dem eine etwas ausführlichere Doku bzgl. was kann/muss in UCR und was muss direkt in den Dateien geändert werden, hilfreich wäre. Es ist für einen Neueinsteiger mit UCS nicht so ganz leicht ersichtlich, was in der UCR möglich ist und was nicht.)


#4

Hallo Herr Illenseer,

[quote=“F. Illenseer”]
(PS: Dies ist auch so ein Fall, bei dem eine etwas ausführlichere Doku bzgl. was kann/muss in UCR und was muss direkt in den Dateien geändert werden, hilfreich wäre. Es ist für einen Neueinsteiger mit UCS nicht so ganz leicht ersichtlich, was in der UCR möglich ist und was nicht.)[/quote]
Tatsächlich ist es so, dass es sich hierbei um eine fehlende Anpassung handelt. Normalerweise sollte das Setzen der UCR-Variable wie zuvor ausreichend sein - aufgrund von Anpassungen an den Konfigurationsdateien von Horde 4 greift die alte Konfiguration aber nicht mehr. Daher habe ich Ihnen den entsprechenden Workaround (direktes Editieren der Konfigurationsdatei) herausgearbeitet.

Ich werde dies an einem entsprechenden Bugeintrag dokumentieren, so dass dies zukünftig wieder erfolgreich per UCR-Varibable konfigurierbar sein sollte.

Mit freundlichen Grüßen,
Tim Petersen


#5

Vielen Dank für die superschnelle Antwort!

Was ich eigentlich damit sagen wollte, ist, dass es für mich als neuen Nutzer des UCS nicht so einfach ist, zu sehen, wo welche Einstellung am besten geändert wird… In der UCR oder direkt in den Konfig-Dateien…? Da steht man manchmal etwas “ratlos” da und muss Try-and-Error Verfahren anwenden…


Mail-Vorschau in Horde