HORDE Webmail - Einstellungen und Filter

mail
german

#1

Hallo,

ich teste derzeit den aktuellen UCS 3.1-1 mit dem darin enthaltenen Horde WebMail.

Wenn ich mich nun in Horde anmelde und in den Benutzereinstellungen auf “Allgemeines” -> “Persönliche Einstellungen” klicke, dann bekomme ich nur “Lade…” auf einer weißen Seite geschrieben und dann passiert nichts mehr.

Gleiches passiert auch, wenn ich auf der “Filter” Seite auf den per Deafult schon vorhandenen “Spamfilter” klicke, um dessen Eigenschaften anzuzeigen.

Können Sie dazu etwas sagen, oder ist das evtl. bekannt? - Kann das behoben werden?

Und dann noch eine Frage:
Wo kann man im Webmail einen Out-of-Office (oder auch Vacation) Filter einrichten, so dass auf eingehende Nachrichten automatisch eine Antwort mit einer Abwesenheitsnotiz versendet wird?
(Auf meinem alten Server konnte ich mit Squirrelmail dies auch unter den Filter-Regeln einstellen und aktivieren/deaktivieren.)
Es sollte so sein, dass es jeder Nutzer für sich selbst einstellen kann.

Vielen Dank und mit freundlichen Grüßen,
F. Illenseer


#2

Hallo
Ich hatte mal ein ähnliches Problem:
Könntest du mal was ausprobieren, und zwar beim Horde Login den Modus von “automatisch” auf “Traditionell” ändern. Hatte bei mir geholfen und irgendwann war das Problem weg.
Vermutete aber, das ich etwas falsch konfiguriert hatte ( oder zuviel experimentiert ).

Mit dem Abwesenheitsassitenten:
Das war unter > Benutzereinstellungen -> Sonstige > Filter > Filterregeln bearbeiten > dort müsste es einen Punkt mit “Abwesenheit” geben.

Vielleicht musst du noch das Vacation-Modul nachinstallieren, da könnte aber jemand anderes bestimmt weiterhelfen.

mfg Stefan


#3

Hallo,

Wenn ich “Traditionell” verwende, dann bekomme ich eine ganz leere Seite (also wirklich nix; hab den Quelltext anzeigen lassen).
Wenn ich “Dynamisch” auswähle, dann kann ich mich einloggen mit obigen Problemen. (Ich denke, dass der Standard “automatisch” dann wohl die Login-Art “dynamisch” auswählt.)

Also leider scheint das “Traditionell” bei mir nicht zu funktionieren.
Aber andererseits scheint es dann wirklich ein Problem zu geben, denn so wie ich das sehe sollte “Traditionell” immer funktionieren…

Ich bin für jegliche Hilfe dankbar.

MfG
F. Illenseer


#4

Hallo nochmal,

Danke, Stefan! - Ich hab nochmals in den Filterregeln geschaut un d tatsächlich den Abwesenheits-Knopf gefunden! (Ist ganz oben in der Leiste - manchmal sieht man den Wald vor lauter Bäumen nicht…) - Also das scheint genau das zu sein, was ich suchte.

Aber bei dieser Suche hab ich die anderen Buttons in der Leiste auch ausprobiert und bei “Ausschlussliste” und “Spam” passiert auch der Fehler, dass ich nur “Lade…” bekomme, wie eingangs beschrieben.

Also das ursprüngliche Problem besteht weiterhin.

MfG,
F. Illenseer


#5

Hallo,

beide Verhaltenweisen kann ich auf einem UCS 3.1-1 System derzeit nicht beobachten.
Lassen sich entsprechend auffällige Meldungen in der /var/log/horde/horde.log erkennen, wenn Sie die beschriebenen Aktionen durchführen?

Mit freundlichen Grüßen,
Tim Petersen


#6

Hallo,

nein, ich kann keine Auffälligkeiten sehen. Das Log in /var/log/horde/horde.log zeigt lediglich:

2013-04-04T16:58:03+02:00 NOTICE: HORDE [imp] Login success for my.login@company.de (Horde user my.login@company.de) [ip.ip.ip.ip] to {localhost:143 [imap]} [pid 5427 on line 176 of "/usr/share/horde4/imp/lib/Auth.php"]
2013-04-04T16:58:03+02:00 NOTICE: HORDE [horde] Login success for my.user@company.de [ip.ip.ip.ip] to horde. [pid 5427 on line 153 of "/usr/share/horde4/login.php"]

(Also nur meine erfolgreiche Anmeldung am WebMailer.)

Was ich aber sehe ist, dass in /var/log/apache2/error.log folgendes auftaucht:

[Thu Apr 04 17:07:45 2013] [error] [client ip.ip.ip.ip] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 73 bytes) in /usr/share/horde4/imp/lib/Imap/Tree.php on line 1687, referer: https://www.company.de/horde4/services/prefs.php?app=imp&ajaxui=1

Und wenn ich mit IE 10 in Horde bin, bekomme ich dann exakt zu der Zeit, zu der obige Meldung von Apache geschrieben wird, einen HTTP Fehler 500.

Können Sie mir damit weiterhelfen?

MfG,
F. Illenseer


#7

Hallo,

sie könnten einmal versuchen, den Parameter memory_limit über die UCR-Variable php/memory/limit zu erhöhen:

ucr set php/memory/limit=256 invoke-rc.d apache2 restart

Können Sie das Verhalten mit unterschiedlichen Browsern beobachten?

Mit freundlichen Grüßen,
Tim Petersen


#8

Hallo Herr Petersen,

vielen Dank für diese Info!

Ja, ich habe extra nochmals geprüft, dass ich das Verhalten sowohl in Internet Exploerer wie auch im FireFox nachstellen kann. Beides Mal bekam ich die Fehlermeldung im Apache Log.

Nach dem Setzen der UCR Variable für das memory limit scheint es nun zu gehen.
Ich kann alle Benutzereinstellungen anzeigen (das Laden dauert zwar etwas) ohne dass ein Fehler ins Log geschrieben wird.

Sollte damit nun alles behoben sein für den Produktiveinsatz, oder war das nur eine Testeinstellung?

Mit freundlichen Grüßen,
F. Illenseer


#9

Hallo,

schön, dass ich Ihnen helfen konnte.

Mit diesem Parameter können Sie konfigurieren, wieviel Arbeitspeicher ein PHP-Skript maximal verwenden darf - Horde scheint in Ihrer Umgebung für bestimmte Operationen etwas mehr als den Standard (128MB) zu benötigen. Sofern aus Ihrer Sicht nichts gegen die maximale Verwendung von 256MB spricht, können Sie die Einstellung natürlich problemlos so für den Produktivbetrieb beibehalten.

Mit freundlichen Grüßen,
Tim Petersen


#10

Danke!