Horde mnemo Notizbuch nach update auf UCS 4.04 Fehlerhaft

mail
german

#1

Hallo zusammen,

nach dem update auf die aktuelle Version von UCS bzw. Horde Groupware 5.2.7 ist bzw. war kein login in Horde mehr möglich.
Erst nach deaktivieren von mnemo in der UCS-Variabel war ein login in Horde wieder möglich.
Das Notizbuch ist damit natürlich deaktiviert.

Die Fehler Beschreinung von Horde in kurzform :

[Bug]
Missing required connection parameter(s).

  1. Horde_Core_Block_Layout_View->toHtml() /usr/share/horde/services/portal/index.php:35
  2. Horde_Core_Block->getContent() /usr/share/php/Horde/Core/Block/Layout/View.php:98
  3. Horde_Core_Block->_call() /usr/share/php/Horde/Core/Block.php:175
  4. Mnemo_Block_Summary->_content() /usr/share/php/Horde/Core/Block.php:278
  5. Mnemo::listMemos() /usr/share/horde/mnemo/lib/Block/Summary.php:59
  6. Mnemo_Factory_Driver->create() /usr/share/horde/mnemo/lib/Mnemo.php:80
  7. Mnemo_Driver_Sql->__construct() /usr/share/horde/mnemo/lib/Factory/Driver.php:73
    [/Bug]

In Version Horde v5.2.6
wurde folgende Änderung vorgenommen:

[mjr] Fix using custom SQL configuration parameters.

möglicherweise liegt hier der Fehler vor.

Kann dies jemand bestätigen?

Viele Grüße

Hallo nochmal das Notizbuch funktioniert wieder,
durch setzen von

* $conf[menu][import_export] = false ;

/etc/horde/mnemo/conf.php

Nun ist zwar kein export mehr möglich, aber das Notizbuch funktioniert wieder.

Warum?
Keine Ahnung!
Hilft vielecht jemandem weiter.

Grüße


#2

Hallo,

ich kann das Problem auf meinem eigenen Server (nur UCS, Horde und Etherpad via App Center) nicht adhoc reproduzieren.

Viele Grüße,
Dirk Ahrnke


#3

Hallo,

bei einem update von horde auf die aktuelle Version auf einem andern UCS-Server trat dieser Fehler nicht auf.

Beide Servern haben jedoch einen Fehler gemeinsam,

HTML-Mails sind nicht mehr zu erstellen.

Der html-editor wird beim erstellen einer neuen Nachricht nicht geladen.(grauer Hintergrund, kein editieren möglich).


#4

[quote=“tom123”]
Der html-editor wird beim erstellen einer neuen Nachricht nicht geladen.(grauer Hintergrund, kein editieren möglich).[/quote]

Das kann ich bestätigen. Sieht auf den ersten Blick nach dem in [horde] Composing / forwarding email beschrieben Problem aus.


#5

Da gibt es wohl einen Versionskonflikt

/horde/js/ckeditor/plugins/pasteattachment/plugin.js
/usr/share/horde/imp/js/ckeditor/pasteattachment.js

Dateien kopiert, jetzt geht html-edit wieder. (Sever1), Server2 probiere ich noch aus


UCS 4.1 mit Horde HTML Mail erstellen nicht möglich
#6

Hallo,

können Sie bitte den Pfad überprüfen?
Es wäre dann sicher sinnvoll, das Problem im Univention-Bugzilla (forge.univention.org) einzukippen.

Viele Grüße,
Dirk Ahrnke


#7

Hallo,

das ist die Fehlerausgabe von Firefox im debug Modus unter horde:

uncaught exception: [CKEDITOR.resourceManager.load] Resource name “pasteattachment” was not found at “http://xxx.xxx.xxx.xxx/horde/js/ckeditor/plugins/pasteattachment/plugin.js?t=B5GJ5GG”.

Die Datei “plugin.js” wird an obiger Stelle erwartet aber nicht gefunden.

Zu finden ist sie, wenn auch unter andrem Namen
/usr/share/horde/imp/js/ckeditor/pasteattachment.js

Umbenennen und kopieren nach
/horde/js/ckeditor/plugins/pasteattachment/plugin.js

Hat bei beiden Servern zum Erfolg geführt, bis jetzt ohne Nebenwirkungen

Da ist halt was verdreht worden.

Grüße