Having difficulty setting IPv6 addresses [owncloud]

Hey, I’m not terribly familiar with how ipv6 works, and need some help. I spooled up an owncloud vm, configured it how I like, but I need it to have a global ipv6 address so I can route it through cloudflare, and append it to my domain.

The problem is, my router is using open-wrt, and I have it configured to use DHCPV6-PD, which requires stateful ipv6 address allocations. The webinterface for owncloud only has an option for SLAAC, and when I try to enter in static addresses, it just refuses to connect, since the router doesn’t accept static addresses for DHCPv6.

I genuinely don’t know what to do, and need some guidance.

1 Like

Okay, I fixed it. Turns out DHCPv6, and SLAAC are incompatible with each other, since obviously one is stateless, and the other is stateful. So I changed router settings.

It’s just weird, since my ILO port on my server was using SLAAC, and had no issues getting an assignment. Now it does, but it’s not a huge deal.