Guacamole install problem

guacamole

#1

UCS: version 4.4-0 errata 143
Guacamole: Version 0.9.13-univention14

I have two servers running the same setup with different domains.

When I originally install Guacamole from the app center on both servers last month, everything worked well. I was able to set up SSH connections and RDP connections to ‘hostname=xxx.xxx.xxx.xxx’ Windows 7 workstations.

I believe that after the Rocketchat SSO ‘upgrade’ on both servers, the Guacamole services have stopped working on both. The symptoms:

  1. Server 1, all attempts to login to RDP via Guacamole were met with “Invalid Login” even though they previously worked. The same credentials continue to work for Kopano, etc;
  2. Server 2, previously working connections successfully logged into Guacamole, but, then there is a long pause ‘waiting for response’, and then You have been disconnected. The previously working RDP connection now fails. The same credentials continue to work for Kopano, etc;

I can successfully RDP into the targeted workstations when on the LAN, so, I don’t believe that there is a Windows configration issue.

For Server 1, I attempted to follow notes seen here to uninstall the Guacamole, remove the LDAP schema entries, and reinstall. This is now creating a different problem. I can no longer reinstall Guacamole. The error is:

“Registering schema file /usr/share/univention-appcenter/apps/guacamole/guacamole.schema failed”

Thoughts and suggestions?
Thank you!
John


#2

In the alternative, are there steps I can take to clear any reference to Guacamole in my installation and start fresh WITHOUT a complete server rebuild from scratch?