Grub Fehlermeldungen beim Kernel Update

german

#1

Ich möchte eine Zarafa Installation auf die Version 7 updaten. Vorher müssen aber die Pakete
libboost-filesystem1.35.0, libboost-system1.35.0 installiert werden. Geht aber nicht. Es kommt
diese Fehlermeldung:
(Univention Version: 2.4-0, Kernel: 2.6.32-ucs11-amd64)

apt-get install libboost-filesystem1.35.0

[code]Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein… Fertig
libboost-filesystem1.35.0 ist schon die neueste Version.
Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
libapt-pkg-perl
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
4 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0B Plattenplatz zusätzlich benutzt.
Richte linux-image-2.6.32-ucs21-amd64 ein (2.6.32-24.21.201011241525) …
Running depmod.
Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.32-ucs21-amd64
Running /usr/sbin/update-grub.
Searching for GRUB installation directory …
No GRUB directory found.
To create a template run ‘mkdir /boot/grub’ first.
To install grub, install it manually or try the ‘grub-install’ command.

Warning, grub-install is used to change your MBR.

User postinst hook script [/usr/sbin/update-grub] exited with value 1
dpkg: Fehler beim Bearbeiten von linux-image-2.6.32-ucs21-amd64 (–configure):
Unterprozess post-installation script gab den Fehlerwert 1 zurück
Richte linux-image-2.6.32-ucs35-amd64 ein (2.6.32-30.35.201102011556) …
Running depmod.
Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.32-ucs35-amd64
Running /usr/sbin/update-grub.
Searching for GRUB installation directory …
No GRUB directory found.
To create a template run ‘mkdir /boot/grub’ first.
To install grub, install it manually or try the ‘grub-install’ command.

Warning, grub-install is used to change your MBR.

User postinst hook script [/usr/sbin/update-grub] exited with value 1
dpkg: Fehler beim Bearbeiten von linux-image-2.6.32-ucs35-amd64 (–configure):
Unterprozess post-installation script gab den Fehlerwert 1 zurück
Richte linux-image-2.6.32-ucs44-amd64 ein (2.6.32-35~ucs1.44.201107011448) …
Running depmod.
Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.32-ucs44-amd64
Running /usr/sbin/update-grub.
Searching for GRUB installation directory …
No GRUB directory found.
To create a template run ‘mkdir /boot/grub’ first.
To install grub, install it manually or try the ‘grub-install’ command.

Warning, grub-install is used to change your MBR.

User postinst hook script [/usr/sbin/update-grub] exited with value 1
dpkg: Fehler beim Bearbeiten von linux-image-2.6.32-ucs44-amd64 (–configure):
Unterprozess post-installation script gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von univention-kernel-image-2.6.32:
univention-kernel-image-2.6.32 hängt ab von linux-image-2.6.32-ucs44-amd64; aber:
Paket linux-image-2.6.32-ucs44-amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von univention-kernel-image-2.6.32 (–configure):
Abhängigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
linux-image-2.6.32-ucs21-amd64
linux-image-2.6.32-ucs35-amd64
linux-image-2.6.32-ucs44-amd64
univention-kernel-image-2.6.32
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Sub-process /usr/bin/dpkg returned an error code (1)[/code]


#2

Hallo,

es scheint hier eher ein Problem beim Einrichten der Kernel zu bestehen. Die Einrichtung des Kernels schlägt fehl, da keine Grub-Installation gefunden werden kann - ist auf diesem System eventuell LILO, o.ä. installiert? Sollte Grub installiert sein, könnten Sie einmal verifizieren, dass das Verzeichnis /boot korrekt gemounted ist?

Könnten Sie uns darüberhinaus einmal die UCS-System des Systems mitteilen?

ucr search version

Es scheint, als bestünde der inkonsistente Paketstatus schon länger (erkennbar daran, dass auch ältere Kernel-Pakete zu Einrichtung vorgemerkt sind).

Mit freundlichen Grüßen,
Tim Petersen


#3

Ich versehe nicht was da wieder schief gegangen ist. Univention ist ganz normal installiert worden mit zarafa-4-ucs und das wars. Und jetzt nach einigen Monaten Laufzeit schlägt das Update fehl …


#4

Hallo,

wie von meinem Kollegen bereits erläutert besteht dieses Problem vermutlich schon etwas länger (das Kernel Paket “linux-image-2.6.32-ucs21” wurde bereits Ende 2010 veröffentlicht). Um die Ursache untersuchen zu können, lassen Sie uns bitte die von meinem Kollegen angefragten Informtionen zukommen. Außerdem könnten Sie z.B. anhand der dpkg und updater Logdateien (/var/log/dpkg.log*, /var/log/univention/updater.log*, /var/log/univention/actualise.log*) nachvollziehen wann das Problem inital aufgetreten ist und ggf. wodurch es ausgelößt wurde.

Mit freundlichen Grüßen
Janis Meybohm