GRUB displays Error: Disk filter writes are not supported


#1

Hello everyone

After upgrade to ucs-174 kernel “errata 112,113” server started to show GRUB Error displays: Disk filter writes are not supported in boot
I did a search, and one way to solve this is described below:
To work around this issue, perform the Following steps:

 Open the file in an editor /etc/grub.d/10_linux
 Disable the quick_boot option by setting it to zero:
 quick_boot = "0"
 Update the GRUB boot loader:
 $ Sudo update-grub

The problem is that this file 10_linux is already configured with quick_boot = “0”
Do you have another clue of how to solve this?

Thank you,
Michael C. Voigt


#2

Same hre, better to fill a bug report, isn’t it?


#3

Hi,

[quote=“mcvoigt”]After upgrade to ucs-174 kernel “errata 112,113” server started to show GRUB Error displays: Disk filter writes are not supported in boot
[/quote]

Are you using software RAID via mdadm?
It looks like GRUB is unable to write to filesystems located on a software RAID. One possibility for the write request is the “savedefault” option introduced in errata 82.
To disable “savedefault” execute the following command:

ucr set grub/savedefault=false

Afterwards GRUB should be able to boot without manual key press.

Regards

Sönke Schwardt-Krummrich


#4

Hi Sönke, tanks for your help
Yes, I’m using software RAID via mdadm.
I suggested setting, and I was successful. I solved my problem.

Regards,

Michael C. Voigt


#5

Hi!

[quote=“mcvoigt”]Hi Sönke, tanks for your help
Yes, I’m using software RAID via mdadm.
[/quote]
Thanks for your confirmation. The neccessary steps for avoiding the manual keypress are now documented in our SDB: http://sdb.univention.de/1357

Regards

Sönke Schwardt-Krummrich