Group Policy - "The security ID structure is invalid"

When creating Group Policy Objects, I am getting the following error

ErrorCode 1337
ErrorDescription The security ID structure is invalid

I tried to run samba-tool ntacl sysvolreset, but python crashes:

root@dc1:~/sysvol/Policies# samba-tool ntacl sysvolreset
ERROR(<class 'TypeError'>): uncaught exception - 'NTSTATUSError' object is not subscriptable
  File "/usr/lib/python3/dist-packages/samba/netcmd/", line 186, in _run
    return*args, **kwargs)
  File "/usr/lib/python3/dist-packages/samba/netcmd/", line 415, in run
  File "/usr/lib/python3/dist-packages/samba/provision/", line 1788, in setsysvolacl
    _setntacl(os.path.join(root, name))
  File "/usr/lib/python3/dist-packages/samba/provision/", line 1780, in _setntacl
    logger=logger, resume_on_error=resume_on_error)
  File "/usr/lib/python3/dist-packages/samba/provision/", line 1618, in set_nt_acl_wrapper
    err_value = ctypes.c_uint32(error[0]).value

I’m using RSAT under Windows 10

Has anyone seen this and/or resolved it?


Has anyone run into this issue and solved it?