'Give root password for maintenance' beim Booten

german

#1

Hallo,

der neu aufsetzte DC läuft gut mit Version 4.1-1 errata 136. Wird der Rechner jedoch neugestartet (Reboot oder Neustart nach Ausschalten) erscheint kurz der Bildschirm mit dem Univention-Logo und dann die Meldung:

Loading, please wait... Give root password for maintenance (or type Control-D to continue)
Einloggen mit dem root Passwort funktioniert an dieser Aufforderung genau wie auch im Betrieb über ssh. Mit dem Passwort ist soweit alles i.O.
Mit CRTL-D wird der Bootvorgang dann auch korrekt zu Ende geführt.

Wie kommt das? Und noch wichtiger: wie bringe ich den Rechner dazu, ohne Eingabe zu booten?

Gruß
Uwe


Phpmyadmin installieren
Phpmyadmin installieren
#2

Moin,

Meine allererste Vermutung ist, dass Sie über Grub einen Eintrag booten, der »single« in der Kernel-Kommandozeile stehen hat. Das sind out of the box diejenigen, deren Titel »recovery« enthält. Schauen Sie also bitte mal bei einem Reboot genau hin, welcher Eintrag in Grub ausgewählt ist und gebootet wird. Mit einem Druck auf »e« können Sie den Eintrag editieren; relevant ist die Zeile, die mit »linux …« beginnt.

Ist das der Fall: einfach einen anderen Eintrag booten und im System dann prüfen, welcher Eintrag bei Grub per default gebootet wird (UCR-Variable »grub/default«).

Falls das nicht der Fall sein sollte, dann hier weiter :slight_smile:

Mehr Meldungen erscheinen in dem Moment nicht?

Bitte probieren Sie noch einen Reboot, loggen sich an dem Prompt ein, und geben Sie dann mal »dmesg« ein. Die Ausgaben davon bitte auch einmal hier posten.

Weiterhin probieren können Sie: die Grub-Konfiguration mit »update-grub« neu bauen; in der Mainenance-Shell das Root-Dateisystem mit »fsck« prüfen lassen.

Gruß,
mosu


#3

Hallo,

erstmal zu Ihren Vorschlägen:
Grub bootet korrekt den ersten Eintrag, ohne ‘single’ und ‘recovery’.
Die Variable ‘grub/default’ ist nicht angelegt, bzw. wird in der UMC leer angezeigt

Weitere Meldungen beim Systemstart sind keine zu sehen, dafür ist mir aber beim Shutdown eine Meldung aufgefallen:
[FAIL] File system check failed. A log is being saved in /var/log/fsck/checkfs if that location is writeable.
In checkfs sowie in chekcroot findet sich aber kein Fehler, nur ‘clean’ und auch fsck in der Maintenance-Konsole liefert keinen Fehler bezüglich des Root-Dateisystems.

Hierüber bin ich aber auf einen Fehler bei der extern angeschlossenen USB-Platte, die für die Bareos-Sicherung zuständig ist. Stecke ich diese aus und entferne den zugehörigen Eintrag in der fstab, dann bootet der Server korrekt ohne Meldung und ohne Eingriff.

Den entsprechende Eintrag in der fstab habe ich nun von:UUID=a52368e2-ce3a-4215-8933-ced08183f896 /var/lib/bareos/storage ext4 defaults,user_xattr 0 2zuUUID=a52368e2-ce3a-4215-8933-ced08183f896 /var/lib/bareos/storage ext4 defaults,users 0 0geändert.

Damit wird ja die Prüfung unterbunden und der Server startet normal. Bei der Option user_xattr bin ich aber nicht sicher, ob diese nicht doch benötigt wird.

Gruß
Uwe