Gitlab: can't archive or delete projects

Hello all,

i have installed Gitlab with the ucs appcenter. I have added some projects for testing, configured everything. So now i would delete these all testprojects, but if i delete they, i get an 500 Error in the webbrowser. I found a lot of things for many years with simiar problems. But no solution, ok no easy solution. The discus about coding over the api to delete the projects and other things… i’am not a coder :wink:

What do you need that you can help me?

UCS 4.4-4 and Gitlab 12.1.0

Thanks and best Regards

I get the same error 500 if i click on any option as root/Administrator to save. Can anyone tell me were i can find the logs to see some error messages? I found this:


with this message:

{"correlation_id":"FkhkLNpQu22","duration":0.087726948,"host":"","level":"info","method":"POST","msg":"access","proto":"HTTP/1.1","referer":"","remoteAddr":"[2001:470:1f0b:569:56d5:721b:9aaa:f4e9]:51636","remoteIp":"2001:470:1f0b:569:56d5:721b:9aaa:f4e9","status":500,"system":"http","time":"2020-07-05T21:56:18+02:00","uri":"/gitlab/admin/application_settings/ci_cd","userAgent":"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36","written":2926}

Ok, i’ve setuped a testdomain with gitlab from appcenter, and it works perfectly, no errors. So i deinstalled gitlab from my server, and installed it again, but all data’s were there again. So how can i remove gitlab completly from my ucs server? Really all, all Projects, all settings…?

According to the app ini all data, logs and config is stored below /var/lib/univention-appcenter/apps/gitlab/. So deleting this folder while the app is not installed will result in a clean installation of it the next time.

Very thanks. I’ve deinstalled and deleted the folder and the backupfolder. I found an Overlay2 Folder with gitlabthings, is this also to delete?

Here an example:


no, I don’t think this is necessary (although I must say that I have never worked with the Gitlab app, or a selfhosted Gitlab in general). What you see there is the actual file system of the app, reinstalling should imho create a new container anyways.

If you want to get rid of container images no longer required this should rather be done be running docker system prune (although I don’t know if that is actually recommended by Univention).

Reinstallation has worked fine.