[Gelöst] Opsi4Ucs: memtest kann nicht ausgeführt werden

ucs-4-1
german
opsi

#1

Ich benutze die Opsi-Installation auf meinem UCS 4.1 Server. Installiert wurde Opsi durch das Opsi4Ucs-Paket innerhalb von UCS.

Leider kann ich nun aber nicht das memtest-Programm über Opsi ausführen lassen. Auf dem Client kommt folgende Meldung:

Could not find kernel image: memtest86+-5.01

Vorhanden ist die Datei aber im entsprechenden Verzeichnis:


root@ucs002254:/tftpboot/linux# ls -ls
insgesamt 198772
   16 -rw-rw-r-- 1 opsiconfd opsifileadmins        12372 Aug  8 13:37 chain.c32
    0 lrwxrwxrwx 1       996 OPSI Depot Servers       14 Aug  8 13:37 install -> vmlinuz-4.12.1
    0 lrwxrwxrwx 1       996 OPSI Depot Servers       11 Aug  8 13:37 install64 -> install-x64
    0 lrwxrwxrwx 1       996 OPSI Depot Servers       18 Aug  8 13:37 install-x64 -> vmlinuz-x64-4.12.1
  148 -rw-rw-r-- 1 opsiconfd opsifileadmins       150024 Aug 23  2013 memtest86+-5.01
   52 -rw-rw-r-- 1 opsiconfd opsifileadmins        52272 Aug  8 13:37 menu.c32
87400 -rw-rw-r-- 1 opsiconfd opsifileadmins     89490540 Aug  8 13:37 miniroot-20170720.bz2
    0 lrwxrwxrwx 1       996 OPSI Depot Servers       21 Aug  8 13:37 miniroot.bz2 -> miniroot-20170720.bz2
89868 -rw-rw-r-- 1 opsiconfd opsifileadmins     92018687 Aug  8 13:37 miniroot-x64-20170720.bz2
    0 lrwxrwxrwx 1       996 OPSI Depot Servers       25 Aug  8 13:37 miniroot-x64.bz2 -> miniroot-x64-20170720.bz2
   16 -rw-rw-r-- 1 opsiconfd opsifileadmins        15710 Aug  8 13:37 pxelinux.0
    4 drwxrwxr-x 2 opsiconfd opsifileadmins         4096 Dez 22 08:30 pxelinux.cfg
10892 -rw-rw-r-- 1 opsiconfd opsifileadmins     11151920 Aug  8 13:37 vmlinuz-4.12.1
10372 -rw-rw-r-- 1 opsiconfd opsifileadmins     10620480 Aug  8 13:37 vmlinuz-x64-4.12.1

Was muss ich jetzt noch anpassen, bzw. welches Logfile könnte mir Aufschluß geben, warum das memtest nicht ausgeführt werden kann

Als Hinweis: Das hwiventory-Paket konnte ich erfolgreich für den Client festlegen und ausführen. Die Daten wurden in Opsi auch gespeichert

Die Einstellungen zu dem TFTP-Server sind folgende (nano /etc/default/atftpd):

USE_INETD=true
OPTIONS="--daemon --port 69 --tftpd-timeout 300 --retry-timeout 5     --mcast-port 1758 --mcast-addr 239.239.239.0-255 --mcast-ttl 1 --maxthread 100 --verbose=5  /tftpboot"

#2

tftproot sollte eigentlich /var/lib/univention-client-boot sein. Funkionieren sollte aber auch /tftproot/linux. Was ist in /etc/inetd.conf konfiguriert?

cat /etc/inetd.conf

EDIT: Vermutlich fehlt in /var/lib/univention-client-boot der Symlink zu memtest

ls -l /var/lib/univention-client-boot

#3

Danke für deine Rückmeldung. Hier die gewünschten Infos:

root@ucs002254:~# cat /etc/inetd.conf
# /etc/inetd.conf:  see inetd(8) for further informations.
#
# Internet superserver configuration database
#
#
# Lines starting with "#:LABEL:" or "#<off>#" should not
# be changed unless you know what you are doing!
#
# If you want to disable an entry so it isn't touched during
# package updates just comment it out with a single '#' character.
#
# Packages should modify this file by using update-inetd(8)
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
#:INTERNAL: Internal services
#discard                stream  tcp     nowait  root    internal
#discard                dgram   udp     wait    root    internal
#daytime                stream  tcp     nowait  root    internal
#time           stream  tcp     nowait  root    internal

#:STANDARD: These are standard services.

#:BSD: Shell, login, exec and talk are BSD protocols.

#:MAIL: Mail, news and uucp services.

#:INFO: Info services

#:BOOT: TFTP service is provided primarily for booting.  Most sites
#       run this only on machines acting as "boot servers."

#:RPC: RPC based services

#:HAM-RADIO: amateur-radio services

#:OTHER: Other services
tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd --tftpd-timeout 300 --retry-timeout 5 --verbose=5 /var/lib/univention-client-boot

kerberos-adm    stream  tcp     nowait  root    /usr/sbin/tcpd /usr/lib/heimdal-servers/kadmind
#krb_prop       stream  tcp     nowait  root    /usr/sbin/tcpd /usr/sbin/hpropd
kshell  stream  tcp     nowait  root    /usr/sbin/tcpd /usr/lib/heimdal-servers/rshd -k
time            stream  tcp4     nowait  root    internal
time            stream  tcp6     nowait  root    internal

und dann noch

root@ucs002254:~# ls -l /var/lib/univention-client-boot
insgesamt 0
lrwxrwxrwx 1 root root 25 Nov  8 09:14 chain.c32 -> /tftpboot/linux/chain.c32
lrwxrwxrwx 1 root root 23 Nov  8 09:14 install -> /tftpboot/linux/install
lrwxrwxrwx 1 root root 27 Nov  8 09:14 install-x64 -> /tftpboot/linux/install-x64
lrwxrwxrwx 1 root root 24 Nov  8 09:14 menu.c32 -> /tftpboot/linux/menu.c32
lrwxrwxrwx 1 root root 28 Nov  8 09:14 miniroot.bz2 -> /tftpboot/linux/miniroot.bz2
lrwxrwxrwx 1 root root 32 Nov  8 09:14 miniroot-x64.bz2 -> /tftpboot/linux/miniroot-x64.bz2
lrwxrwxrwx 1 root root 26 Nov  8 09:12 pxelinux.0 -> /tftpboot/linux/pxelinux.0
lrwxrwxrwx 1 root root 28 Nov  8 09:12 pxelinux.cfg -> /tftpboot/linux/pxelinux.cfg


#4

Na es ist so wie es mir gedacht habe. Also sollte es reichen den Symlink manuell anzulegen:

ln -s /tftpboot/linux/memtest86+-5.01 /var/lib/univention-client-boot/

#5

Hallo,

so wie es aussieht, ist das schon gelöst. Ein Hinweis für spätere Leser: Fragen rund um opsi auch auf UCS bitte unter https://forum.opsi.org/ stellen.

Gruß, Nico.