Fwbuilder - Installation

german

#1

Hallo,

ich habe auf einem UCS 1.3-2-0 versucht, fwbuilder zu installieren, nachdem ich auf OOffice2 und KDE 3.5 upgedatet habe. Das Installationsprotokoll sagt dazu:

The following packages have unmet dependencies:
fwbuilder: Depends: libqt3c102-mt (>= 3:3.3.3) but it is not going to be installed
Depends: fwbuilder-linux but it is not going to be installed or
fwbuilder-backend

Nachdem ich daraufhin mal libqt3c102-mt installiert hatte, wurde (ohne Vorwarnung) Univention-KDE, Univention-GDM sowie Univention-oofice2 deinstalliert, was sich aber glücklicherweise von der Konsole (ich arbeite sonst eigentlich nur mit der Paketverwaltung) wieder herstellen liess.

Bis jetzt habe ich herausgefunden, dass das Paket libqt3-mt wohl die neuere Version ist (3.3.7), aber die Installation von fwbuilder will trotzdem nicht gelingen.

Ich glaube, es fehlen die entsprechenden Pakete libqt3-mt-dev sowie libqt3-headers, damit die Installation von fwbuilder funktioniert, da bei der Installation der Verweis auf ein fehlendes qmake gemacht wurde, was wohl in dem entsprechenden ibqt3-mt-dev vorhanden ist.

Sind diese Pakete für UCS verfügbar?
Oder ist möglich, das libqt3-mt - Paket von UCS gegen die Original Debian Version auszutauschen, damit die fehlenden Pakete zusätzlich installiert werden können?

Gruß und danke

Dietmar


#2

Hallo,

man kann sich eigene Pakete für UCS bauen.
Nachzulesen hier [url]Zsh]

MfG

Ingo Ebel


#3

Hallo,

[quote=“dietmar”]The following packages have unmet dependencies:
fwbuilder: Depends: libqt3c102-mt (>= 3:3.3.3) but it is not going to be installed
[…]
[/quote]
Dieses Paket ist unter apt.univention.de/addons/ bereits verfügbar oder können kurzfristig dort abgelegt werden.

Dies ist nicht zu empfehlen, da die Installation von Original-Debian-Paketen erfahrungsgemäß zu weiteren Problem wegen nicht abgestimmten Paketversionen kommt.

Mit freundlichen Grüßen,

Wolf Wiegand


#4

Hallo,
welche Pakete genau benötigt werden, weiss ich noch nicht, werde m,ich dann aber
melden. Ich hatte, wenn ich mich rechtig erinnere, unter KDE3.4 mal den fwbuilder in einer älteren Version (direkt von debian.org) installiert, und jetzt mit dem upgedateten System kam eben diese Fehlermeldung.
Dann habe ich mir eine aktuelle Version von fwbuilder.org heruntergeladen, und versucht, diese zu installieren. Das Installationsscript brach dann mit dem Fehler ab, dass “qmake” nicht gefunden werden kann.
Soweit ich bis jetzt weiss, ist “qmake” wohl in dem Paket libqt3-mt-dev enthalten, bin mir aber nicht sicher, ob das Paket alleine für die Installation reicht.
Gruß
Dietmar


#5

Hallo,
für das aktuelle Paket fwbuilder (2.1.8-1) (unstable) von Debian werden folgende Pakete benötigt:

libc6 (>= 2.3.6-6) [i386]
libgcc1 (>= 1:4.1.1-12)
libqt3-mt (>= 3:3.3.7)
libsnmp9 (>= 5.2.3)
libssl0.9.8 (>= 0.9.8c-1)
libstdc++6 (>= 4.1.1-12)
libxml2 (>= 2.6.27)
libxslt1.1 (>= 1.1.18)

Gruß
Dietmar


#6

Hallo,

[quote=“dietmar”]für das aktuelle Paket fwbuilder (2.1.8-1) (unstable) von Debian werden folgende Pakete benötigt:

libc6 (>= 2.3.6-6) [i386] […][/quote]
Zu diesem Paket stehen keine aktualisierten Versionen zur Verfügung. Bitte versuchen Sie, das Paket fwbuilder aus den Quellen neu zu bauen, unter [Zsh) finden Sie eine kurze Anleitung dazu.

Mit freundlichen Grüßen,

Wolf Wiegand


#7

Hallo,
danke für die Info,
ich bekomme aber folgende Meldungen:

E: Build-Depends Abhängigkeit für fwbuilder kann nicht befriedigt werden, da Paket dbs nicht gefunden werden kann.

Habe dann dbs installiert, danach kam folgende Meldung:

Paket automake ist nicht verfügbar, wird aber von einem anderen
Paket referenziert. Das kann heißen, dass das Paket fehlt, dass es veraltet
ist oder nur aus einer anderen Quelle verfügbar ist.
E: Paket automake hat keinen Installationskandidaten
E: Konnte die Build-Depends-Abhängigkeit für fwbuilder nicht erfüllen: automake

automake ist aber in verschiedenen Versionen installiert, so dass ich jetzt nicht weiter weiss.

Ist es möglich, das entsprechende qt3-devel Paket zur Verfügung zu stellen.
Lt. fwbuilder.org müssten dan eigentlich alle Pakete verfügbar sein.

Besten Dank im Voraus
Dietmar


#8

Hallo,

da in UCS 2 Versionen von Automake vorhanden sind muss man diese genau angeben:

apt-get install automake1.7

sollte das Problem beheben.

Gruß Ingo


#9

Hallo,
danke für die Info.
laut meiner UCS Paketverwaltung sind allerdings
automake1.6, automake1.7 sowie automake1.9 installiert.

Muss/darf denn vielleicht nur eine Version installiert sein?

Wenn ja, welche nimmt man dann am besten?

Gruß
Dietmar


#10

Hallo,
ist es denn möglich, kurzfristig das Paket qt3-dev zur Verfügung zu stellen?
Danke im Voraus
Dietmar


#11

Hallo,

[quote=“dietmar”]E: Paket automake hat keinen Installationskandidaten
E: Konnte die Build-Depends-Abhängigkeit für fwbuilder nicht erfüllen: automake [/quote]
Das Paket automake ist momentan nicht für UCS verfügbar. Bei den Paketen automake1.X handelt es sich nicht um verschiedene Versionen des Pakets, sondern um jeweils andere Pakete.

qt3-dev wird bei UCS/Debian durch das Paket libqt3-dev bereitgestellt. Dieses Paket ist für die KDE 3.5-Umgebung derzeit leider nicht für UCS verfügbar.

MIt freundlichen Grüßen,

Wolf Wiegand


#12

Schade,
trotzdem danke für die Info.
Gruß
Dietmar


#13

Nachdem das -dev Paket ja nicht zur Verfügung gestellt wird und ich jetzt auch nicht mehr weiter weiss, eine Frage:

Gibts denn irgendeiene lauffähige GUI für iptables auf dem UCS System mit KDE3.5?

Irgendwas fehlt immer in der entsprechenden Version, ist das gewollt?

Gruß
Dietmar


#14

Hallo,

Ich habe fwbuilder aus Sarge für UCS mit KDE 3.5 bauen können. Die Pakete liegen unter informatik.uni-oldenburg.de/ … fwbuilder/ , probier bitte mal aus, ob die so bei Dir funktionieren. Zur Installation kannst Du folgenden Eintrag in /etc/apt/sources.list verwenden:

deb http://www.informatik.uni-oldenburg.de/~a310015/fwbuilder/ ./

Gruß, flow


#15

Hallo flow,

scheint zu funktionieren - super, genial!!!
Vielen Dank

Dietmar


#16

Hallo,

mit den nun zur Verfügung stehenden devel-Paketen vom 11.05.2007 war es mir sogar möglich, die aktuellste Version von fwbuilder (2.1.11) aus den sourcen zu installieren.

Gruß
Dietmar